package/gnu-efi: bump to version 3.0.15
Changes from 3.0.14 to 3.0.15: 8b018e67212957de176292f95718df48f49a418b Bump revision to VERSION = 3.0.15 803b49c40bb0b720b90d9c31d372911f1b946aa7 */*.S: add non-executable GNU stack marking on ELF-linux 2ed6486834634130fe7bc9b8803b0113767fc7c1 lib/Makefile: add .o file dependency on libsubdirs targets 6b28563584edd08ab9c94a746a8061434c165837 Handle __mips64 The patch 0002-inc-efi-.h-also-support-__mips64-to-recognize-mips64.patch is dropped as it is equivalent to upstream commit 6b28563584edd08ab9c94a746a8061434c165837 ("Handle __mips64") Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com> Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
This commit is contained in:
parent
f28cccb146
commit
a706593282
@ -1,60 +0,0 @@
|
|||||||
From 2c0ad0d7547558be59ef10dd289e619373341704 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
|
|
||||||
Date: Thu, 21 Jul 2022 09:47:49 +0200
|
|
||||||
Subject: [PATCH] inc/efi*.h: also support __mips64 to recognize mips64
|
|
||||||
|
|
||||||
gcc built-in define for the MIPS64 architecture is __mips64, not
|
|
||||||
__mips64__, so the current condition did not match for gcc. See
|
|
||||||
https://gcc.gnu.org/git/?p=gcc.git;a=blob;f=gcc/config/mips/mips.h;h=47aac9d3d61245c4d3df5dbd0bbcd833190de7c3;hb=2d280e7eafc086e9df85f50ed1a6526d6a3a204d#l431
|
|
||||||
in the gcc source.
|
|
||||||
|
|
||||||
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
|
|
||||||
Upstream: https://sourceforge.net/p/gnu-efi/mailman/message/37683797/
|
|
||||||
---
|
|
||||||
inc/efi.h | 2 +-
|
|
||||||
inc/efilib.h | 2 +-
|
|
||||||
inc/efirtlib.h | 2 +-
|
|
||||||
3 files changed, 3 insertions(+), 3 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/inc/efi.h b/inc/efi.h
|
|
||||||
index 43c832e..b193932 100644
|
|
||||||
--- a/inc/efi.h
|
|
||||||
+++ b/inc/efi.h
|
|
||||||
@@ -48,7 +48,7 @@ Revision History
|
|
||||||
#include "aarch64/efibind.h"
|
|
||||||
#elif defined (_M_ARM) || defined(__arm__)
|
|
||||||
#include "arm/efibind.h"
|
|
||||||
-#elif defined (_M_MIPS64) || defined(__mips64__)
|
|
||||||
+#elif defined (_M_MIPS64) || defined(__mips64__) || defined(__mips64)
|
|
||||||
#include "mips64el/efibind.h"
|
|
||||||
#elif defined (__riscv) && __riscv_xlen == 64
|
|
||||||
#include "riscv64/efibind.h"
|
|
||||||
diff --git a/inc/efilib.h b/inc/efilib.h
|
|
||||||
index 9f748ad..a2b39b2 100644
|
|
||||||
--- a/inc/efilib.h
|
|
||||||
+++ b/inc/efilib.h
|
|
||||||
@@ -31,7 +31,7 @@ Revision History
|
|
||||||
#include "aarch64/efilibplat.h"
|
|
||||||
#elif defined (_M_ARM) || defined(__arm__)
|
|
||||||
#include "arm/efilibplat.h"
|
|
||||||
-#elif defined (_M_MIPS64) || defined(__mips64__)
|
|
||||||
+#elif defined (_M_MIPS64) || defined(__mips64__) || defined(__mips64)
|
|
||||||
#include "mips64el/efilibplat.h"
|
|
||||||
#elif defined (__riscv) && __riscv_xlen == 64
|
|
||||||
#include "riscv64/efilibplat.h"
|
|
||||||
diff --git a/inc/efirtlib.h b/inc/efirtlib.h
|
|
||||||
index 8643061..518859e 100644
|
|
||||||
--- a/inc/efirtlib.h
|
|
||||||
+++ b/inc/efirtlib.h
|
|
||||||
@@ -30,7 +30,7 @@ Revision History
|
|
||||||
#include "aarch64/efilibplat.h"
|
|
||||||
#elif defined (_M_ARM) || defined(__arm__)
|
|
||||||
#include "arm/efilibplat.h"
|
|
||||||
-#elif defined (_M_MIPS64) || defined(__mips64__)
|
|
||||||
+#elif defined (_M_MIPS64) || defined(__mips64__) || defined(__mips64)
|
|
||||||
#include "mips64el/efilibplat.h"
|
|
||||||
#elif defined (__riscv) && __riscv_xlen == 64
|
|
||||||
#include "riscv64/efilibplat.h"
|
|
||||||
--
|
|
||||||
2.36.1
|
|
||||||
|
|
@ -1,6 +1,6 @@
|
|||||||
# From http://sourceforge.net/projects/gnu-efi/files
|
# From http://sourceforge.net/projects/gnu-efi/files
|
||||||
md5 e2902ad09d53d7a94dc96a449dbb4058 gnu-efi-3.0.14.tar.bz2
|
md5 192d94e995ddd4ebdce4903adfd06039 gnu-efi-3.0.15.tar.bz2
|
||||||
sha1 e46b3726478838e85d0a79d0a0d3508c4f2995cf gnu-efi-3.0.14.tar.bz2
|
sha1 40c8a4715cf8c409a093c8d2ca9f5d5b24d73058 gnu-efi-3.0.15.tar.bz2
|
||||||
# Locally computed
|
# Locally computed
|
||||||
sha256 b73b643a0d5697d1f396d7431448e886dd805668789578e3e1a28277c9528435 gnu-efi-3.0.14.tar.bz2
|
sha256 931a257b9c5c1ba65ff519f18373c438a26825f2db7866b163e96d1b168f20ea gnu-efi-3.0.15.tar.bz2
|
||||||
sha256 42d352e9c28dd446fd0209cd6f75588c8e41f0934540bb382bbd61c752360265 README.efilib
|
sha256 42d352e9c28dd446fd0209cd6f75588c8e41f0934540bb382bbd61c752360265 README.efilib
|
||||||
|
@ -4,7 +4,7 @@
|
|||||||
#
|
#
|
||||||
################################################################################
|
################################################################################
|
||||||
|
|
||||||
GNU_EFI_VERSION = 3.0.14
|
GNU_EFI_VERSION = 3.0.15
|
||||||
GNU_EFI_SOURCE = gnu-efi-$(GNU_EFI_VERSION).tar.bz2
|
GNU_EFI_SOURCE = gnu-efi-$(GNU_EFI_VERSION).tar.bz2
|
||||||
GNU_EFI_SITE = http://downloads.sourceforge.net/project/gnu-efi
|
GNU_EFI_SITE = http://downloads.sourceforge.net/project/gnu-efi
|
||||||
GNU_EFI_INSTALL_STAGING = YES
|
GNU_EFI_INSTALL_STAGING = YES
|
||||||
|
Loading…
Reference in New Issue
Block a user