package/exiv2: fix patch with stack protector flag
One of the files have CRLF line endings, which have been lost in the process, causing build issues. Also, we update the upstream status of the patch. Fixes: http://autobuild.buildroot.net/results/31744f8476819c725f8c0024529515bb8059582d/ Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
This commit is contained in:
parent
de669abcb4
commit
a6a1810711
@ -1,6 +1,6 @@
|
|||||||
From 8651c9f823ace70b6609b10aeef0c0740636b570 Mon Sep 17 00:00:00 2001
|
From 4bb57da5fb0bb0d7e747b9e325e9ec0876ffc1f9 Mon Sep 17 00:00:00 2001
|
||||||
From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
||||||
Date: Thu, 1 Jul 2021 19:31:25 +0200
|
Date: Sat, 31 Jul 2021 16:36:50 +0200
|
||||||
Subject: [PATCH] add BUILD_WITH_STACK_PROTECTOR option
|
Subject: [PATCH] add BUILD_WITH_STACK_PROTECTOR option
|
||||||
|
|
||||||
Add BUILD_WITH_STACK_PROTECTOR to avoid the following build failure with
|
Add BUILD_WITH_STACK_PROTECTOR to avoid the following build failure with
|
||||||
@ -15,38 +15,40 @@ enable SSP support
|
|||||||
Fixes:
|
Fixes:
|
||||||
- http://autobuild.buildroot.org/results/ae4635899124c602c70d2b342a76f95c34aa4a3d
|
- http://autobuild.buildroot.org/results/ae4635899124c602c70d2b342a76f95c34aa4a3d
|
||||||
|
|
||||||
|
Upstream: https://github.com/Exiv2/exiv2/commit/f31c0eba098889899d29b7b0da830aee2b62a7b8
|
||||||
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
||||||
[Upstream status: https://github.com/Exiv2/exiv2/pull/1756]
|
|
||||||
---
|
---
|
||||||
CMakeLists.txt | 1 +
|
CMakeLists.txt | 1 +
|
||||||
cmake/compilerFlags.cmake | 2 +-
|
cmake/compilerFlags.cmake | 4 ++--
|
||||||
2 files changed, 2 insertions(+), 1 deletion(-)
|
2 files changed, 3 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||||
index 9fe8b5f9..aabb3dca 100644
|
index 6f0da06a..0746ee14 100644
|
||||||
--- a/CMakeLists.txt
|
--- a/CMakeLists.txt
|
||||||
+++ b/CMakeLists.txt
|
+++ b/CMakeLists.txt
|
||||||
@@ -52,6 +52,7 @@ mark_as_advanced(
|
@@ -47,6 +47,7 @@ mark_as_advanced(
|
||||||
EXIV2_TEAM_USE_SANITIZERS
|
EXIV2_TEAM_USE_SANITIZERS
|
||||||
)
|
)
|
||||||
|
|
||||||
+option( BUILD_WITH_STACK_PROTECTOR "Build with stack protector" ON )
|
+option( BUILD_WITH_STACK_PROTECTOR "Build with stack protector" ON )
|
||||||
option( BUILD_WITH_CCACHE "Use ccache to speed up compilations" OFF )
|
option( BUILD_WITH_CCACHE "Use ccache to speed up compilations" OFF )
|
||||||
option( BUILD_WITH_COVERAGE "Add compiler flags to generate coverage stats" OFF )
|
option( BUILD_WITH_COVERAGE "Add compiler flags to generate coverage stats" OFF )
|
||||||
include(cmake/gcovr.cmake REQUIRED)
|
|
||||||
diff --git a/cmake/compilerFlags.cmake b/cmake/compilerFlags.cmake
|
diff --git a/cmake/compilerFlags.cmake b/cmake/compilerFlags.cmake
|
||||||
index c8a85c59..20f6ac53 100644
|
index 35faf501..0a646e50 100644
|
||||||
--- a/cmake/compilerFlags.cmake
|
--- a/cmake/compilerFlags.cmake
|
||||||
+++ b/cmake/compilerFlags.cmake
|
+++ b/cmake/compilerFlags.cmake
|
||||||
@@ -44,7 +44,7 @@ if ( MINGW OR UNIX OR MSYS ) # MINGW, Linux, APPLE, CYGWIN
|
@@ -33,8 +33,8 @@ if ( MINGW OR UNIX OR MSYS ) # MINGW, Linux, APPLE, CYGWIN
|
||||||
if(HAS_FCF_PROTECTION)
|
endif()
|
||||||
add_compile_options(-fcf-protection)
|
if(HAS_FCF_PROTECTION)
|
||||||
endif()
|
add_compile_options(-fcf-protection)
|
||||||
- if(HAS_FSTACK_PROTECTOR_STRONG)
|
- endif()
|
||||||
+ if(BUILD_WITH_STACK_PROTECTOR AND HAS_FSTACK_PROTECTOR_STRONG)
|
- if(HAS_FSTACK_PROTECTOR_STRONG)
|
||||||
add_compile_options(-fstack-protector-strong)
|
+ endif()
|
||||||
endif()
|
+ if(BUILD_WITH_STACK_PROTECTOR AND HAS_FSTACK_PROTECTOR_STRONG)
|
||||||
endif()
|
add_compile_options(-fstack-protector-strong)
|
||||||
|
endif()
|
||||||
|
endif()
|
||||||
--
|
--
|
||||||
2.30.2
|
2.31.1
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user