package/s390-tools: bump to version 2.21.0
Signed-off-by: Alexander Egorenkov <egorenar@linux.ibm.com> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
This commit is contained in:
parent
858e6183d6
commit
a667c62433
@ -1,29 +0,0 @@
|
||||
From 9fd3c733c645be13a2e39a3bae3983f88530b48d Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Lukas=20M=C3=A4rdian?= <lukas.maerdian@canonical.com>
|
||||
Date: Thu, 7 Jan 2021 12:46:22 +0100
|
||||
Subject: [PATCH] zipl/boot/Makefile: -no-pie is not a valid ld flag
|
||||
|
||||
The "-no-pie" option never has been a valid flag of ld. It breaks the build with newer binutils.
|
||||
See:
|
||||
https://sourceware.org/bugzilla/show_bug.cgi?id=27050
|
||||
https://bugs.launchpad.net/ubuntu/+source/s390-tools/+bug/1907789
|
||||
|
||||
[Retrieved from: https://github.com/ibm-s390-linux/s390-tools/pull/106]
|
||||
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
||||
---
|
||||
zipl/boot/Makefile | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/zipl/boot/Makefile b/zipl/boot/Makefile
|
||||
index a2e5f190..b81df778 100644
|
||||
--- a/zipl/boot/Makefile
|
||||
+++ b/zipl/boot/Makefile
|
||||
@@ -109,7 +109,7 @@ stage3.bin: stage3.exec
|
||||
$< $@
|
||||
|
||||
data.o: $(FILES)
|
||||
- $(LD) $(NO_PIE_LDFLAGS) -r -b binary -o data.o $(FILES)
|
||||
+ $(LD) -r -b binary -o data.o $(FILES)
|
||||
|
||||
data.h: data.o
|
||||
rm -f data.h
|
@ -1,3 +1,3 @@
|
||||
# Locally computed:
|
||||
sha256 6fa6add92e896541c0ef74885a4084474fc0d77049e8ac7372872a70a46ddd74 s390-tools-2.20.0.tar.gz
|
||||
sha256 d0f56fe4f6a62dda45ccd87191e42ebfaec82671ff4b96cc2229a7fe240ce072 s390-tools-2.21.0.tar.gz
|
||||
sha256 cca17a9a944ebec769adee4aebd805c912c357785ff2705a99ffe68563021f75 LICENSE
|
||||
|
@ -4,7 +4,7 @@
|
||||
#
|
||||
################################################################################
|
||||
|
||||
S390_TOOLS_VERSION = 2.20.0
|
||||
S390_TOOLS_VERSION = 2.21.0
|
||||
S390_TOOLS_SITE = $(call github,ibm-s390-linux,s390-tools,v$(S390_TOOLS_VERSION))
|
||||
S390_TOOLS_LICENSE = MIT
|
||||
S390_TOOLS_LICENSE_FILES = LICENSE
|
||||
@ -12,9 +12,7 @@ S390_TOOLS_DEPENDENCIES = zlib
|
||||
|
||||
S390_TOOLS_MAKE_OPTS = \
|
||||
ARCH=$(BR2_ARCH) \
|
||||
CFLAGS="$(TARGET_CFLAGS) -D_GNU_SOURCE" \
|
||||
LINK="$(TARGET_CC)" \
|
||||
LINKXX="$(TARGET_CXX)"
|
||||
CFLAGS="$(TARGET_CFLAGS) -D_GNU_SOURCE"
|
||||
|
||||
ifeq ($(BR2_PACKAGE_LIBCURL),y)
|
||||
S390_TOOLS_DEPENDENCIES += libcurl
|
||||
|
Loading…
Reference in New Issue
Block a user