pptp-linux: fix parallel build
Add a patch to fix a parallel build issue caused by a header file being generated too late. Fixes: http://autobuild.buildroot.org/results/2324974d4818b2657a7df4beee33fc4713d6116f/build-end.log Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
This commit is contained in:
parent
f72c65a3ae
commit
a5b8081b89
23
package/pptp-linux/pptp-linux-004-fix-parallel-build.patch
Normal file
23
package/pptp-linux/pptp-linux-004-fix-parallel-build.patch
Normal file
@ -0,0 +1,23 @@
|
||||
Fix parallel build issue
|
||||
|
||||
The config.h header file must be created before being used to build
|
||||
source files that include it, especially version.c. In order for this
|
||||
to happen even in highly-parallel builds, we add a dependency of all
|
||||
object files on config.h, in order to ensure it gets generated before
|
||||
make attempts to build the object files.
|
||||
|
||||
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
||||
|
||||
Index: b/Makefile
|
||||
===================================================================
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -37,6 +37,8 @@
|
||||
|
||||
all: config.h $(PPTP_BIN) pptpsetup.8
|
||||
|
||||
+$(PPTP_OBJS): config.h
|
||||
+
|
||||
$(PPTP_BIN): $(PPTP_OBJS) $(PPTP_DEPS)
|
||||
$(CC) -o $(PPTP_BIN) $(PPTP_OBJS) $(LDFLAGS) $(LIBS)
|
||||
|
Loading…
Reference in New Issue
Block a user