package/libmanette: bump to version 0.2.7

This is a bugfix release which mainly imroves device detection,
specially inside the Flatpak sandbox. Additionally, this version
includes the patch for building as a static library, and the patch
file can be removed.

Release notes:

  27554bd118

Signed-off-by: Adrian Perez de Castro <aperez@igalia.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
This commit is contained in:
Adrian Perez de Castro 2024-03-25 16:39:15 +02:00 committed by Thomas Petazzoni
parent 631254df93
commit a4a90ee603
4 changed files with 3 additions and 38 deletions

View File

@ -913,7 +913,6 @@ package/libloki/0001-allow-to-install-to-a-specific-location-using-DESTDI.patch
package/libloki/0002-use-ln-snf.patch lib_patch.Upstream package/libloki/0002-use-ln-snf.patch lib_patch.Upstream
package/libmad/0001-mips-h-constraint-removal.patch lib_patch.Sob lib_patch.Upstream package/libmad/0001-mips-h-constraint-removal.patch lib_patch.Sob lib_patch.Upstream
package/libmad/0002-configure-ac-automake-foreign.patch lib_patch.Upstream package/libmad/0002-configure-ac-automake-foreign.patch lib_patch.Upstream
package/libmanette/0001-Meson-Un-hardcode-building-a-shared-library.patch lib_patch.Upstream
package/libmng/0001-jpeg-9a.patch lib_patch.Upstream package/libmng/0001-jpeg-9a.patch lib_patch.Upstream
package/libmodsecurity/0001-configure.ac-drop-usage-of-git-at-configure-time.patch lib_patch.Upstream package/libmodsecurity/0001-configure.ac-drop-usage-of-git-at-configure-time.patch lib_patch.Upstream
package/libmodsecurity/0002-modsecurity.pc.in-add-lstdc.patch lib_patch.Upstream package/libmodsecurity/0002-modsecurity.pc.in-add-lstdc.patch lib_patch.Upstream

View File

@ -1,34 +0,0 @@
From 003c2e84d95357bbbef72fb395ef85f1650097a3 Mon Sep 17 00:00:00 2001
From: Adrian Perez de Castro <aperez@igalia.com>
Date: Fri, 23 Sep 2022 14:35:51 +0300
Subject: [PATCH] Meson: Un-hardcode building a shared library
Use library() instead of shared_library() to allow specifying which kind
of library to build with "meson setup --default-library ..."
This allows more easily incorporating libmanette in an application e.g.
as a Meson subproject which gets built into a program as a static
library.
Signed-off-by: Adrian Perez de Castro <aperez@igalia.com>
[Upstream status: https://gitlab.gnome.org/GNOME/libmanette/-/merge_requests/84]
---
src/meson.build | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/meson.build b/src/meson.build
index c140cac..b71d090 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -63,7 +63,7 @@ if gudev.found()
libmanette_deps += [ gudev ]
endif
-libmanette_lib = shared_library(
+libmanette_lib = library(
libmanette_module,
libmanette_sources,
c_args: libmanette_c_args,
--
2.37.3

View File

@ -1,5 +1,5 @@
# From https://download.gnome.org/sources/libmanette/0.2/libmanette-0.2.6.sha256sum # From https://download.gnome.org/sources/libmanette/0.2/libmanette-0.2.7.sha256sum
sha256 63653259a821ec7d90d681e52e757e2219d462828c9d74b056a5f53267636bac libmanette-0.2.6.tar.xz sha256 cddd5c02a131072c19c6cde6f2cb2cd57eae7dacb50d14c337efd980baa51a51 libmanette-0.2.7.tar.xz
# Locally calculated # Locally calculated
sha256 dc626520dcd53a22f727af3ee42c770e56c97a64fe3adb063799d8ab032fe551 COPYING sha256 dc626520dcd53a22f727af3ee42c770e56c97a64fe3adb063799d8ab032fe551 COPYING

View File

@ -5,7 +5,7 @@
################################################################################ ################################################################################
LIBMANETTE_VERSION_MAJOR = 0.2 LIBMANETTE_VERSION_MAJOR = 0.2
LIBMANETTE_VERSION = $(LIBMANETTE_VERSION_MAJOR).6 LIBMANETTE_VERSION = $(LIBMANETTE_VERSION_MAJOR).7
LIBMANETTE_SOURCE = libmanette-$(LIBMANETTE_VERSION).tar.xz LIBMANETTE_SOURCE = libmanette-$(LIBMANETTE_VERSION).tar.xz
LIBMANETTE_SITE = https://download.gnome.org/sources/libmanette/$(LIBMANETTE_VERSION_MAJOR) LIBMANETTE_SITE = https://download.gnome.org/sources/libmanette/$(LIBMANETTE_VERSION_MAJOR)
LIBMANETTE_LICENSE = LGPL-2.1+ LIBMANETTE_LICENSE = LGPL-2.1+