package/gdb: add support for version 12.1
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com> Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
This commit is contained in:
parent
f3b3887012
commit
a493f6288b
@ -0,0 +1,55 @@
|
||||
From bca7617f325787550e2133fe082dbe4da7716fc6 Mon Sep 17 00:00:00 2001
|
||||
From: Khem Raj <raj.khem@gmail.com>
|
||||
Date: Sat, 6 Aug 2016 17:32:50 -0700
|
||||
Subject: [PATCH] ppc/ptrace: Define pt_regs uapi_pt_regs on !GLIBC systems
|
||||
|
||||
Upstream-Status: Pending
|
||||
|
||||
Signed-off-by: Khem Raj <raj.khem@gmail.com>
|
||||
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
||||
[Rebase on gdb 8.3]
|
||||
Signed-off-by: Romain Naour <romain.naour@gmail.com>
|
||||
---
|
||||
gdb/nat/ppc-linux.h | 6 ++++++
|
||||
gdbserver/linux-ppc-low.cc | 6 ++++++
|
||||
2 files changed, 12 insertions(+)
|
||||
|
||||
diff --git a/gdb/nat/ppc-linux.h b/gdb/nat/ppc-linux.h
|
||||
index 1094f6b0be3..d8588a646c2 100644
|
||||
--- a/gdb/nat/ppc-linux.h
|
||||
+++ b/gdb/nat/ppc-linux.h
|
||||
@@ -18,7 +18,13 @@
|
||||
#ifndef NAT_PPC_LINUX_H
|
||||
#define NAT_PPC_LINUX_H
|
||||
|
||||
+#if !defined(__GLIBC__)
|
||||
+# define pt_regs uapi_pt_regs
|
||||
+#endif
|
||||
#include <asm/ptrace.h>
|
||||
+#if !defined(__GLIBC__)
|
||||
+# undef pt_regs
|
||||
+#endif
|
||||
#include <asm/cputable.h>
|
||||
|
||||
/* This sometimes isn't defined. */
|
||||
diff --git a/gdbserver/linux-ppc-low.cc b/gdbserver/linux-ppc-low.cc
|
||||
index 08824887003..69afbae5359 100644
|
||||
--- a/gdbserver/linux-ppc-low.cc
|
||||
+++ b/gdbserver/linux-ppc-low.cc
|
||||
@@ -23,7 +23,13 @@
|
||||
#include "elf/common.h"
|
||||
#include <sys/uio.h>
|
||||
#include <elf.h>
|
||||
+#if !defined(__GLIBC__)
|
||||
+# define pt_regs uapi_pt_regs
|
||||
+#endif
|
||||
#include <asm/ptrace.h>
|
||||
+#if !defined(__GLIBC__)
|
||||
+# undef pt_regs
|
||||
+#endif
|
||||
|
||||
#include "arch/ppc-linux-common.h"
|
||||
#include "arch/ppc-linux-tdesc.h"
|
||||
--
|
||||
2.37.1
|
||||
|
@ -0,0 +1,43 @@
|
||||
From a3b84f1777bd75bdc5914f4ce5f52c55e723cd9a Mon Sep 17 00:00:00 2001
|
||||
From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
||||
Date: Sat, 3 Jun 2017 21:23:52 +0200
|
||||
Subject: [PATCH] sh/ptrace: Define pt_{dsp,}regs uapi_pt_{dsp,}regs on !GLIBC
|
||||
systems
|
||||
|
||||
Fixes a pt_{dsp,}regs redefinition when building with the musl C library
|
||||
on SuperH.
|
||||
|
||||
Inspired by
|
||||
http://git.yoctoproject.org/clean/cgit.cgi/poky/plain/meta/recipes-devtools/gdb/gdb/0004-ppc-ptrace-Define-pt_regs-uapi_pt_regs-on-GLIBC-syst.patch,
|
||||
adapted for SuperH.
|
||||
|
||||
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
||||
[Rebase on gdb 8.0]
|
||||
Signed-off-by: Romain Naour <romain.naour@gmail.com>
|
||||
---
|
||||
gdbserver/linux-sh-low.cc | 8 ++++++++
|
||||
1 file changed, 8 insertions(+)
|
||||
|
||||
diff --git a/gdbserver/linux-sh-low.cc b/gdbserver/linux-sh-low.cc
|
||||
index 966bdeb8ba7..1e3ce53b4d5 100644
|
||||
--- a/gdbserver/linux-sh-low.cc
|
||||
+++ b/gdbserver/linux-sh-low.cc
|
||||
@@ -76,7 +76,15 @@ extern const struct target_desc *tdesc_sh;
|
||||
#include <sys/reg.h>
|
||||
#endif
|
||||
|
||||
+#if !defined(__GLIBC__)
|
||||
+# define pt_regs uapi_pt_regs
|
||||
+# define pt_dspregs uapi_pt_dspregs
|
||||
+#endif
|
||||
#include <asm/ptrace.h>
|
||||
+#if !defined(__GLIBC__)
|
||||
+# undef pt_regs
|
||||
+# undef pt_dspregs
|
||||
+#endif
|
||||
|
||||
#define sh_num_regs 41
|
||||
|
||||
--
|
||||
2.37.1
|
||||
|
40
package/gdb/12.1/0003-use-asm-sgidefs.h.patch
Normal file
40
package/gdb/12.1/0003-use-asm-sgidefs.h.patch
Normal file
@ -0,0 +1,40 @@
|
||||
From 8c94bf2b40d51c500c364ac03a2da1e9f9a94287 Mon Sep 17 00:00:00 2001
|
||||
From: Andre McCurdy <amccurdy@gmail.com>
|
||||
Date: Sat, 30 Apr 2016 15:29:06 -0700
|
||||
Subject: [PATCH] use <asm/sgidefs.h>
|
||||
|
||||
Build fix for MIPS with musl libc
|
||||
|
||||
The MIPS specific header <sgidefs.h> is provided by glibc and uclibc
|
||||
but not by musl. Regardless of the libc, the kernel headers provide
|
||||
<asm/sgidefs.h> which provides the same definitions, so use that
|
||||
instead.
|
||||
|
||||
Upstream-Status: Pending
|
||||
|
||||
[Vincent:
|
||||
Taken from: https://sourceware.org/bugzilla/show_bug.cgi?id=21070]
|
||||
|
||||
Signed-off-by: Andre McCurdy <armccurdy@gmail.com>
|
||||
Signed-off-by: Khem Raj <raj.khem@gmail.com>
|
||||
Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
|
||||
---
|
||||
gdb/mips-linux-nat.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/gdb/mips-linux-nat.c b/gdb/mips-linux-nat.c
|
||||
index 20e12b6889e..1e66e98a013 100644
|
||||
--- a/gdb/mips-linux-nat.c
|
||||
+++ b/gdb/mips-linux-nat.c
|
||||
@@ -31,7 +31,7 @@
|
||||
#include "gdb_proc_service.h"
|
||||
#include "gregset.h"
|
||||
|
||||
-#include <sgidefs.h>
|
||||
+#include <asm/sgidefs.h>
|
||||
#include "nat/gdb_ptrace.h"
|
||||
#include <asm/ptrace.h>
|
||||
#include "inf-ptrace.h"
|
||||
--
|
||||
2.37.1
|
||||
|
63
package/gdb/12.1/0004-gdbserver-fix-build-for-m68k.patch
Normal file
63
package/gdb/12.1/0004-gdbserver-fix-build-for-m68k.patch
Normal file
@ -0,0 +1,63 @@
|
||||
From 48af20f76b468c5d274d286677a2887136c4c7c4 Mon Sep 17 00:00:00 2001
|
||||
From: Romain Naour <romain.naour@gmail.com>
|
||||
Date: Fri, 22 Jun 2018 22:40:26 +0200
|
||||
Subject: [PATCH] gdbserver: fix build for m68k
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
As for strace [1], when <sys/reg.h> is included after <linux/ptrace.h>,
|
||||
the build fails on m68k with the following diagnostics:
|
||||
|
||||
In file included from ./../nat/linux-ptrace.h:28:0,
|
||||
from linux-low.h:27,
|
||||
from linux-m68k-low.c:20:
|
||||
[...]/usr/include/sys/reg.h:26:3: error: expected identifier before numeric constant
|
||||
PT_D1 = 0,
|
||||
^
|
||||
[...]usr/include/sys/reg.h:26:3: error: expected « } » before numeric constant
|
||||
[...]usr/include/sys/reg.h:26:3: error: expected unqualified-id before numeric constant
|
||||
In file included from linux-m68k-low.c:27:0:
|
||||
[...]usr/include/sys/reg.h:99:1: error: expected declaration before « } » token
|
||||
};
|
||||
^
|
||||
|
||||
Fix this by moving <sys/reg.h> on top of "linux-low.h".
|
||||
|
||||
[1] https://github.com/strace/strace/commit/6ebf6c4f9e5ebca123a5b5f24afe67cf0473cf92
|
||||
|
||||
Signed-off-by: Romain Naour <romain.naour@gmail.com>
|
||||
---
|
||||
gdbserver/linux-m68k-low.cc | 9 +++++----
|
||||
1 file changed, 5 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/gdbserver/linux-m68k-low.cc b/gdbserver/linux-m68k-low.cc
|
||||
index 7a433ffab5e..bb3fbd69bd7 100644
|
||||
--- a/gdbserver/linux-m68k-low.cc
|
||||
+++ b/gdbserver/linux-m68k-low.cc
|
||||
@@ -17,6 +17,11 @@
|
||||
along with this program. If not, see <http://www.gnu.org/licenses/>. */
|
||||
|
||||
#include "server.h"
|
||||
+
|
||||
+#ifdef HAVE_SYS_REG_H
|
||||
+#include <sys/reg.h>
|
||||
+#endif
|
||||
+
|
||||
#include "linux-low.h"
|
||||
|
||||
/* Linux target op definitions for the m68k architecture. */
|
||||
@@ -80,10 +85,6 @@ m68k_target::low_decr_pc_after_break ()
|
||||
void init_registers_m68k (void);
|
||||
extern const struct target_desc *tdesc_m68k;
|
||||
|
||||
-#ifdef HAVE_SYS_REG_H
|
||||
-#include <sys/reg.h>
|
||||
-#endif
|
||||
-
|
||||
#define m68k_num_regs 29
|
||||
#define m68k_num_gregs 18
|
||||
|
||||
--
|
||||
2.37.1
|
||||
|
@ -0,0 +1,53 @@
|
||||
From cbcb73a86dea0c0b9917b49b37095463155c5377 Mon Sep 17 00:00:00 2001
|
||||
From: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
|
||||
Date: Sun, 24 Jun 2018 23:33:55 +0200
|
||||
Subject: [PATCH] nat/fork-inferior: include linux-ptrace.h
|
||||
|
||||
To decide whether fork() or vfork() should be used, fork-inferior.c
|
||||
uses the following test:
|
||||
|
||||
#if !(defined(__UCLIBC__) && defined(HAS_NOMMU))
|
||||
|
||||
However, HAS_NOMMU is never defined, because it gets defined in
|
||||
linux-ptrace.h, which is not included by fork-inferior.c. Due to this,
|
||||
gdbserver fails to build on noMMU architectures. This commit fixes
|
||||
that by simply including linux-ptrace.h.
|
||||
|
||||
This bug was introduced by commit
|
||||
2090129c36c7e582943b7d300968d19b46160d84 ("Share fork_inferior et al
|
||||
with gdbserver"). Indeed, the same fork()/vfork() selection was done,
|
||||
but in another file where linux-ptrace.h was included.
|
||||
|
||||
Fixes the following build issue:
|
||||
|
||||
../nat/fork-inferior.c: In function 'pid_t fork_inferior(const char*, const string&, char**, void (*)(), void (*)(int), void (*)(), const char*, void (*)(const char*, char* const*, char* const*))':
|
||||
../nat/fork-inferior.c:376:11: error: 'fork' was not declared in this scope
|
||||
pid = fork ();
|
||||
^~~~
|
||||
../nat/fork-inferior.c:376:11: note: suggested alternative: 'vfork'
|
||||
pid = fork ();
|
||||
^~~~
|
||||
vfork
|
||||
|
||||
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
|
||||
[Romain: rebase on gdb 8.3]
|
||||
Signed-off-by: Romain Naour <romain.naour@gmail.com>
|
||||
---
|
||||
gdb/nat/fork-inferior.c | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/gdb/nat/fork-inferior.c b/gdb/nat/fork-inferior.c
|
||||
index 4df9a98047e..9bf0f6059f5 100644
|
||||
--- a/gdb/nat/fork-inferior.c
|
||||
+++ b/gdb/nat/fork-inferior.c
|
||||
@@ -27,6 +27,7 @@
|
||||
#include "gdbsupport/pathstuff.h"
|
||||
#include "gdbsupport/signals-state-save-restore.h"
|
||||
#include "gdbsupport/gdb_tilde_expand.h"
|
||||
+#include "linux-ptrace.h"
|
||||
#include <vector>
|
||||
|
||||
extern char **environ;
|
||||
--
|
||||
2.37.1
|
||||
|
@ -0,0 +1,39 @@
|
||||
From 03efe04b5748703234516836cb0186d25b052556 Mon Sep 17 00:00:00 2001
|
||||
From: Peter Seiderer <ps.report@gmx.net>
|
||||
Date: Sat, 6 Nov 2021 10:06:25 +0100
|
||||
Subject: [PATCH] Fix getrandom compile for uclibc < v1.0.35
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
- fix getrandom compile for uclibc < v1.0.35, add missing stddef.h
|
||||
include (fixed in uclibc since v1.0.35, see [1])
|
||||
|
||||
Fixes:
|
||||
|
||||
.../host/x86_64-buildroot-linux-uclibc/sysroot/usr/include/sys/random.h:27:35: error: unknown type name ‘size_t’
|
||||
27 | extern int getrandom(void *__buf, size_t count, unsigned int flags)
|
||||
| ^~~~~~
|
||||
|
||||
[1] https://cgit.uclibc-ng.org/cgi/cgit/uclibc-ng.git/commit/?id=00972c02c2b6e0a95d5def4a71bdfb188e091782t
|
||||
|
||||
Signed-off-by: Peter Seiderer <ps.report@gmx.net>
|
||||
---
|
||||
gnulib/import/getrandom.c | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/gnulib/import/getrandom.c b/gnulib/import/getrandom.c
|
||||
index 41212fb329d..0ad3f9648d2 100644
|
||||
--- a/gnulib/import/getrandom.c
|
||||
+++ b/gnulib/import/getrandom.c
|
||||
@@ -19,6 +19,7 @@
|
||||
|
||||
#include <config.h>
|
||||
|
||||
+#include <stddef.h>
|
||||
#include <sys/random.h>
|
||||
|
||||
#include <errno.h>
|
||||
--
|
||||
2.37.1
|
||||
|
60
package/gdb/12.1/0007-fix-musl-build-on-riscv.patch
Normal file
60
package/gdb/12.1/0007-fix-musl-build-on-riscv.patch
Normal file
@ -0,0 +1,60 @@
|
||||
From f2dd94dce490d8e8301fba9e4684cfb8d7bc7756 Mon Sep 17 00:00:00 2001
|
||||
From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
||||
Date: Wed, 10 Nov 2021 23:14:54 +0100
|
||||
Subject: [PATCH] fix musl build on riscv
|
||||
|
||||
Fix the following build failure raised with musl:
|
||||
|
||||
../../gdbserver/linux-riscv-low.cc: In function 'void riscv_fill_fpregset(regcache*, void*)':
|
||||
../../gdbserver/linux-riscv-low.cc:140:19: error: 'ELF_NFPREG' was not declared in this scope; did you mean 'ELF_NGREG'?
|
||||
140 | for (i = 0; i < ELF_NFPREG - 1; i++, regbuf += flen)
|
||||
| ^~~~~~~~~~
|
||||
| ELF_NGREG
|
||||
|
||||
musl fixed the issue with
|
||||
https://git.musl-libc.org/cgit/musl/commit/?id=e5d2823631bbfebacf48e1a34ed28f28d7cb2570
|
||||
|
||||
Fixes:
|
||||
- http://autobuild.buildroot.org/results/16b19198980ce9c81a618b3f6e8dc9fe28247a28
|
||||
|
||||
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
||||
---
|
||||
gdb/nat/riscv-linux-tdesc.c | 5 +++++
|
||||
gdbserver/linux-riscv-low.cc | 5 +++++
|
||||
2 files changed, 10 insertions(+)
|
||||
|
||||
diff --git a/gdb/nat/riscv-linux-tdesc.c b/gdb/nat/riscv-linux-tdesc.c
|
||||
index 07b49c0f16e..1ff58cce16f 100644
|
||||
--- a/gdb/nat/riscv-linux-tdesc.c
|
||||
+++ b/gdb/nat/riscv-linux-tdesc.c
|
||||
@@ -31,6 +31,11 @@
|
||||
# define NFPREG 33
|
||||
#endif
|
||||
|
||||
+/* Work around musl breakage since version 1.1.24. */
|
||||
+#ifndef ELF_NFPREG
|
||||
+# define ELF_NFPREG 33
|
||||
+#endif
|
||||
+
|
||||
/* See nat/riscv-linux-tdesc.h. */
|
||||
|
||||
struct riscv_gdbarch_features
|
||||
diff --git a/gdbserver/linux-riscv-low.cc b/gdbserver/linux-riscv-low.cc
|
||||
index 6b2902e422d..ead54db09a8 100644
|
||||
--- a/gdbserver/linux-riscv-low.cc
|
||||
+++ b/gdbserver/linux-riscv-low.cc
|
||||
@@ -30,6 +30,11 @@
|
||||
# define NFPREG 33
|
||||
#endif
|
||||
|
||||
+/* Work around musl breakage since version 1.1.24. */
|
||||
+#ifndef ELF_NFPREG
|
||||
+# define ELF_NFPREG 33
|
||||
+#endif
|
||||
+
|
||||
/* Linux target op definitions for the RISC-V architecture. */
|
||||
|
||||
class riscv_target : public linux_process_target
|
||||
--
|
||||
2.37.1
|
||||
|
@ -0,0 +1,38 @@
|
||||
From 73487022cb629415c3b0c2d9e125035b6e5c2d32 Mon Sep 17 00:00:00 2001
|
||||
From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
||||
Date: Thu, 18 Nov 2021 22:52:08 +0100
|
||||
Subject: [PATCH] gdbserver/Makefile.in: fix NLS build
|
||||
|
||||
Fix the following build failure raised since gdb version 10.1 and
|
||||
https://sourceware.org/git/?p=binutils-gdb.git;a=commit;h=9a665d62266e75f0519f3a663784c458885b5c63:
|
||||
|
||||
CXXLD libinproctrace.so
|
||||
/home/buildroot/autobuild/instance-2/output-1/host/opt/ext-toolchain/bin/../lib/gcc/i586-buildroot-linux-musl/9.3.0/../../../../i586-buildroot-linux-musl/bin/ld: gdbsupport/tdesc-ipa.o: in function `print_xml_feature::visit(tdesc_type_builtin const*)':
|
||||
/home/buildroot/autobuild/instance-2/output-1/build/gdb-10.2/build/gdbserver/../../gdbserver/../gdbsupport/tdesc.cc:310: undefined reference to `libintl_gettext'
|
||||
|
||||
Fixes:
|
||||
- http://autobuild.buildroot.org/results/faacc874fe9d32b74cb3d3dea988ef661cb0e3d0
|
||||
|
||||
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
||||
[Upstream status:
|
||||
https://sourceware.org/pipermail/gdb-patches/2021-November/183580.html]
|
||||
---
|
||||
gdbserver/Makefile.in | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/gdbserver/Makefile.in b/gdbserver/Makefile.in
|
||||
index 47648b8d962..9d862bcb9c9 100644
|
||||
--- a/gdbserver/Makefile.in
|
||||
+++ b/gdbserver/Makefile.in
|
||||
@@ -383,7 +383,7 @@ $(IPA_LIB): $(sort $(IPA_OBJS)) ${CDEPS}
|
||||
$(ECHO_CXXLD) $(CC_LD) -shared -fPIC -Wl,--soname=$(IPA_LIB) \
|
||||
-Wl,--no-undefined $(INTERNAL_CFLAGS) $(INTERNAL_LDFLAGS) \
|
||||
$(CXXFLAGS) \
|
||||
- -o $(IPA_LIB) ${IPA_OBJS} $(LIBIBERTY_FOR_SHLIB) -ldl -pthread
|
||||
+ -o $(IPA_LIB) ${IPA_OBJS} $(LIBIBERTY_FOR_SHLIB) -ldl -pthread $(INTL)
|
||||
|
||||
# Put the proper machine-specific files first, so M-. on a machine
|
||||
# specific routine gets the one for the correct machine.
|
||||
--
|
||||
2.37.1
|
||||
|
@ -52,6 +52,7 @@ config BR2_PACKAGE_GDB_DEBUGGER
|
||||
depends on BR2_USE_WCHAR
|
||||
depends on !BR2_sh
|
||||
select BR2_PACKAGE_GMP if BR2_GDB_VERSION_11
|
||||
select BR2_PACKAGE_GMP if BR2_GDB_VERSION_12
|
||||
select BR2_PACKAGE_NCURSES
|
||||
|
||||
comment "full gdb on target needs a toolchain w/ wchar"
|
||||
|
@ -57,6 +57,9 @@ config BR2_GDB_VERSION_10
|
||||
config BR2_GDB_VERSION_11
|
||||
bool "gdb 11.x"
|
||||
|
||||
config BR2_GDB_VERSION_12
|
||||
bool "gdb 12.x"
|
||||
|
||||
endchoice
|
||||
|
||||
endif
|
||||
@ -68,6 +71,7 @@ config BR2_GDB_VERSION
|
||||
default "9.2" if BR2_GDB_VERSION_9_2
|
||||
default "10.2" if BR2_GDB_VERSION_10 || !BR2_PACKAGE_HOST_GDB
|
||||
default "11.2" if BR2_GDB_VERSION_11
|
||||
default "12.1" if BR2_GDB_VERSION_12
|
||||
depends on BR2_PACKAGE_GDB || BR2_PACKAGE_HOST_GDB
|
||||
|
||||
# recent gdb versions (>= 10) have gdbserver moved at the top-level,
|
||||
@ -77,5 +81,6 @@ config BR2_PACKAGE_GDB_TOPLEVEL
|
||||
default y if BR2_arc
|
||||
default y if BR2_GDB_VERSION_10
|
||||
default y if BR2_GDB_VERSION_11
|
||||
default y if BR2_GDB_VERSION_12
|
||||
default y if !BR2_PACKAGE_HOST_GDB
|
||||
depends on BR2_PACKAGE_GDB || BR2_PACKAGE_HOST_GDB
|
||||
|
@ -2,6 +2,7 @@
|
||||
sha512 73635f00f343117aa5e2436f1e1597099e2bfb31ef7bb162b273fa1ea282c3fa9b0f52762e70bfc7ad0334addb8d159e9ac7cbe5998ca4f755ea8cf90714d274 gdb-9.2.tar.xz
|
||||
sha512 3653762ac008e065c37cd641653184c9ff7ce51ee2222ade1122bec9d6cc64dffd4fb74888ef11ac1942064a08910e96b7865112ad37f4602eb0a16bed074caa gdb-10.2.tar.xz
|
||||
sha512 07e9026423438049b11f4f784d57401ece4e940570f613bd6958b3714fe7fbc2c048470bcce3e7d7d9f93331cdf3881d30dcc964cb113a071143a02b28e5b127 gdb-11.2.tar.xz
|
||||
sha512 425568d2e84672177d0fb87b1ad7daafdde097648d605e30cf0656970f66adc6a82ca2d83375ea4be583e9683a340e5bfdf5819668ddf66728200141ae50ff2d gdb-12.1.tar.xz
|
||||
|
||||
# Locally calculated (fetched from Github)
|
||||
sha512 5a2acf2fd33ab2ff589e1037ca40abda54328997dcff26b2b49b874bd3be980be5a63342962254f3c3bda98e32ce7a33af704d37353352833dee193135600458 gdb-arc-2020.09-release-gdb.tar.gz
|
||||
|
@ -65,9 +65,8 @@ GDB_DEPENDENCIES += host-flex host-bison
|
||||
HOST_GDB_DEPENDENCIES += host-flex host-bison
|
||||
endif
|
||||
|
||||
# When BR2_GDB_VERSION_11=y, we're going to build gdb 11.x for the
|
||||
# host (if enabled), so we add the necessary gmp dependency.
|
||||
ifeq ($(BR2_GDB_VERSION_11),y)
|
||||
# Add the necessary host-gmp dependency for the newer releases of GDB
|
||||
ifeq ($(BR2_GDB_VERSION_11)$(BR2_GDB_VERSION_12),y)
|
||||
HOST_GDB_DEPENDENCIES += host-gmp
|
||||
endif
|
||||
|
||||
@ -155,11 +154,11 @@ GDB_CONF_OPTS += \
|
||||
--without-curses
|
||||
endif
|
||||
|
||||
# When BR2_GDB_VERSION_11=y (because it's enabled for the host) and
|
||||
# we're building the full gdb for the target, we need gmp as a
|
||||
# When GDB >= 11.x (because it's enabled for the host) and we're
|
||||
# building the full gdb for the target, we need gmp as a
|
||||
# dependency. For now the default gdb version in Buildroot doesn't
|
||||
# require gmp.
|
||||
ifeq ($(BR2_GDB_VERSION_11)$(BR2_PACKAGE_GDB_DEBUGGER),yy)
|
||||
ifeq ($(BR2_GDB_VERSION_11)$(BR2_GDB_VERSION_12):$(BR2_PACKAGE_GDB_DEBUGGER),y:y)
|
||||
GDB_CONF_OPTS += \
|
||||
--with-libgmp-prefix=$(STAGING_DIR)/usr
|
||||
GDB_DEPENDENCIES += gmp
|
||||
|
Loading…
Reference in New Issue
Block a user