package/coreutils: drop useless patch

Until version 8.23, we needed to patch coreutils to ensure that options
be passed before non-options when calling help2man (during the build).
Our patch would just swap around two consecutive lines, and required
autoreconfguring and gettextising.

However, in coreutils 8.24, upstream applied a semantically equivalent
fix, but we did not notice, and we blindly fixed the patch by swapping
the previously faulty lines, even though the issue was no longer present
to begin with (if one would need an example of cargo cult, this is it).

Drop our patch, as it has not been needed for the past 4.5 years.

This means that we can also stop autoreconfiguring and gettextising.
Woot!

Rename the remaining patch.

Reported-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
Cc: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
This commit is contained in:
Yann E. MORIN 2020-01-06 22:23:36 +01:00 committed by Thomas Petazzoni
parent fd42481b22
commit a4003d700d
3 changed files with 0 additions and 29 deletions

View File

@ -1,25 +0,0 @@
Upstream-Status: Pending
coreutils: fix for dummy-man usage
The options should be before the final argument, otherwise, the following error
would appear when compiling.
"dummy-man: too many non-option arguments"
Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
[Gustavo: update for 8.24]
diff -Nura coreutils-8.24.orig/man/local.mk coreutils-8.24/man/local.mk
--- coreutils-8.24.orig/man/local.mk 2015-07-04 11:23:47.190503631 -0300
+++ coreutils-8.24/man/local.mk 2015-07-04 11:24:25.046741090 -0300
@@ -186,8 +186,8 @@
&& $(run_help2man) \
--source='$(PACKAGE_STRING)' \
--include=$(srcdir)/man/$$name.x \
- --output=$$t/$$name.1 \
--info-page='\(aq(coreutils) '$$name' invocation\(aq' \
+ --output=$$t/$$name.1 \
$$t/$$argv$(EXEEXT) \
&& sed \
-e 's|$*\.td/||g' \

View File

@ -10,10 +10,6 @@ COREUTILS_SOURCE = coreutils-$(COREUTILS_VERSION).tar.xz
COREUTILS_LICENSE = GPL-3.0+
COREUTILS_LICENSE_FILES = COPYING
# coreutils-01-fix-for-dummy-man-usage.patch triggers autoreconf on build
COREUTILS_AUTORECONF = YES
COREUTILS_GETTEXTIZE = YES
COREUTILS_CONF_OPTS = --disable-rpath \
$(if $(BR2_TOOLCHAIN_USES_MUSL),--with-included-regex)