package/gstreamer1/gstd: bump to version 0.14.0
Drop patches that are now upstream. Signed-off-by: James Hilliard <james.hilliard1@gmail.com> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
This commit is contained in:
parent
2f32185679
commit
a334b9a766
@ -1,33 +0,0 @@
|
||||
From 586bb97459e72da30bd9991c228b6b8e9251c68b Mon Sep 17 00:00:00 2001
|
||||
From: James Hilliard <james.hilliard1@gmail.com>
|
||||
Date: Tue, 14 Sep 2021 01:49:49 -0600
|
||||
Subject: [PATCH] Don't require gstreamer-check-1.0 unless tests are enabled.
|
||||
|
||||
Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
|
||||
[Upstream status:
|
||||
https://github.com/RidgeRun/gstd-1.x/pull/248]
|
||||
---
|
||||
meson.build | 4 +++-
|
||||
1 file changed, 3 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/meson.build b/meson.build
|
||||
index 1d9ce9d..76990a0 100644
|
||||
--- a/meson.build
|
||||
+++ b/meson.build
|
||||
@@ -22,10 +22,12 @@ gio_unix_dep = dependency('gio-unix-2.0', version : '>=2.44.1')
|
||||
json_glib_dep = dependency('json-glib-1.0', version : '>=0.16.2')
|
||||
libd_dep = dependency('libdaemon', version : '>=0.14')
|
||||
jansson_dep = dependency('jansson', version : '>=2.7')
|
||||
-gst_check_dep = dependency('gstreamer-check-1.0',version : '>=1.0.5')
|
||||
thread_dep = dependency('threads')
|
||||
libsoup_dep = dependency('libsoup-2.4', version : '>=2.4')
|
||||
|
||||
+gst_check_required = get_option('enable-tests').enabled()
|
||||
+gst_check_dep = dependency('gstreamer-check-1.0', required : gst_check_required, version : '>=1.0.5')
|
||||
+
|
||||
systemd_required = get_option('enable-systemd').enabled()
|
||||
systemd_dep = dependency('systemd', required : systemd_required, version : '>=232')
|
||||
|
||||
--
|
||||
2.25.1
|
||||
|
@ -1,38 +0,0 @@
|
||||
From a670beca8dcc76171dcfe3f10970d76c6f0439be Mon Sep 17 00:00:00 2001
|
||||
From: James Hilliard <james.hilliard1@gmail.com>
|
||||
Date: Tue, 14 Sep 2021 02:49:10 -0600
|
||||
Subject: [PATCH] Use relative symlink for gstd/gst-client exe.
|
||||
|
||||
This should fix the symlink path when cross compiling.
|
||||
|
||||
Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
|
||||
[Upstream status:
|
||||
https://github.com/RidgeRun/gstd-1.x/pull/249]
|
||||
---
|
||||
gst_client/gst_client_symbolic_link.sh | 2 +-
|
||||
gstd/gstd_symbolic_link.sh | 2 +-
|
||||
2 files changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/gst_client/gst_client_symbolic_link.sh b/gst_client/gst_client_symbolic_link.sh
|
||||
index d8d7617..b87dd12 100755
|
||||
--- a/gst_client/gst_client_symbolic_link.sh
|
||||
+++ b/gst_client/gst_client_symbolic_link.sh
|
||||
@@ -4,4 +4,4 @@
|
||||
# $1: target
|
||||
# $2: link name
|
||||
rm -f ${DESTDIR}${MESON_INSTALL_PREFIX}/$2
|
||||
-ln -s ${DESTDIR}${MESON_INSTALL_PREFIX}/$1 ${DESTDIR}${MESON_INSTALL_PREFIX}/$2
|
||||
+ln -s --relative ${DESTDIR}${MESON_INSTALL_PREFIX}/$1 ${DESTDIR}${MESON_INSTALL_PREFIX}/$2
|
||||
diff --git a/gstd/gstd_symbolic_link.sh b/gstd/gstd_symbolic_link.sh
|
||||
index d8d7617..b87dd12 100755
|
||||
--- a/gstd/gstd_symbolic_link.sh
|
||||
+++ b/gstd/gstd_symbolic_link.sh
|
||||
@@ -4,4 +4,4 @@
|
||||
# $1: target
|
||||
# $2: link name
|
||||
rm -f ${DESTDIR}${MESON_INSTALL_PREFIX}/$2
|
||||
-ln -s ${DESTDIR}${MESON_INSTALL_PREFIX}/$1 ${DESTDIR}${MESON_INSTALL_PREFIX}/$2
|
||||
+ln -s --relative ${DESTDIR}${MESON_INSTALL_PREFIX}/$1 ${DESTDIR}${MESON_INSTALL_PREFIX}/$2
|
||||
--
|
||||
2.25.1
|
||||
|
@ -1,3 +1,3 @@
|
||||
# Locally calculated
|
||||
sha256 94c10c798d3618b63cc68cbe053fabd19335a57f982a47b3d66c27c37d325da3 gstd-0.13.0.tar.gz
|
||||
sha256 56afd58530b63d0d88dd818fd4e6c9230861819b3e131c6a87a46084c3f3fa96 gstd-0.14.0.tar.gz
|
||||
sha256 8177f97513213526df2cf6184d8ff986c675afb514d4e68a404010521b880643 COPYING
|
||||
|
@ -4,7 +4,7 @@
|
||||
#
|
||||
################################################################################
|
||||
|
||||
GSTD_VERSION = 0.13.0
|
||||
GSTD_VERSION = 0.14.0
|
||||
GSTD_SITE = $(call github,RidgeRun,gstd-1.x,v$(GSTD_VERSION))
|
||||
GSTD_LICENSE_FILES = COPYING
|
||||
GSTD_LICENSE = GPL-2.0+
|
||||
|
Loading…
Reference in New Issue
Block a user