package/highway: bump to version 1.1.0

For release note, see [1].

This commit removes the package patch, as it is now included in this new
release.

LICENSE-BSD3 hash changed, due to reformatting. See [2].

[1] https://github.com/google/highway/releases/tag/1.1.0
[2] edc35d14c7

Signed-off-by: Julien Olivain <ju.o@free.fr>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
This commit is contained in:
Julien Olivain 2024-02-19 23:14:58 +01:00 committed by Yann E. MORIN
parent ec344d6013
commit a2e08963a2
3 changed files with 3 additions and 45 deletions

View File

@ -1,42 +0,0 @@
From 5d58d233fbcec0c6a39df8186a877329147324b3 Mon Sep 17 00:00:00 2001
From: Mathieu Malaterre <mathieu.malaterre@gmail.com>
Date: Wed, 13 Sep 2023 08:37:54 +0200
Subject: [PATCH] Add an option to opt-out of HWY_RISCV
Fixes #1740
Upstream: https://github.com/google/highway/commit/5d58d233fbcec0c6a39df8186a877329147324b3
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
CMakeLists.txt | 11 ++++++++---
1 file changed, 8 insertions(+), 3 deletions(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c2bf57b3f5..be639c945f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -61,6 +61,9 @@ set(HWY_CMAKE_ARM7 OFF CACHE BOOL "Set copts for Armv7 with NEON (requires vfpv4
# skipped. For GCC 13.1+, you can also build with -fexcess-precision=standard.
set(HWY_CMAKE_SSE2 OFF CACHE BOOL "Set SSE2 as baseline for 32-bit x86?")
+# Currently this will compile the entire codebase with `-march=rv64gcv1p0`:
+set(HWY_CMAKE_RVV ON CACHE BOOL "Set copts for RISCV with RVV?")
+
# Unconditionally adding -Werror risks breaking the build when new warnings
# arise due to compiler/platform changes. Enable this in CI/tests.
set(HWY_WARNINGS_ARE_ERRORS OFF CACHE BOOL "Add -Werror flag?")
@@ -260,9 +263,11 @@ else()
# gcc(13) and recent clang both support V, but not yet runtime dispatch, so
# we add the gcv compiler flag, which then requires the CPU (now when using
# either compiler) to support V.
- list(APPEND HWY_FLAGS -march=rv64gcv1p0)
- if(${CMAKE_CXX_COMPILER_ID} MATCHES "Clang")
- list(APPEND HWY_FLAGS -menable-experimental-extensions)
+ if(HWY_CMAKE_RVV)
+ list(APPEND HWY_FLAGS -march=rv64gcv1p0)
+ if(${CMAKE_CXX_COMPILER_ID} MATCHES "Clang")
+ list(APPEND HWY_FLAGS -menable-experimental-extensions)
+ endif()
endif()
endif()

View File

@ -1,4 +1,4 @@
# Locally computed:
sha256 5434488108186c170a5e2fca5e3c9b6ef59a1caa4d520b008a9b8be6b8abe6c5 highway-1.0.7.tar.gz
sha256 354a8b4539b588e70b98ec70844273e3f2741302c4c377bcc4e81b3d1866f7c9 highway-1.1.0.tar.gz
sha256 43070e2d4e532684de521b885f385d0841030efa2b1a20bafb76133a5e1379c1 LICENSE
sha256 6dcc159f448e3aca73a15e355d0a6735ca3fd224abe637e0b7437dce2d24f765 LICENSE-BSD3
sha256 d25e82e26acd42ca3ccc9993622631163425b869b9e16284226d534cff6470f2 LICENSE-BSD3

View File

@ -4,7 +4,7 @@
#
################################################################################
HIGHWAY_VERSION = 1.0.7
HIGHWAY_VERSION = 1.1.0
HIGHWAY_SITE = $(call github,google,highway,$(HIGHWAY_VERSION))
HIGHWAY_LICENSE = Apache-2.0 or BSD-3-Clause
HIGHWAY_LICENSE_FILES = LICENSE LICENSE-BSD3