libpcap: drop libnl headers patch

We can avoid host headers using a --with-libnl parameter to override the
default host headers path. The configure script adds /include suffix to the
include path. So we still need to manually add -I with the correct path to
CFLAGS because libnl headers are under the libnl3/ directory.

Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
This commit is contained in:
Baruch Siach 2016-10-26 20:03:09 +03:00 committed by Thomas Petazzoni
parent 20f73c2ecb
commit a2d9202f6f
2 changed files with 1 additions and 25 deletions

View File

@ -1,25 +0,0 @@
Remove hardcoded path to libnl3 include directory
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
[Gustavo: update for 1.7.2]
diff -Nura libpcap-1.7.2.orig/configure.in libpcap-1.7.2/configure.in
--- libpcap-1.7.2.orig/configure.in 2015-03-14 08:02:05.538706347 -0300
+++ libpcap-1.7.2/configure.in 2015-03-14 08:17:22.637519050 -0300
@@ -461,14 +461,13 @@
#
# Yes, we have libnl 3.x.
#
- LIBS="${libnldir} -lnl-genl-3 -lnl-3 $LIBS"
+ LIBS="-lnl-genl-3 -lnl-3 $LIBS"
AC_DEFINE(HAVE_LIBNL,1,[if libnl exists])
AC_DEFINE(HAVE_LIBNL_3_x,1,[if libnl exists and is version 3.x])
AC_DEFINE(HAVE_LIBNL_NLE,1,[libnl has NLE_FAILURE])
AC_DEFINE(HAVE_LIBNL_SOCKETS,1,[libnl has new-style socket api])
- V_INCLS="$V_INCLS ${incdir}"
have_any_nl="yes"
- ],[], ${incdir} ${libnldir} -lnl-genl-3 -lnl-3 )
+ ],[], -lnl-genl-3 -lnl-3 )
if test x$have_any_nl = xno ; then
#

View File

@ -51,6 +51,7 @@ endif
ifeq ($(BR2_PACKAGE_LIBNL),y)
LIBPCAP_DEPENDENCIES += libnl
LIBPCAP_CFLAGS += "-I$(STAGING_DIR)/usr/include/libnl3"
LIBPCAP_CONF_OPTS += --with-libnl=$(STAGING_DIR)/usr
else
LIBPCAP_CONF_OPTS += --without-libnl
endif