package/qemu: bump to version 8.1.0

Drop patch which is now upstream.

Replace no longer supported --with-git-submodules config option with
new --disable-download option.

Replace no longer supported --meson config option with --python config
option. The configure script expects --python to point to the python
interpreter with the meson installation.

Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
This commit is contained in:
James Hilliard 2023-08-25 16:49:11 -06:00 committed by Thomas Petazzoni
parent 4aa36a507c
commit a2888f439c
3 changed files with 5 additions and 43 deletions

View File

@ -1,38 +0,0 @@
From 9d9b74f806f5dbca53df6630c1a0591eaedd4500 Mon Sep 17 00:00:00 2001
From: Carlos Santos <casantos@redhat.com>
Date: Sun, 1 Jan 2023 21:00:57 -0300
Subject: [PATCH] meson: install keyboard maps only if necessary
They are required only for system emulation (i.e. have_system is true).
Upstream: https://patchwork.kernel.org/project/qemu-devel/patch/20230327172147.196607-1-casantos@redhat.com/
Signed-off-by: Carlos Santos <casantos@redhat.com>
Signed-off-by: Carlos Santos <unixmania@gmail.com>
---
pc-bios/keymaps/meson.build | 6 ++++--
1 file changed, 4 insertions(+), 2 deletions(-)
diff --git a/pc-bios/keymaps/meson.build b/pc-bios/keymaps/meson.build
index 158a3b410c..bff3083313 100644
--- a/pc-bios/keymaps/meson.build
+++ b/pc-bios/keymaps/meson.build
@@ -47,7 +47,7 @@ if native_qemu_keymap.found()
build_by_default: true,
output: km,
command: [native_qemu_keymap, '-f', '@OUTPUT@', args.split()],
- install: true,
+ install: have_system,
install_dir: qemu_datadir / 'keymaps')
endforeach
@@ -56,4 +56,6 @@ else
install_data(keymaps.keys(), install_dir: qemu_datadir / 'keymaps')
endif
-install_data(['sl', 'sv'], install_dir: qemu_datadir / 'keymaps')
+if have_system
+ install_data(['sl', 'sv'], install_dir: qemu_datadir / 'keymaps')
+endif
--
2.31.1

View File

@ -1,4 +1,4 @@
# Locally computed, tarball verified with GPG signature
sha256 ecf4d32cbef9d397bfc8cc50e4d1e92a1b30253bf32e8ee73c7a8dcf9a232b09 qemu-8.0.3.tar.xz
sha256 710c101198e334d4762eef65f649bc43fa8a5dd75303554b8acfec3eb25f0e55 qemu-8.1.0.tar.xz
sha256 6f04ae8364d0079a192b14635f4b1da294ce18724c034c39a6a41d1b09df6100 COPYING
sha256 dc626520dcd53a22f727af3ee42c770e56c97a64fe3adb063799d8ab032fe551 COPYING.LIB

View File

@ -6,7 +6,7 @@
# When updating the version, check whether the list of supported targets
# needs to be updated.
QEMU_VERSION = 8.0.3
QEMU_VERSION = 8.1.0
QEMU_SOURCE = qemu-$(QEMU_VERSION).tar.xz
QEMU_SITE = https://download.qemu.org
QEMU_LICENSE = GPL-2.0, LGPL-2.1, MIT, BSD-3-Clause, BSD-2-Clause, Others/BSD-1c
@ -272,7 +272,7 @@ define QEMU_CONFIGURE_CMDS
--prefix=/usr \
--cross-prefix=$(TARGET_CROSS) \
--audio-drv-list= \
--meson=$(HOST_DIR)/bin/meson \
--python=$(HOST_DIR)/bin/python3 \
--ninja=$(HOST_DIR)/bin/ninja \
--disable-alsa \
--disable-bpf \
@ -313,7 +313,7 @@ define QEMU_CONFIGURE_CMDS
--enable-attr \
--enable-kvm \
--enable-vhost-net \
--with-git-submodules=ignore \
--disable-download \
--disable-hexagon-idef-parser \
$(QEMU_OPTS)
endef
@ -458,7 +458,7 @@ define HOST_QEMU_CONFIGURE_CMDS
--host-cc="$(HOSTCC)" \
--extra-cflags="$(HOST_QEMU_CFLAGS)" \
--extra-ldflags="$(HOST_LDFLAGS)" \
--meson=$(HOST_DIR)/bin/meson \
--python=$(HOST_DIR)/bin/python3 \
--ninja=$(HOST_DIR)/bin/ninja \
--disable-alsa \
--disable-bpf \