package/python-requests: bump to version 2.26.0

Remove python3-requests host package and combine with python-requests.

Make packages depending on host-python3-requests depend on
host-python-requests instead.

Drop idna patch that is now upstream.

Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
This commit is contained in:
James Hilliard 2021-10-24 20:42:33 -06:00 committed by Arnout Vandecappelle (Essensium/Mind)
parent 88a8565de0
commit a0a9edb64c
9 changed files with 9 additions and 94 deletions

View File

@ -20,7 +20,7 @@ MONGODB_DEPENDENCIES = \
host-python3-psutil \
host-python3-pyyaml \
host-python3-regex \
host-python3-requests \
host-python-requests \
host-scons \
pcre \
snappy \

View File

@ -1,33 +0,0 @@
From d747c4753484aa9b90a094d6bf7ec45e5acfb623 Mon Sep 17 00:00:00 2001
From: Naor Livne <naorlivne@gmail.com>
Date: Wed, 7 Jul 2021 16:25:20 +0300
Subject: [PATCH] Allow idna 3.x to be installed on Python 3.x
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
Co-authored-by: Mickaël Schoentgen <contact@tiger-222.fr>
Co-authored-by: Seth Michael Larson <sethmichaellarson@gmail.com>
(cherry picked from commit 33cf965f7271ab4978ed551754db37865c4085db)
Signed-off-by: Romain Naour <romain.naour@gmail.com>
---
setup.py | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/setup.py b/setup.py
index 7ba4b2a2..83d78665 100755
--- a/setup.py
+++ b/setup.py
@@ -43,7 +43,8 @@ packages = ['requests']
requires = [
'chardet>=3.0.2,<5',
- 'idna>=2.5,<3',
+ 'idna>=2.5,<3; python_version < "3"',
+ 'idna>=2.5,<4; python_version >= "3"',
'urllib3>=1.21.1,<1.27',
'certifi>=2017.4.17'
--
2.31.1

View File

@ -2,7 +2,7 @@ config BR2_PACKAGE_PYTHON_REQUESTS
bool "python-requests"
depends on BR2_PACKAGE_PYTHON3 # python-idna
select BR2_PACKAGE_PYTHON_CERTIFI # runtime
select BR2_PACKAGE_PYTHON_CHARDET # runtime
select BR2_PACKAGE_PYTHON_CHARSET_NORMALIZER # runtime
select BR2_PACKAGE_PYTHON_IDNA # runtime
select BR2_PACKAGE_PYTHON_URLLIB3 # runtime
select BR2_PACKAGE_PYTHON3_SSL # runtime

View File

@ -1,5 +1,5 @@
# md5, sha256 from https://pypi.org/pypi/requests/json
md5 514d6f7eba77ada0b8c98ec7818828db requests-2.25.1.tar.gz
sha256 27973dd4a904a4f13b263a19c866c13b92a39ed1c964655f025f3f8d3d75b804 requests-2.25.1.tar.gz
md5 8c745949ad3e9ae83d9927fed213db8a requests-2.26.0.tar.gz
sha256 b8aa58f8cf793ffd8782d3d8cb19e66ef36f7aba4353eec859e74678b01b07a7 requests-2.26.0.tar.gz
# Locally computed sha256 checksums
sha256 09e8a9bcec8067104652c168685ab0931e7868f9c8284b66f5ae6edae5f1130b LICENSE

View File

@ -4,14 +4,15 @@
#
################################################################################
# Please keep in sync with package/python3-requests/python3-requests.mk
PYTHON_REQUESTS_VERSION = 2.25.1
PYTHON_REQUESTS_VERSION = 2.26.0
PYTHON_REQUESTS_SOURCE = requests-$(PYTHON_REQUESTS_VERSION).tar.gz
PYTHON_REQUESTS_SITE = https://files.pythonhosted.org/packages/6b/47/c14abc08432ab22dc18b9892252efaf005ab44066de871e72a38d6af464b
PYTHON_REQUESTS_SITE = https://files.pythonhosted.org/packages/e7/01/3569e0b535fb2e4a6c384bdbed00c55b9d78b5084e0fb7f4d0bf523d7670
PYTHON_REQUESTS_SETUP_TYPE = setuptools
PYTHON_REQUESTS_LICENSE = Apache-2.0
PYTHON_REQUESTS_LICENSE_FILES = LICENSE
PYTHON_REQUESTS_CPE_ID_VENDOR = python
PYTHON_REQUESTS_CPE_ID_PRODUCT = requests
HOST_PYTHON_REQUESTS_NEEDS_HOST_PYTHON = python3
$(eval $(python-package))
$(eval $(host-python-package))

View File

@ -1,33 +0,0 @@
From d747c4753484aa9b90a094d6bf7ec45e5acfb623 Mon Sep 17 00:00:00 2001
From: Naor Livne <naorlivne@gmail.com>
Date: Wed, 7 Jul 2021 16:25:20 +0300
Subject: [PATCH] Allow idna 3.x to be installed on Python 3.x
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
Co-authored-by: Mickaël Schoentgen <contact@tiger-222.fr>
Co-authored-by: Seth Michael Larson <sethmichaellarson@gmail.com>
(cherry picked from commit 33cf965f7271ab4978ed551754db37865c4085db)
Signed-off-by: Romain Naour <romain.naour@gmail.com>
---
setup.py | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/setup.py b/setup.py
index 7ba4b2a2..83d78665 100755
--- a/setup.py
+++ b/setup.py
@@ -43,7 +43,8 @@ packages = ['requests']
requires = [
'chardet>=3.0.2,<5',
- 'idna>=2.5,<3',
+ 'idna>=2.5,<3; python_version < "3"',
+ 'idna>=2.5,<4; python_version >= "3"',
'urllib3>=1.21.1,<1.27',
'certifi>=2017.4.17'
--
2.31.1

View File

@ -1 +0,0 @@
../python-requests/python-requests.hash

View File

@ -1,19 +0,0 @@
################################################################################
#
# python3-requests
#
################################################################################
# Please keep in sync with package/python-requests/python-requests.mk
PYTHON3_REQUESTS_VERSION = 2.25.1
PYTHON3_REQUESTS_SOURCE = requests-$(PYTHON3_REQUESTS_VERSION).tar.gz
PYTHON3_REQUESTS_SITE = https://files.pythonhosted.org/packages/6b/47/c14abc08432ab22dc18b9892252efaf005ab44066de871e72a38d6af464b
PYTHON3_REQUESTS_SETUP_TYPE = setuptools
PYTHON3_REQUESTS_LICENSE = Apache-2.0
PYTHON3_REQUESTS_LICENSE_FILES = LICENSE
PYTHON3_REQUESTS_CPE_ID_VENDOR = python
PYTHON3_REQUESTS_CPE_ID_PRODUCT = requests
HOST_PYTHON3_REQUESTS_DL_SUBDIR = python-requests
HOST_PYTHON3_REQUESTS_NEEDS_HOST_PYTHON = python3
$(eval $(host-python-package))

View File

@ -111,7 +111,7 @@ UHD_CONF_OPTS += -DENABLE_RFNOC=OFF
endif
ifeq ($(BR2_PACKAGE_UHD_PYTHON),y)
UHD_DEPENDENCIES += host-python-numpy host-python3-requests \
UHD_DEPENDENCIES += host-python-numpy host-python-requests \
python-numpy python-requests
UHD_CONF_OPTS += -DENABLE_PYTHON_API=ON
else