package/openblas: strip any optimization flag where needed

openblas strips off -O1-O3 for certain source files, but forgets to handle
-Os, -Og and -O. This means that the intended effect of 'no optimization' is
not always reached.

Signed-off-by: Thomas De Schampheleire <thomas.de_schampheleire@nokia.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
This commit is contained in:
Thomas De Schampheleire 2021-03-05 14:48:37 +01:00 committed by Peter Korsgaard
parent 2793167b57
commit a0508b5705

View File

@ -0,0 +1,31 @@
From ced08de1ad74811bc23d74121751537bfd8e9556 Mon Sep 17 00:00:00 2001
From: Thomas De Schampheleire <thomas.de_schampheleire@nokia.com>
Date: Fri, 5 Mar 2021 11:15:52 +0100
Subject: [PATCH] Makefile: also consider -O, -Og and -Os when stripping flags
gcc also supports -O, -Og and -Os as optimization flags.
They may be given on the make command-line by users.
For the calculation of LAPACK_NOOPT, all such flags should be considered.
Signed-off-by: Thomas De Schampheleire <thomas.de_schampheleire@nokia.com>
---
Makefile | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/Makefile b/Makefile
index a22e16ba..fc5fe3f5 100644
--- a/Makefile
+++ b/Makefile
@@ -32,7 +32,7 @@ export NOFORTRAN
export NO_LAPACK
endif
-LAPACK_NOOPT := $(filter-out -O0 -O1 -O2 -O3 -Ofast,$(LAPACK_FFLAGS))
+LAPACK_NOOPT := $(filter-out -O0 -O1 -O2 -O3 -Ofast -O -Og -Os,$(LAPACK_FFLAGS))
SUBDIRS_ALL = $(SUBDIRS) test ctest utest exports benchmark ../laswp ../bench cpp_thread_test
--
2.26.2