package/python{3}-requests: allow idna 3.x to be installed on python 3.x
The tests.package.test_docker_compose.TestDockerCompose is broken since the python-idna version bump to 3.0 because python-requests needs python-idna < 3.0. # docker-compose up -d Traceback (most recent call last): File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 583, in _build_master File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 900, in require File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 791, in resolve pkg_resources.ContextualVersionConflict: (idna 3.2 (/usr/lib/python3.9/site-packages), Requirement.parse('idna<3,>=2.5'), {'requests'}) During handling of the above exception, another exception occurred: Traceback (most recent call last): File "/usr/bin/docker-compose", line 6, in <module> from pkg_resources import load_entry_point File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 3252, in <module> File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 3235, in _call_aside File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 3264, in _initialize_master_working_set File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 585, in _build_master File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 598, in _build_from_requirements File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 786, in resolve pkg_resources.DistributionNotFound: The 'idna<3,>=2.5' distribution was not found and is required by requests Fixes: https://gitlab.com/kubu93/buildroot/-/jobs/1522848327 Signed-off-by: Romain Naour <romain.naour@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
This commit is contained in:
parent
5d60e07e27
commit
a0238b538f
@ -0,0 +1,33 @@
|
||||
From d747c4753484aa9b90a094d6bf7ec45e5acfb623 Mon Sep 17 00:00:00 2001
|
||||
From: Naor Livne <naorlivne@gmail.com>
|
||||
Date: Wed, 7 Jul 2021 16:25:20 +0300
|
||||
Subject: [PATCH] Allow idna 3.x to be installed on Python 3.x
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
Co-authored-by: Mickaël Schoentgen <contact@tiger-222.fr>
|
||||
Co-authored-by: Seth Michael Larson <sethmichaellarson@gmail.com>
|
||||
(cherry picked from commit 33cf965f7271ab4978ed551754db37865c4085db)
|
||||
Signed-off-by: Romain Naour <romain.naour@gmail.com>
|
||||
---
|
||||
setup.py | 3 ++-
|
||||
1 file changed, 2 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/setup.py b/setup.py
|
||||
index 7ba4b2a2..83d78665 100755
|
||||
--- a/setup.py
|
||||
+++ b/setup.py
|
||||
@@ -43,7 +43,8 @@ packages = ['requests']
|
||||
|
||||
requires = [
|
||||
'chardet>=3.0.2,<5',
|
||||
- 'idna>=2.5,<3',
|
||||
+ 'idna>=2.5,<3; python_version < "3"',
|
||||
+ 'idna>=2.5,<4; python_version >= "3"',
|
||||
'urllib3>=1.21.1,<1.27',
|
||||
'certifi>=2017.4.17'
|
||||
|
||||
--
|
||||
2.31.1
|
||||
|
@ -0,0 +1,33 @@
|
||||
From d747c4753484aa9b90a094d6bf7ec45e5acfb623 Mon Sep 17 00:00:00 2001
|
||||
From: Naor Livne <naorlivne@gmail.com>
|
||||
Date: Wed, 7 Jul 2021 16:25:20 +0300
|
||||
Subject: [PATCH] Allow idna 3.x to be installed on Python 3.x
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
Co-authored-by: Mickaël Schoentgen <contact@tiger-222.fr>
|
||||
Co-authored-by: Seth Michael Larson <sethmichaellarson@gmail.com>
|
||||
(cherry picked from commit 33cf965f7271ab4978ed551754db37865c4085db)
|
||||
Signed-off-by: Romain Naour <romain.naour@gmail.com>
|
||||
---
|
||||
setup.py | 3 ++-
|
||||
1 file changed, 2 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/setup.py b/setup.py
|
||||
index 7ba4b2a2..83d78665 100755
|
||||
--- a/setup.py
|
||||
+++ b/setup.py
|
||||
@@ -43,7 +43,8 @@ packages = ['requests']
|
||||
|
||||
requires = [
|
||||
'chardet>=3.0.2,<5',
|
||||
- 'idna>=2.5,<3',
|
||||
+ 'idna>=2.5,<3; python_version < "3"',
|
||||
+ 'idna>=2.5,<4; python_version >= "3"',
|
||||
'urllib3>=1.21.1,<1.27',
|
||||
'certifi>=2017.4.17'
|
||||
|
||||
--
|
||||
2.31.1
|
||||
|
Loading…
Reference in New Issue
Block a user