package/ruby: bump to 3.3.0

See here for changes:
https://www.ruby-lang.org/en/news/2023/12/25/ruby-3-3-0-released/

Patch applied upstream.

License file LEGAL changed.
[ext/psych/yaml] got removed.
[lib/bundler/vendor/molinillo] got removed.
[lib/bundler/vendor/pub_grub] added with MIT License.

Signed-off-by: Waldemar Brodkorb <wbx@openadk.org>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
This commit is contained in:
Waldemar Brodkorb 2024-01-27 03:20:54 +01:00 committed by Peter Korsgaard
parent 67b1eb8a6d
commit a01c278df7
4 changed files with 6 additions and 32 deletions

View File

@ -1182,7 +1182,6 @@ package/rtorrent/0001-Added--disable-execinfo-option-to-configure.patch Upstream
package/rtty/0001-CMakeLists.txt-prefer-pkg_check_modules.patch Upstream package/rtty/0001-CMakeLists.txt-prefer-pkg_check_modules.patch Upstream
package/rubix/0001-dont-use-legacy-functions.patch Upstream package/rubix/0001-dont-use-legacy-functions.patch Upstream
package/rubix/0002-misc-fixes.patch Sob Upstream package/rubix/0002-misc-fixes.patch Sob Upstream
package/ruby/0001-Fix-build-with-LibreSSL-3-5.patch Upstream
package/rygel/0001-build-Add-man_pages-build-options.patch Upstream package/rygel/0001-build-Add-man_pages-build-options.patch Upstream
package/rygel/0002-meson.build-fix-g_ir_compiler-calls.patch Upstream package/rygel/0002-meson.build-fix-g_ir_compiler-calls.patch Upstream
package/rygel/S99rygel Indent Shellcheck Variables package/rygel/S99rygel Indent Shellcheck Variables

View File

@ -1,25 +0,0 @@
From e25fb0d0d86da5a9398ebdc9216b2ea89f80fa3d Mon Sep 17 00:00:00 2001
From: Jeremy Evans <code@jeremyevans.net>
Date: Fri, 25 Mar 2022 13:11:31 -0700
Subject: [PATCH] Fix build with LibreSSL 3.5
[Retrieved from:
https://github.com/ruby/openssl/commit/e25fb0d0d86da5a9398ebdc9216b2ea89f80fa3d]
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
ext/openssl/ossl_pkey.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/ext/openssl/ossl_pkey.c b/ext/openssl/ossl_pkey.c
index 2a4835a2..24d0da46 100644
--- a/ext/openssl/ossl_pkey.c
+++ b/ext/openssl/ossl_pkey.c
@@ -710,7 +710,7 @@ ossl_pkey_export_traditional(int argc, VALUE *argv, VALUE self, int to_der)
}
}
else {
-#if OPENSSL_VERSION_NUMBER >= 0x10100000 && !defined(LIBRESSL_VERSION_NUMBER)
+#if OSSL_OPENSSL_PREREQ(1, 1, 0) || OSSL_LIBRESSL_PREREQ(3, 5, 0)
if (!PEM_write_bio_PrivateKey_traditional(bio, pkey, enc, NULL, 0,
ossl_pem_passwd_cb,
(void *)pass)) {

View File

@ -1,7 +1,7 @@
# https://www.ruby-lang.org/en/news/2022/11/24/ruby-3-1-3-released/ # https://www.ruby-lang.org/en/news/2023/12/25/ruby-3-3-0-released/
sha512 4b0fd334ae56132ba98b8a69adad54bdcf7f7aeabd5eba5b0f0399a3868e2054f9026ca1b1cb2dbb197a9e9b0610b263481949c0623a62071546bc5adff8ca69 ruby-3.1.3.tar.xz sha512 7959c5753bfa0bfc4d6d74060869aabbe9815c1c97930659da11b917ee0803ddbbd80e869e00c48b8694b4ba48709c3b6493fd045568e36e902616c35ababf01 ruby-3.3.0.tar.xz
# License files, Locally calculated # License files, Locally calculated
sha256 794c384f94396ab07e3e6f53a9f8be093facb7eb4193266024302b93b29e12dc LEGAL sha256 e849b28d324423e636a3e6bc5d583cdaf4bd046c2b20872c53886b612d01a4a1 LEGAL
sha256 967586d538a28955ec2541910cf63c5ac345fcdea94bfb1f1705a1f6eb36bcbb COPYING sha256 967586d538a28955ec2541910cf63c5ac345fcdea94bfb1f1705a1f6eb36bcbb COPYING
sha256 36a9a6e7347214bbba599a412617204e65bff065dcbe5c46f5cb454c80de9eb0 BSDL sha256 36a9a6e7347214bbba599a412617204e65bff065dcbe5c46f5cb454c80de9eb0 BSDL

View File

@ -4,9 +4,9 @@
# #
################################################################################ ################################################################################
RUBY_VERSION_MAJOR = 3.1 RUBY_VERSION_MAJOR = 3.3
RUBY_VERSION = $(RUBY_VERSION_MAJOR).3 RUBY_VERSION = $(RUBY_VERSION_MAJOR).0
RUBY_VERSION_EXT = 3.1.0 RUBY_VERSION_EXT = 3.3.0
RUBY_SITE = http://cache.ruby-lang.org/pub/ruby/$(RUBY_VERSION_MAJOR) RUBY_SITE = http://cache.ruby-lang.org/pub/ruby/$(RUBY_VERSION_MAJOR)
RUBY_SOURCE = ruby-$(RUBY_VERSION).tar.xz RUBY_SOURCE = ruby-$(RUBY_VERSION).tar.xz