uClibc: bump 0.9.32.x version to 0.9.32.1
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
This commit is contained in:
parent
bea251c696
commit
9fd4c35058
@ -32,7 +32,7 @@ config BR2_USE_UCLIBC_SNAPSHOT
|
||||
config BR2_UCLIBC_VERSION_STRING
|
||||
string
|
||||
default 0.9.31.1 if BR2_UCLIBC_VERSION_0_9_31
|
||||
default 0.9.32 if BR2_UCLIBC_VERSION_0_9_32
|
||||
default 0.9.32.1 if BR2_UCLIBC_VERSION_0_9_32
|
||||
default $BR2_USE_UCLIBC_SNAPSHOT if BR2_UCLIBC_VERSION_SNAPSHOT
|
||||
|
||||
config BR2_UCLIBC_CONFIG
|
||||
|
@ -1,31 +0,0 @@
|
||||
>From 826984dee547b41238dc9572a1c756506a3c9148 Mon Sep 17 00:00:00 2001
|
||||
From: Jason Woodward <jason.woodward@timesys.com>
|
||||
Date: Sat, 11 Jun 2011 19:09:53 -0400
|
||||
Subject: [PATCH] Fix e500 fpu libm build
|
||||
|
||||
Define libm_ARCH_fpu_OUT in libm/powerpc/e500/Makefile.arch as it is used
|
||||
in libm/powerpc/e500/fpu/Makefile.arch
|
||||
|
||||
libm_ARCH_OBJ:=$(patsubst $(libm_ARCH_fpu_DIR)/%.c,$(libm_ARCH_fpu_OUT)/%.o,$(libm_ARCH_SRC))
|
||||
|
||||
This appears to have been broken since cd3a494e99fa4bcad1c2a621b71361005528bead
|
||||
|
||||
Signed-off-by: Jason Woodward <jason.woodward@timesys.com>
|
||||
---
|
||||
libm/powerpc/e500/Makefile.arch | 1 +
|
||||
1 files changed, 1 insertions(+), 0 deletions(-)
|
||||
|
||||
diff --git a/libm/powerpc/e500/Makefile.arch b/libm/powerpc/e500/Makefile.arch
|
||||
index 912ce7f..febde67 100644
|
||||
--- a/libm/powerpc/e500/Makefile.arch
|
||||
+++ b/libm/powerpc/e500/Makefile.arch
|
||||
@@ -6,5 +6,6 @@
|
||||
#
|
||||
|
||||
libm_ARCH_fpu_DIR := $(libm_SUBARCH_DIR)/fpu
|
||||
+libm_ARCH_fpu_OUT := $(libm_SUBARCH_OUT)/fpu
|
||||
-include $(libm_ARCH_fpu_DIR)/Makefile.arch
|
||||
|
||||
--
|
||||
1.7.0.4
|
||||
|
@ -1,36 +0,0 @@
|
||||
From 47f3da1cf49377c25772bb54d07db55225bbb142 Mon Sep 17 00:00:00 2001
|
||||
From: Guillaume Bourcier <guillaumebourcier@free.fr>
|
||||
Date: Tue, 11 Oct 2011 13:45:33 +0200
|
||||
Subject: [PATCH] libc: fix daylight saving time handling
|
||||
|
||||
The algorithm computing daylight saving time incorrectly adds a day for
|
||||
each month after January for leap years. The clock shift from/to DST can
|
||||
be delayed if the last Sunday of a transition month is exactly seven
|
||||
days before the first of the following month.
|
||||
|
||||
This change adds a day for the February month only.
|
||||
|
||||
Signed-off-by: Guillaume Bourcier <guillaumebourcier@free.fr>
|
||||
Signed-off-by: Richard Braun <rbraun@sceen.net>
|
||||
Signed-off-by: Carmelo Amoroso <carmelo.amoroso@st.com>
|
||||
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
|
||||
---
|
||||
libc/misc/time/time.c | 2 +-
|
||||
1 files changed, 1 insertions(+), 1 deletions(-)
|
||||
|
||||
diff --git a/libc/misc/time/time.c b/libc/misc/time/time.c
|
||||
index 19d68e1..8e2ebf1 100644
|
||||
--- a/libc/misc/time/time.c
|
||||
+++ b/libc/misc/time/time.c
|
||||
@@ -689,7 +689,7 @@ static int tm_isdst(register const struct tm *__restrict ptm,
|
||||
++day;
|
||||
}
|
||||
monlen = 31 + day_cor[r->month -1] - day_cor[r->month];
|
||||
- if (isleap && (r->month > 1)) {
|
||||
+ if (isleap && (r->month == 2)) {
|
||||
++monlen;
|
||||
}
|
||||
/* Wweekday (0 is Sunday) of 1st of the month
|
||||
--
|
||||
1.7.3.4
|
||||
|
@ -1,28 +0,0 @@
|
||||
>From 69d9cf20955d0222a5a2631021bc10854ea98128 Mon Sep 17 00:00:00 2001
|
||||
From: Jason Woodward <jason.woodward@timesys.com>
|
||||
Date: Sat, 11 Jun 2011 20:39:33 -0400
|
||||
Subject: [PATCH] honor UCLIBC_HAS_FENV for e500
|
||||
|
||||
Signed-off-by: Jason Woodward <jason.woodward@timesys.com>
|
||||
---
|
||||
libm/powerpc/e500/fpu/Makefile.arch | 2 ++
|
||||
1 files changed, 2 insertions(+), 0 deletions(-)
|
||||
|
||||
diff --git a/libm/powerpc/e500/fpu/Makefile.arch b/libm/powerpc/e500/fpu/Makefile.arch
|
||||
index 8f00e09..904561e 100644
|
||||
--- a/libm/powerpc/e500/fpu/Makefile.arch
|
||||
+++ b/libm/powerpc/e500/fpu/Makefile.arch
|
||||
@@ -6,8 +6,10 @@
|
||||
#
|
||||
|
||||
|
||||
+ifeq ($(UCLIBC_HAS_FENV),y)
|
||||
libm_ARCH_SRC:=$(wildcard $(libm_ARCH_fpu_DIR)/*.c)
|
||||
libm_ARCH_OBJ:=$(patsubst $(libm_ARCH_fpu_DIR)/%.c,$(libm_ARCH_fpu_OUT)/%.o,$(libm_ARCH_SRC))
|
||||
+endif
|
||||
|
||||
libm_ARCH_OBJS:=$(libm_ARCH_OBJ)
|
||||
|
||||
--
|
||||
1.7.0.4
|
||||
|
Loading…
Reference in New Issue
Block a user