package/umtprd: add patch to fix output_dir make dependency
Object file targets need to depend on the output_dir target.
Upstream commit:
d84216a678
Fixes:
- http://autobuild.buildroot.net/results/c7ce975d398190fc191ccc03813f8ec0b3464c7d/
- http://autobuild.buildroot.net/results/0331fb9cf2748b16440ef830d09452a9812f5217/
- http://autobuild.buildroot.net/results/a1b1de9e2f764ce22f23d8a8ea88f7ddcf2969a9/
- http://autobuild.buildroot.net/results/7c7dbe03d769dc5f155fc14102f6591855605640/
- http://autobuild.buildroot.net/results/6cd90b7877520669d9ab9c9fadc9fa36912963b4/
- http://autobuild.buildroot.net/results/186689fc9637ae1a8330d7e19057cd1b3c9a841c/
Signed-off-by: Paul Cercueil <paul@crapouillou.net>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
This commit is contained in:
parent
2d5a94b742
commit
9f1a357452
46
package/umtprd/0001-Fix-output_dir-make-dependency.patch
Normal file
46
package/umtprd/0001-Fix-output_dir-make-dependency.patch
Normal file
@ -0,0 +1,46 @@
|
||||
From d84216a678edaca81c0899318231cdcca2100d38 Mon Sep 17 00:00:00 2001
|
||||
From: James Hilliard <james.hilliard1@gmail.com>
|
||||
Date: Mon, 17 Oct 2022 16:39:56 -0600
|
||||
Subject: [PATCH] Fix output_dir make dependency
|
||||
|
||||
Object file targets need to depend on the output_dir target.
|
||||
|
||||
Fixes:
|
||||
make --shuffle=reverse -j1
|
||||
cc -o obj/mtp_op_truncateobject.o src/mtp_operations/mtp_op_truncateobject.c -c -I./inc -lpthread -Wall -O3
|
||||
Assembler messages:
|
||||
Fatal error: can't create obj/mtp_op_truncateobject.o: No such file or directory
|
||||
make: *** [Makefile:19: obj/mtp_op_truncateobject.o] Error 1 shuffle=reverse
|
||||
|
||||
[paul@crapouillou.net: Backport from upstream commit d84216a]
|
||||
Signed-off-by: Paul Cercueil <paul@crapouillou.net>
|
||||
---
|
||||
Makefile | 6 +++---
|
||||
1 file changed, 3 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/Makefile b/Makefile
|
||||
index 7c98b63..c28e186 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -7,15 +7,15 @@ objects := $(sources:src/%.c=obj/%.o)
|
||||
ops_sources := $(wildcard src/mtp_operations/*.c)
|
||||
ops_objects := $(ops_sources:src/mtp_operations/%.c=obj/%.o)
|
||||
|
||||
-all: output_dir umtprd
|
||||
+all: umtprd
|
||||
|
||||
umtprd: $(objects) $(ops_objects)
|
||||
${CC} -o $@ $^ $(LDFLAGS) -lpthread
|
||||
|
||||
-$(objects): obj/%.o: src/%.c
|
||||
+$(objects): obj/%.o: src/%.c | output_dir
|
||||
${CC} -o $@ $^ -c $(CPPFLAGS) $(CFLAGS)
|
||||
|
||||
-$(ops_objects): obj/%.o: src/mtp_operations/%.c
|
||||
+$(ops_objects): obj/%.o: src/mtp_operations/%.c | output_dir
|
||||
${CC} -o $@ $^ -c $(CPPFLAGS) $(CFLAGS)
|
||||
|
||||
output_dir:
|
||||
--
|
||||
2.35.1
|
||||
|
Loading…
Reference in New Issue
Block a user