package/lsof: drop first and third patches
Set LSOF_AR and LSOF_CC to be able to drop first patch which is not upstreamable: https://github.com/lsof-org/lsof/issues/197 $(TARGET_CONFIGURE_OPTS) must also be removed to avoid overriding AR and so we can drop LSOF_CFLAGS_OVERRIDE=1 and third patch DEBUG="$(TARGET_CFLAGS)" can also be dropped from LSOF_BUILD_CMDS as it is already set in LSOF_CONFIGURE_CMDS Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> [Arnout: add quotes around TARGET_CC] Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
This commit is contained in:
parent
1fe5029122
commit
9e9d9b2279
@ -1,14 +0,0 @@
|
||||
diff -ru lsof_4.81.orig/lsof_4.81_src/lib/Makefile.skel lsof_4.81/lsof_4.81_src/lib/Makefile.skel
|
||||
--- a/lib/Makefile.skel 2001-02-13 03:12:22.000000000 +0100
|
||||
+++ b/lib/Makefile.skel 2006-11-29 13:51:44.000000000 +0100
|
||||
@@ -21,8 +21,8 @@
|
||||
all: ${LIB}
|
||||
|
||||
${LIB}: ${OBJ}
|
||||
- ${AR}
|
||||
- ${RANLIB}
|
||||
+ ${AR} cr ${LIB} ${OBJ}
|
||||
+ ${RANLIB} ${LIB}
|
||||
|
||||
clean: FRC
|
||||
rm -f ${LIB} ${OBJ} errs Makefile.bak a.out core
|
@ -1,13 +0,0 @@
|
||||
--- lsof_4.84/Configure 2008-10-21 18:21:45.000000000 +0200
|
||||
+++ lsof_4.84/Configure 2010-11-03 14:00:00.000000000 +0100
|
||||
@@ -5206,6 +5206,10 @@
|
||||
cp $LSOF_MKFC ${LSOF_LIB}/$LSOF_LIBMKF
|
||||
fi # }
|
||||
cat ./dialects/$LSOF_DIALECT_DIR/$LSOF_REST >> $LSOF_MKFC
|
||||
+if test "X$LSOF_CFLAGS_OVERRIDE" != "X" # {
|
||||
+then
|
||||
+ sed -i -e 's/^CFLAGS=/override CFLAGS=/' $LSOF_MKFC
|
||||
+fi # }
|
||||
if test "X$LSOF_LIB_NO" = "X" # {
|
||||
then
|
||||
|
@ -33,7 +33,8 @@ endif
|
||||
define LSOF_CONFIGURE_CMDS
|
||||
(cd $(@D) ; \
|
||||
echo n | $(TARGET_CONFIGURE_OPTS) DEBUG="$(TARGET_CFLAGS)" \
|
||||
LSOF_INCLUDE="$(STAGING_DIR)/usr/include" LSOF_CFLAGS_OVERRIDE=1 \
|
||||
LSOF_AR="$(TARGET_AR) cr" LSOF_CC="$(TARGET_CC)" \
|
||||
LSOF_INCLUDE="$(STAGING_DIR)/usr/include" \
|
||||
LINUX_CLIB=-DGLIBCV=2 LSOF_CFGL="$(TARGET_LDFLAGS)" \
|
||||
./Configure linux)
|
||||
$(LSOF_CONFIGURE_WCHAR_FIXUPS)
|
||||
@ -41,7 +42,7 @@ define LSOF_CONFIGURE_CMDS
|
||||
endef
|
||||
|
||||
define LSOF_BUILD_CMDS
|
||||
$(TARGET_MAKE_ENV) $(MAKE) $(TARGET_CONFIGURE_OPTS) DEBUG="$(TARGET_CFLAGS)" -C $(@D)
|
||||
$(TARGET_MAKE_ENV) $(MAKE) -C $(@D)
|
||||
endef
|
||||
|
||||
define LSOF_INSTALL_TARGET_CMDS
|
||||
|
Loading…
Reference in New Issue
Block a user