- add a layer 2 tunneling protocol package

This commit is contained in:
Bernhard Reutner-Fischer 2007-01-31 21:22:33 +00:00
parent f0be91fd17
commit 9e453fb42d
7 changed files with 3066 additions and 0 deletions

View File

@ -130,6 +130,7 @@ source "package/hostap/Config.in"
source "package/iproute2/Config.in"
source "package/ipsec-tools/Config.in"
source "package/iptables/Config.in"
source "package/l2tp/Config.in"
source "package/libcgi/Config.in"
source "package/libcgicc/Config.in"
source "package/libpcap/Config.in"

8
package/l2tp/Config.in Normal file
View File

@ -0,0 +1,8 @@
config BR2_PACKAGE_L2TP
bool "l2tp"
default n
help
Layer 2 Tunnelling Protocol (RFC2661).
http://sourceforge.net/projects/l2tpd/

View File

@ -0,0 +1,14 @@
--- l2tpd-0.70-pre20031121.oorig/osport.h 2004-07-08 22:47:52.000000000 +0200
+++ l2tpd-0.70-pre20031121/osport.h 2006-12-28 15:32:50.000000000 +0100
@@ -37,4 +37,11 @@
#endif /* defined(SOLARIS) */
+#if defined __UCLIBC__ && !defined UCLIBC_SUSV3_LEGACY_MACROS
+# define index(x, y) strchr(x, y)
+# define bcopy(S1, S2, LEN) ((void)memmove(S2, S1, LEN))
+# define bzero(S1, LEN) ((void)memset(S1, 0, LEN))
+# define bcmp(S1,S2,LEN) ((memcmp(S2, S1, LEN)==0)?0:1)
+#endif /* defined __UCLIBC__ && !defined UCLIBC_SUSV3_LEGACY_MACROS */
+
#endif /* _OSPORT_H_ */

View File

@ -0,0 +1,33 @@
--- l2tpd-0.70-pre20031121.oorig/avpsend.c 2006-12-28 16:00:26.000000000 +0100
+++ l2tpd-0.70-pre20031121/avpsend.c 2006-12-28 16:21:06.000000000 +0100
@@ -98,19 +98,26 @@ int add_hostname_avp(struct buffer *buf,
int sz = 0;
if(t->lac && t->lac->hostname[0]) {
strncpy(n,t->lac->hostname, sizeof(n));
- sz = strnlen(t->lac->hostname, sizeof(t->lac->hostname));
+ sz = strlen(t->lac->hostname);
+ if (sz > sizeof(t->lac->hostname))
+ sz = sizeof(t->lac->hostname);
}
else if(t->lns && t->lns->hostname[0]) {
strncpy(n,t->lns->hostname, sizeof(n));
- sz = strnlen(t->lns->hostname, sizeof(t->lns->hostname));
+ sz = strlen(t->lns->hostname);
+ if (sz > sizeof(t->lns->hostname))
+ sz = sizeof(t->lns->hostname);
}
else {
if(gethostname(n, STRLEN)) {
strcpy(n,"eriwan");
sz = 6;
}
- else
- sz = strnlen(n, sizeof(n));
+ else {
+ sz = strlen(n);
+ if (sz > sizeof(n))
+ sz = sizeof(n);
+ }
}
if(add_avp(buf, HOSTNAME_AVP, n, sz, 1))
return 1;

File diff suppressed because it is too large Load Diff

View File

@ -0,0 +1,49 @@
diff -rdup l2tpd-0.70-pre20031121.oorig/avp.c l2tpd-0.70-pre20031121/avp.c
--- l2tpd-0.70-pre20031121.oorig/avp.c 2006-12-28 16:00:26.000000000 +0100
+++ l2tpd-0.70-pre20031121/avp.c 2006-12-28 16:06:43.000000000 +0100
@@ -146,6 +146,7 @@ int validate_msgtype_avp(int attr, stru
u_int8_t *p = data + sizeof(struct avp_hdr);
c->msgtype = get16(p);
+#ifdef SANITY
if (t->sanity)
{
/*
@@ -293,6 +294,7 @@ int validate_msgtype_avp(int attr, stru
return -EINVAL;
}
}
+#endif
return 0;
}
@@ -301,7 +303,7 @@ int validate_gen_avp(int attr, struct t
void *data, int datalen) {
(void)data; (void)datalen;
int i = 0, found = 0;
-
+#ifdef SANITY
if(t->sanity) {
for(i = 0; i < 8; i++) {
if(c->msgtype == avps[attr].allowed_states[i])
@@ -310,6 +312,7 @@ int validate_gen_avp(int attr, struct t
if(!found)
return -EINVAL;
}
+#endif
return 0;
}
diff -rdup l2tpd-0.70-pre20031121.oorig/l2tpd.c l2tpd-0.70-pre20031121/l2tpd.c
--- l2tpd-0.70-pre20031121.oorig/l2tpd.c 2006-12-28 16:00:26.000000000 +0100
+++ l2tpd-0.70-pre20031121/l2tpd.c 2006-12-28 16:04:15.000000000 +0100
@@ -748,7 +748,9 @@ struct tunnel *new_tunnel ()
tmp->peer.sin_family = AF_INET;
tmp->peer.sin_port = 0;
bzero (&(tmp->peer.sin_addr), sizeof (tmp->peer.sin_addr));
+#ifdef SANITY
tmp->sanity = -1;
+#endif
tmp->qtid = -1;
tmp->ourfc = ASYNC_FRAMING | SYNC_FRAMING;
tmp->ourbc = 0;

59
package/l2tp/l2tp.mk Normal file
View File

@ -0,0 +1,59 @@
#############################################################
#
# l2tp
#
#############################################################
L2TP_VER:=0.70-pre20031121
L2TP_SOURCE:=l2tpd_$(L2TP_VER).orig.tar.gz
L2TP_PATCH:=l2tpd_$(L2TP_VER)-2.1.diff.gz
L2TP_SITE:=ftp://ftp.debian.org/debian/pool/main/l/l2tpd/
L2TP_DIR:=$(BUILD_DIR)/l2tpd-$(L2TP_VER)
L2TP_CAT:=$(ZCAT)
L2TP_BINARY:=l2tpd
L2TP_TARGET_BINARY:=usr/sbin/l2tpd
$(DL_DIR)/$(L2TP_SOURCE):
$(WGET) -P $(DL_DIR) $(L2TP_SITE)/$(L2TP_SOURCE)
$(DL_DIR)/$(L2TP_PATCH):
$(WGET) -P $(DL_DIR) $(L2TP_SITE)/$(L2TP_PATCH)
l2tp-source: $(DL_DIR)/$(L2TP_SOURCE) $(DL_DIR)/$(L2TP_PATCH)
$(L2TP_DIR)/.unpacked: $(DL_DIR)/$(L2TP_SOURCE) $(DL_DIR)/$(L2TP_PATCH)
$(L2TP_CAT) $(DL_DIR)/$(L2TP_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
-mv -f $(L2TP_DIR).orig $(L2TP_DIR)
ifneq ($(L2TP_PATCH),)
(cd $(L2TP_DIR) && $(L2TP_CAT) $(DL_DIR)/$(L2TP_PATCH) | patch -p1)
if [ -d $(L2TP_DIR)/debian/patches ]; then \
toolchain/patch-kernel.sh $(L2TP_DIR) $(L2TP_DIR)/debian/patches \*.patch ; \
fi
endif
toolchain/patch-kernel.sh $(L2TP_DIR) package/l2tp/ l2tp\*.patch
touch $(L2TP_DIR)/.unpacked
$(L2TP_DIR)/$(L2TP_BINARY): $(L2TP_DIR)/.unpacked
$(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(L2TP_DIR) CC=$(TARGET_CC) \
DFLAGS= \
OSFLAGS="-DLINUX -UUSE_KERNEL $(TARGET_CFLAGS) -USANITY"
$(TARGET_DIR)/$(L2TP_TARGET_BINARY): $(L2TP_DIR)/$(L2TP_BINARY)
cp -dpf $(L2TP_DIR)/$(L2TP_BINARY) $@
$(STRIP) $@
l2tp: uclibc $(TARGET_DIR)/$(L2TP_TARGET_BINARY)
l2tp-clean:
-$(MAKE) -C $(L2TP_DIR) clean
rm -f $(TARGET_DIR)/$(L2TP_TARGET_BINARY)
l2tp-dirclean:
rm -rf $(L2TP_DIR)
#############################################################
#
# Toplevel Makefile options
#
#############################################################
ifeq ($(strip $(BR2_PACKAGE_L2TP)),y)
TARGETS+=l2tp
endif