libuci: bump version and remove obsolete patch

The uci-fix-Lua-finding.patch was upstreamed, so remove it.

Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
This commit is contained in:
Yegor Yefremov 2014-04-08 10:03:34 +02:00 committed by Peter Korsgaard
parent 03d516f517
commit 9d3c0b5c22
2 changed files with 1 additions and 32 deletions

View File

@ -1,31 +0,0 @@
From 980432ce260020ed8a907b3bbc1334845ba4c4a9 Mon Sep 17 00:00:00 2001
From: Yegor Yefremov <yegorslists@googlemail.com>
Date: Sat, 5 Apr 2014 19:18:10 +0200
Subject: [PATCH] uci: fix Lua finding
If ${LUAPATH} is not quoted and Lua is not provided, then following
error occurs:
"NOT" "No such file or directory" "EQUAL" "0" "OR" "EQUAL" ""
Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
---
lua/CMakeLists.txt | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/lua/CMakeLists.txt b/lua/CMakeLists.txt
index e4295d7..4ba8e37 100644
--- a/lua/CMakeLists.txt
+++ b/lua/CMakeLists.txt
@@ -36,7 +36,7 @@ IF(NOT LUAPATH)
)
IF(BUILD_LUA)
- IF(NOT ${LUA_CHECK_RES} EQUAL 0 OR ${LUAPATH} EQUAL "")
+ IF(NOT ${LUA_CHECK_RES} EQUAL 0 OR "${LUAPATH}" EQUAL "")
MESSAGE(SEND_ERROR "Lua was not found on your system")
ENDIF()
ENDIF()
--
1.8.3.2

View File

@ -4,7 +4,7 @@
#
################################################################################
LIBUCI_VERSION = 262fede3e8c8c08c1eb0d1be9bf102232fb86cb9
LIBUCI_VERSION = ed938cc8e423d4a33b8f31e6e6d1eb0805ae3d10
LIBUCI_SITE = git://nbd.name/uci.git
LIBUCI_LICENSE = LGPLv2.1
LIBUCI_INSTALL_STAGING = YES