package/libglib2: bump to version 2.72.3
Rebase remove cpp requirement patch. Signed-off-by: James Hilliard <james.hilliard1@gmail.com> Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
This commit is contained in:
parent
aac5e85726
commit
9c92e958b3
@ -1,4 +1,4 @@
|
||||
From 2f168951df1feebeac549ada1ea44ea092484c54 Mon Sep 17 00:00:00 2001
|
||||
From dd65a8cfdeafeb18b72d8d1eb676c7ca43ae505f Mon Sep 17 00:00:00 2001
|
||||
From: Adam Duskett <Aduskett@gmail.com>
|
||||
Date: Mon, 16 Sep 2019 10:12:38 -0700
|
||||
Subject: [PATCH] remove cpp requirement
|
||||
@ -12,15 +12,14 @@ Upstream status: Denied (Buildroot specific)
|
||||
https://gitlab.gnome.org/GNOME/glib/issues/1748
|
||||
---
|
||||
glib/glibconfig.h.in | 1 -
|
||||
meson.build | 18 +-----------------
|
||||
tests/meson.build | 5 -----
|
||||
3 files changed, 1 insertion(+), 23 deletions(-)
|
||||
meson.build | 19 +------------------
|
||||
2 files changed, 1 insertion(+), 19 deletions(-)
|
||||
|
||||
diff --git a/glib/glibconfig.h.in b/glib/glibconfig.h.in
|
||||
index 7ef8c48..128e65d 100644
|
||||
index e66748d95..2173d8be6 100644
|
||||
--- a/glib/glibconfig.h.in
|
||||
+++ b/glib/glibconfig.h.in
|
||||
@@ -117,7 +117,6 @@ typedef unsigned @glib_intptr_type_define@ guintptr;
|
||||
@@ -119,7 +119,6 @@ typedef unsigned @glib_intptr_type_define@ guintptr;
|
||||
@glib_vacopy@
|
||||
|
||||
@g_have_iso_c_varargs@
|
||||
@ -29,15 +28,15 @@ index 7ef8c48..128e65d 100644
|
||||
/* gcc-2.95.x supports both gnu style and ISO varargs, but if -ansi
|
||||
* is passed ISO vararg support is turned off, and there is no work
|
||||
diff --git a/meson.build b/meson.build
|
||||
index 4bbf4c2..ac59f4e 100644
|
||||
index 48fdfe864..5df242e39 100644
|
||||
--- a/meson.build
|
||||
+++ b/meson.build
|
||||
@@ -1,4 +1,4 @@
|
||||
-project('glib', 'c', 'cpp',
|
||||
+project('glib', 'c',
|
||||
version : '2.70.4',
|
||||
# NOTE: We keep this pinned at 0.49 because that's what Debian 10 ships
|
||||
meson_version : '>= 0.49.2',
|
||||
version : '2.72.3',
|
||||
# NOTE: We keep this pinned at 0.52 because that's what Debian Stable ships
|
||||
meson_version : '>= 0.52.0',
|
||||
@@ -10,7 +10,6 @@ project('glib', 'c', 'cpp',
|
||||
)
|
||||
|
||||
@ -46,7 +45,15 @@ index 4bbf4c2..ac59f4e 100644
|
||||
|
||||
cc_can_run = not meson.is_cross_build() or meson.has_exe_wrapper()
|
||||
|
||||
@@ -1696,20 +1695,6 @@ if g_have_iso_c_varargs
|
||||
@@ -495,7 +494,6 @@ else
|
||||
endif
|
||||
|
||||
add_project_arguments(cc.get_supported_arguments(warning_c_args), language: 'c')
|
||||
-add_project_arguments(cxx.get_supported_arguments(warning_cxx_args), language: 'cpp')
|
||||
|
||||
# FIXME: We cannot build some of the GResource tests with -z nodelete, which
|
||||
# means we cannot use that flag in add_project_link_arguments(), and must add
|
||||
@@ -1734,20 +1732,6 @@ if g_have_iso_c_varargs
|
||||
#endif''')
|
||||
endif
|
||||
|
||||
@ -67,7 +74,7 @@ index 4bbf4c2..ac59f4e 100644
|
||||
g_have_gnuc_varargs = cc.compiles('''
|
||||
void some_func (void) {
|
||||
int a(int p1, int p2, int p3);
|
||||
@@ -2339,7 +2324,6 @@ subdir('gobject')
|
||||
@@ -2381,7 +2365,6 @@ subdir('gobject')
|
||||
subdir('gthread')
|
||||
subdir('gmodule')
|
||||
subdir('gio')
|
||||
@ -75,22 +82,6 @@ index 4bbf4c2..ac59f4e 100644
|
||||
if build_tests
|
||||
subdir('tests')
|
||||
endif
|
||||
diff --git a/tests/meson.build b/tests/meson.build
|
||||
index e4ea226..7fd974c 100644
|
||||
--- a/tests/meson.build
|
||||
+++ b/tests/meson.build
|
||||
@@ -55,11 +55,6 @@ tests = {
|
||||
'source': 'module-test.c',
|
||||
'c_args': ['-DMODULE_TYPE="plugin"'],
|
||||
},
|
||||
- 'cxx-test' : {
|
||||
- 'source' : 'cxx-test.cpp',
|
||||
- 'include_directories' : gmoduleinc,
|
||||
- 'dependencies' : [libgio_dep],
|
||||
- },
|
||||
}
|
||||
|
||||
test_extra_programs = {
|
||||
--
|
||||
2.23.0
|
||||
2.34.1
|
||||
|
||||
|
@ -1,4 +1,4 @@
|
||||
# https://download.gnome.org/sources/glib/2.70/glib-2.70.4.sha256sum
|
||||
sha256 ab3d176f3115dcc4e5d02db795984e04e4f4b48d836252e23e8c468e9d423c33 glib-2.70.4.tar.xz
|
||||
# https://download.gnome.org/sources/glib/2.72/glib-2.72.3.sha256sum
|
||||
sha256 4a39a2f624b8512d500d5840173eda7fa85f51c109052eae806acece85d345f0 glib-2.72.3.tar.xz
|
||||
# License files, locally calculated
|
||||
sha256 dc626520dcd53a22f727af3ee42c770e56c97a64fe3adb063799d8ab032fe551 COPYING
|
||||
|
@ -4,8 +4,8 @@
|
||||
#
|
||||
################################################################################
|
||||
|
||||
LIBGLIB2_VERSION_MAJOR = 2.70
|
||||
LIBGLIB2_VERSION = $(LIBGLIB2_VERSION_MAJOR).4
|
||||
LIBGLIB2_VERSION_MAJOR = 2.72
|
||||
LIBGLIB2_VERSION = $(LIBGLIB2_VERSION_MAJOR).3
|
||||
LIBGLIB2_SOURCE = glib-$(LIBGLIB2_VERSION).tar.xz
|
||||
LIBGLIB2_SITE = http://ftp.gnome.org/pub/gnome/sources/glib/$(LIBGLIB2_VERSION_MAJOR)
|
||||
LIBGLIB2_LICENSE = LGPL-2.1+
|
||||
|
Loading…
Reference in New Issue
Block a user