package/sslh: bump to version 2.0.1

libev is an optional dependency since version 2.0 and
711c11c820

https://github.com/yrutschle/sslh/blob/v2.0.1/ChangeLog

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
This commit is contained in:
Fabrice Fontaine 2023-10-16 22:50:50 +02:00 committed by Thomas Petazzoni
parent 810a7bba04
commit 9c7e0f0119
3 changed files with 68 additions and 2 deletions

View File

@ -0,0 +1,59 @@
From 3e93c1d43de8a662e402127462f28ef0bebf8997 Mon Sep 17 00:00:00 2001
From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Date: Sun, 1 Oct 2023 18:45:53 +0200
Subject: [PATCH] Makefile: add USE_LIBEV
Add USE_LIBEV to avoid the following build failure without libev raised
since version 2.0 and
https://github.com/yrutschle/sslh/commit/711c11c820f8be4f1399024bcaa1d7072de33217:
sslh-ev.c:24:10: fatal error: ev.h: Aucun fichier ou dossier de ce type
24 | #include <ev.h>
| ^~~~~~
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Upstream: https://github.com/yrutschle/sslh/commit/3e93c1d43de8a662e402127462f28ef0bebf8997
---
Makefile | 8 ++++++--
1 file changed, 6 insertions(+), 2 deletions(-)
diff --git a/Makefile b/Makefile
index a4425c3..aa2689e 100644
--- a/Makefile
+++ b/Makefile
@@ -6,6 +6,7 @@ VERSION=$(shell ./genver.sh -r)
ENABLE_SANITIZER= # Enable ASAN/LSAN/UBSAN
ENABLE_REGEX=1 # Enable regex probes
USELIBCONFIG=1 # Use libconfig? (necessary to use configuration files)
+USELIBEV=1 # Use libev?
USELIBWRAP?= # Use libwrap?
USELIBCAP= # Use libcap?
USESYSTEMD= # Make use of systemd socket activation
@@ -72,6 +73,9 @@ ifneq ($(strip $(USELIBBSD)),)
CPPFLAGS+=-DLIBBSD
endif
+ifneq ($(strip $(USELIBEV)),)
+ CONDITIONAL_TARGETS+=sslh-ev
+endif
all: sslh $(MAN) echosrv $(CONDITIONAL_TARGETS)
@@ -84,7 +88,7 @@ $(OBJS_A): $(OBJS)
version.h:
./genver.sh >version.h
-sslh: sslh-fork sslh-select sslh-ev
+sslh: sslh-fork sslh-select
$(OBJS) $(FORK_OBJS) $(SELECT_OBJS) $(EV_OBJS): argtable3.h collection.h common.h gap.h hash.h log.h probe.h processes.h sslh-conf.h tcp-listener.h tcp-probe.h tls.h udp-listener.h version.h
@@ -153,7 +157,7 @@ distclean: clean
rm -f tags sslh-conf.[ch] echosrv-conf.[ch] cscope.*
clean:
- rm -f sslh-fork sslh-select sslh-ev echosrv version.h $(MAN) systemd-sslh-generator *.o *.gcov *.gcno *.gcda *.png *.html *.css *.info
+ rm -f sslh-fork sslh-select $(CONDITIONAL_TARGETS) echosrv version.h $(MAN) systemd-sslh-generator *.o *.gcov *.gcno *.gcda *.png *.html *.css *.info
tags:
ctags --globals -T *.[ch]

View File

@ -1,3 +1,3 @@
# Locally calculated
sha256 8e3742d14edf4119350cfdc7bb96b89134d9218eb6d2a6e1f70891ca18a649b1 sslh-v1.22c.tar.gz
sha256 d88d43ee11cf1324983c196c894b41766c33d957b6af53b62c8479703bbbd26c sslh-v2.0.1.tar.gz
sha256 8177f97513213526df2cf6184d8ff986c675afb514d4e68a404010521b880643 COPYING

View File

@ -4,7 +4,7 @@
#
################################################################################
SSLH_VERSION = 1.22c
SSLH_VERSION = 2.0.1
SSLH_SOURCE = sslh-v$(SSLH_VERSION).tar.gz
SSLH_SITE = http://www.rutschle.net/tech/sslh
SSLH_LICENSE = GPL-2.0+
@ -35,6 +35,13 @@ else
SSLH_MAKE_OPTS += USELIBCONFIG=
endif
ifeq ($(BR2_PACKAGE_LIBEV),y)
SSLH_DEPENDENCIES += libev
SSLH_MAKE_OPTS += USELIBEV=1
else
SSLH_MAKE_OPTS += USELIBEV=
endif
ifeq ($(BR2_PACKAGE_SYSTEMD),y)
SSLH_DEPENDENCIES += systemd
SSLH_MAKE_OPTS += USESYSTEMD=1