package/memcached: fix uclibc build on aarch64
Fix the following uclibc build failure on aarch64: crc32c.c:277:10: fatal error: sys/auxv.h: No such file or directory 277 | #include <sys/auxv.h> | ^~~~~~~~~~~~ Fixes: - http://autobuild.buildroot.org/results/08591fbf9677ff126492c50c15170c641bcab56a Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
This commit is contained in:
parent
2a9ef1f572
commit
97b533c3c2
50
package/memcached/0002-check-for-sys-auxv.h.patch
Normal file
50
package/memcached/0002-check-for-sys-auxv.h.patch
Normal file
@ -0,0 +1,50 @@
|
||||
From 58b6de2135c10b64918f25c48f69f144d08a9c0d Mon Sep 17 00:00:00 2001
|
||||
From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
||||
Date: Fri, 3 Jun 2022 19:10:15 +0200
|
||||
Subject: [PATCH 2/2] check for sys/auxv.h
|
||||
|
||||
Check for sys/auxv.h to avoid the following uclibc build failure on
|
||||
aarch64:
|
||||
|
||||
crc32c.c:277:10: fatal error: sys/auxv.h: No such file or directory
|
||||
277 | #include <sys/auxv.h>
|
||||
| ^~~~~~~~~~~~
|
||||
|
||||
Fixes:
|
||||
- http://autobuild.buildroot.org/results/08591fbf9677ff126492c50c15170c641bcab56a
|
||||
|
||||
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
||||
[Upstream status: not sent yet]
|
||||
---
|
||||
configure.ac | 1 +
|
||||
crc32c.c | 2 +-
|
||||
2 files changed, 2 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 0985f07..3337fe7 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -516,6 +516,7 @@ AH_BOTTOM([#ifdef HAVE_INTTYPES_H
|
||||
#include <inttypes.h>
|
||||
#endif
|
||||
])
|
||||
+AC_CHECK_HEADERS([sys/auxv.h])
|
||||
|
||||
dnl **********************************************************************
|
||||
dnl Figure out if this system has the stupid sasl_callback_ft
|
||||
diff --git a/crc32c.c b/crc32c.c
|
||||
index 26df879..05e61ff 100644
|
||||
--- a/crc32c.c
|
||||
+++ b/crc32c.c
|
||||
@@ -273,7 +273,7 @@ void crc32c_init(void) {
|
||||
}
|
||||
}
|
||||
|
||||
-#elif defined(__aarch64__) && defined(__linux__)
|
||||
+#elif defined(__aarch64__) && defined(__linux__) && defined(HAVE_SYS_AUX_H)
|
||||
#include <sys/auxv.h>
|
||||
|
||||
#if defined(HWCAP_CRC32)
|
||||
--
|
||||
2.35.1
|
||||
|
@ -13,6 +13,8 @@ MEMCACHED_LICENSE = BSD-3-Clause
|
||||
MEMCACHED_LICENSE_FILES = COPYING
|
||||
MEMCACHED_CPE_ID_VENDOR = memcached
|
||||
MEMCACHED_SELINUX_MODULES = memcached
|
||||
# We're patching configure.ac
|
||||
MEMCACHED_AUTORECONF = YES
|
||||
|
||||
ifeq ($(BR2_ENDIAN),"BIG")
|
||||
MEMCACHED_CONF_ENV += ac_cv_c_endian=big
|
||||
|
Loading…
Reference in New Issue
Block a user