diff --git a/scripts/pkg-stats b/scripts/pkg-stats
index 0ed420d325..1174ef04c2 100755
--- a/scripts/pkg-stats
+++ b/scripts/pkg-stats
@@ -70,7 +70,7 @@ for i in $(find package/ -name '*.mk') ; do
$i = "package/database/database.mk" -o \
$i = "package/editors/editors.mk" -o \
$i = "package/games/games.mk" -o \
- $i = "package/multimedia/multimedia" -o \
+ $i = "package/multimedia/multimedia.mk" -o \
$i = "package/customize/customize.mk" -o \
$i = "package/gnuconfig/gnuconfig.mk" -o \
$i = "package/x11r7/x11r7.mk" ; then
@@ -144,7 +144,7 @@ for i in $(find package/ -name '*.mk') ; do
echo ""
echo "
"
- if grep "^$pkg:" $i > /dev/null ; then
+ if test $is_pkg_target -eq 0 -a $is_auto_target -eq 0 ; then
found=1
is_manual_target=1
echo "YES"
@@ -155,18 +155,17 @@ for i in $(find package/ -name '*.mk') ; do
echo " | "
echo ""
- if [ $is_manual_target -eq 1 ]; then
- echo "- convert to generic target
"
- convert_to_generic_target=$((convert_to_generic_target+1))
- fi
- if [ $is_manual_host -eq 1 ]; then
- echo "- convert to generic host
"
- convert_to_generic_host=$((convert_to_generic_host+1))
- fi
- if grep "\./configure" $i > /dev/null ; then
- if [ $is_manual_host -ne 1 ] ; then
- echo "- convert package to autotools ?
"
- convert_to_autotools=$((convert_to_autotools+1))
+ if grep "/configure" $i > /dev/null ; then
+ echo "- convert package to autotools ?
"
+ convert_to_autotools=$((convert_to_autotools+1))
+ else
+ if [ $is_manual_target -eq 1 ]; then
+ echo "- convert to generic target
"
+ convert_to_generic_target=$((convert_to_generic_target+1))
+ fi
+ if [ $is_manual_host -eq 1 ]; then
+ echo "- convert to generic host
"
+ convert_to_generic_host=$((convert_to_generic_host+1))
fi
fi
if [ $found -eq 0 ] ; then
|