package/libglib2: fix 0003-remove-cpp-requirement.patch

This patch was missing the following section:

@@ -1,4 +1,4 @@
-project('glib', 'c', 'cpp',
+project('glib', 'c',
   version : '2.62.3',
   # NOTE: We keep this pinned at 0.49 because that's what Debian 10 ships
   meson_version : '>= 0.49.2',

As such, the package still depended on g++.

Update the patch to add the above section.

Signed-off-by: Adam Duskett <Aduskett@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
This commit is contained in:
Adam Duskett 2019-12-08 13:38:48 -08:00 committed by Thomas Petazzoni
parent 2cda8162d8
commit 97110b578f

View File

@ -12,9 +12,9 @@ Upstream status: Denied (Buildroot specific)
https://gitlab.gnome.org/GNOME/glib/issues/1748
---
glib/glibconfig.h.in | 1 -
meson.build | 16 ----------------
meson.build | 18 +-----------------
tests/meson.build | 5 -----
3 files changed, 22 deletions(-)
3 files changed, 1 insertion(+), 23 deletions(-)
diff --git a/glib/glibconfig.h.in b/glib/glibconfig.h.in
index 7ef8c48..128e65d 100644
@ -29,9 +29,15 @@ index 7ef8c48..128e65d 100644
/* gcc-2.95.x supports both gnu style and ISO varargs, but if -ansi
* is passed ISO vararg support is turned off, and there is no work
diff --git a/meson.build b/meson.build
index 83774d0..99806d0 100644
index 4bbf4c2..ac59f4e 100644
--- a/meson.build
+++ b/meson.build
@@ -1,4 +1,4 @@
-project('glib', 'c', 'cpp',
+project('glib', 'c',
version : '2.62.3',
# NOTE: We keep this pinned at 0.49 because that's what Debian 10 ships
meson_version : '>= 0.49.2',
@@ -10,7 +10,6 @@ project('glib', 'c', 'cpp',
)