package/sentry-cli: fix build with OpenSSL 3.x

Fixes:
http://autobuild.buildroot.net/results/4e2/4e24cb67402bad35ab57833d72e6c857b3eb4e07/

Signed-off-by: Bernd Kuhls <bernd@kuhls.net>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
This commit is contained in:
Bernd Kuhls 2023-07-31 22:49:46 +02:00 committed by Thomas Petazzoni
parent dff67170f7
commit 961dc9d397

View File

@ -0,0 +1,62 @@
From a3754088b4cf7d19ff4f9a98412dd132d5baf1c1 Mon Sep 17 00:00:00 2001
From: Bernd Kuhls <bernd@kuhls.net>
Date: Mon, 31 Jul 2023 22:34:04 +0200
Subject: [PATCH] Disable SSL support for the curl module
Fixes build with OpenSSL v3.
Downloaded Cargo.toml patch from
https://cgit.freebsd.org/ports/tree/devel/sentry-cli/files/patch-Cargo.toml
Upstream: https://github.com/getsentry/sentry-cli/issues/1706
Signed-off-by: Bernd Kuhls <bernd@kuhls.net>
---
Cargo.lock | 10 ----------
Cargo.toml | 2 +-
2 files changed, 1 insertion(+), 11 deletions(-)
diff --git a/Cargo.lock b/Cargo.lock
index 75e1c8c..5121211 100644
--- a/Cargo.lock
+++ b/Cargo.lock
@@ -1557,15 +1557,6 @@ version = "0.1.5"
source = "registry+https://github.com/rust-lang/crates.io-index"
checksum = "ff011a302c396a5197692431fc1948019154afc178baf7d8e37367442a4601cf"
-[[package]]
-name = "openssl-src"
-version = "111.22.0+1.1.1q"
-source = "registry+https://github.com/rust-lang/crates.io-index"
-checksum = "8f31f0d509d1c1ae9cada2f9539ff8f37933831fd5098879e482aa687d659853"
-dependencies = [
- "cc",
-]
-
[[package]]
name = "openssl-sys"
version = "0.9.74"
@@ -1575,7 +1566,6 @@ dependencies = [
"autocfg",
"cc",
"libc",
- "openssl-src",
"pkg-config",
"vcpkg",
]
diff --git a/Cargo.toml b/Cargo.toml
index abd6839..ddc141f 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -19,7 +19,7 @@ clap = { version = "3.2.22", default-features = false, features = [
"wrap_help",
] }
console = "0.15.2"
-curl = { version = "0.4.44", features = ["static-curl", "static-ssl"] }
+curl = { version = "0.4.44" }
dirs = "4.0.0"
dotenv = "0.15.0"
elementtree = "1.2.2"
--
2.39.2