From 95ff38838b2854efd1ced496d11c73f17f174c41 Mon Sep 17 00:00:00 2001
From: Eric Andersen <andersen@codepoet.org>
Date: Wed, 5 Feb 2003 10:43:44 +0000
Subject: [PATCH] teach libtool to use the correct system compiler

---
 make/libtool.mk | 2 ++
 1 file changed, 2 insertions(+)

diff --git a/make/libtool.mk b/make/libtool.mk
index aa754a9230..53038cbae4 100644
--- a/make/libtool.mk
+++ b/make/libtool.mk
@@ -58,6 +58,8 @@ $(TARGET_DIR)/$(LIBTOOL_TARGET_BINARY): $(LIBTOOL_DIR)/$(LIBTOOL_BINARY)
 	    mandir=$(TARGET_DIR)/usr/man \
 	    includedir=$(TARGET_DIR)/usr/include \
 	    -C $(LIBTOOL_DIR) install;
+	perl -pi -e "s,^CC.*,CC=\"/usr/bin/gcc\"," $(TARGET_DIR)/usr/bin/libtool
+	perl -pi -e "s,^LD.*,CC=\"/usr/bin/ld\"," $(TARGET_DIR)/usr/bin/libtool
 	rm -rf $(TARGET_DIR)/share/locale
 
 libtool: uclibc $(TARGET_DIR)/$(LIBTOOL_TARGET_BINARY)