Revert "dropwatch: new package"
This reverts commit 8d228d3010
.
Was not supposed to have been pushed (yet).
This commit is contained in:
parent
8d228d3010
commit
956fa67410
@ -22,7 +22,6 @@ source "package/cache-calibrator/Config.in"
|
||||
source "package/dhrystone/Config.in"
|
||||
source "package/dstat/Config.in"
|
||||
source "package/dmalloc/Config.in"
|
||||
source "package/dropwatch/Config.in"
|
||||
source "package/gdb/Config.in"
|
||||
source "package/iozone/Config.in"
|
||||
source "package/kexec/Config.in"
|
||||
|
@ -1,7 +0,0 @@
|
||||
config BR2_PACKAGE_DROPWATCH
|
||||
bool "dropwatch"
|
||||
help
|
||||
Dropwatch is a project I am tinkering with to improve the visibility
|
||||
developers and sysadmins have into the Linux networking stack.
|
||||
|
||||
https://git.fedorahosted.org/git/dropwatch.git
|
@ -1,27 +0,0 @@
|
||||
From 03bab84ca3f102274837e83ee6da4c997a9da018 Mon Sep 17 00:00:00 2001
|
||||
From: Tzu-Jung Lee <tjlee@ambarella.com>
|
||||
Date: Fri, 12 Jul 2013 20:00:57 +0800
|
||||
Subject: [PATCH] build: modify hardcoded gcc to support buildroot
|
||||
|
||||
Signed-off-by: Tzu-Jung Lee <tjlee@ambarella.com>
|
||||
|
||||
diff --git a/src/Makefile b/src/Makefile
|
||||
index 026b6ba..b87ae9f 100644
|
||||
--- a/src/Makefile
|
||||
+++ b/src/Makefile
|
||||
@@ -5,10 +5,10 @@ OBJFILES := main.o lookup.o\
|
||||
lookup_bfd.o lookup_kas.o
|
||||
|
||||
dropwatch: $(OBJFILES)
|
||||
- gcc -g -o dropwatch $(OBJFILES) $(LDFLAGS)
|
||||
+ $(CC) -g -o dropwatch $(OBJFILES) $(LDFLAGS)
|
||||
|
||||
%.o: %.c
|
||||
- gcc $(CFLAGS) $<
|
||||
+ $(CC) $(CFLAGS) $<
|
||||
clean:
|
||||
rm -f dropwatch *.o
|
||||
|
||||
--
|
||||
1.8.3.2
|
||||
|
@ -1,30 +0,0 @@
|
||||
#############################################################
|
||||
#
|
||||
# dropwatch
|
||||
#
|
||||
#############################################################
|
||||
|
||||
DROPWATCH_VERSION = 1.4
|
||||
DROPWATCH_SOURCE = dropwatch-$(DROPWATCH_VERSION).tar.bz2
|
||||
DROPWATCH_SITE = https://git.fedorahosted.org/cgit/dropwatch.git/snapshot/
|
||||
DROPWATCH_DEPENDENCIES = readline libnl binutils
|
||||
DROPWATCH_LICENSE = GPLv2+
|
||||
DROPWATCH_LICENSE_FILE = COPYING
|
||||
|
||||
define DROPWATCH_INSTALL_TARGET_CMDS
|
||||
cp $(@D)/src/dropwatch $(TARGET_DIR)/usr/bin
|
||||
endef
|
||||
|
||||
define DROPWATCH_BUILD_CMDS
|
||||
$(TARGET_CONFIGURE_OPTS) $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) build
|
||||
endef
|
||||
|
||||
define DROPWATCH_CLEAN_CMDS
|
||||
$(TARGET_CONFIGURE_OPTS) $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) clean
|
||||
endef
|
||||
|
||||
define DROPWATCH_UNINSTALL_CMDS
|
||||
rm -f $(TARGET_DIR)/usr/bin/dropwatch
|
||||
endef
|
||||
|
||||
$(eval $(generic-package))
|
Loading…
Reference in New Issue
Block a user