xerces: bump to version 3.2.2
- Remove patch (already in version) - Move to cmake infrastructure because AC_RUN_IFELSE was added to configure - Remove --with-icu, --with-gnu-ld and --with-curl options (not available in cmake) - Replace --enable-netaccessor-curl by -Dnetwork-accessor=curl - Replace --enable-threads option by -Dthreads - Update XERCES_DISABLE_SAMPLES for cmake - Add hash for license file Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
This commit is contained in:
parent
d582532b95
commit
952a0d6ab3
@ -1,22 +0,0 @@
|
|||||||
XMLString: Don't call catString if relativePath is null
|
|
||||||
|
|
||||||
https://xerces.apache.org/xerces-c/secadv/CVE-2017-12627.txt
|
|
||||||
|
|
||||||
Upstream status: svn revision 1819998
|
|
||||||
|
|
||||||
Signed-off-by: Baruch Siach <baruch@tkos.co.il>
|
|
||||||
|
|
||||||
--- trunk/src/xercesc/util/PlatformUtils.cpp 2018/01/03 18:58:30 1819997
|
|
||||||
+++ trunk/src/xercesc/util/PlatformUtils.cpp 2018/01/03 18:59:30 1819998
|
|
||||||
@@ -920,7 +920,10 @@
|
|
||||||
|
|
||||||
XMLString::subString(tmpBuf, basePath, 0, (basePtr - basePath + 1), manager);
|
|
||||||
tmpBuf[basePtr - basePath + 1] = 0;
|
|
||||||
- XMLString::catString(tmpBuf, relativePath);
|
|
||||||
+ if (relativePath)
|
|
||||||
+ {
|
|
||||||
+ XMLString::catString(tmpBuf, relativePath);
|
|
||||||
+ }
|
|
||||||
|
|
||||||
removeDotSlash(tmpBuf, manager);
|
|
||||||
|
|
@ -1,2 +1,5 @@
|
|||||||
# From http://www.apache.org/dist/xerces/c/3/sources/xerces-c-3.1.4.tar.xz.sha256
|
# From http://www.apache.org/dist/xerces/c/3/sources/xerces-c-3.2.2.tar.xz.sha256
|
||||||
sha256 9973cc79481803f8b6652c52faf5195d963f50d209d4f681ec97e2aa014b6241 xerces-c-3.1.4.tar.xz
|
sha256 6daca3b23364d8d883dc77a73f681242f69389e3564543287ed3d073007e0a8e xerces-c-3.2.2.tar.xz
|
||||||
|
|
||||||
|
# Hash for license file
|
||||||
|
sha256 cfc7749b96f63bd31c3c42b5c471bf756814053e847c10f3eb003417bc523d30 LICENSE
|
||||||
|
@ -4,25 +4,21 @@
|
|||||||
#
|
#
|
||||||
################################################################################
|
################################################################################
|
||||||
|
|
||||||
XERCES_VERSION = 3.1.4
|
XERCES_VERSION = 3.2.2
|
||||||
XERCES_SOURCE = xerces-c-$(XERCES_VERSION).tar.xz
|
XERCES_SOURCE = xerces-c-$(XERCES_VERSION).tar.xz
|
||||||
XERCES_SITE = http://archive.apache.org/dist/xerces/c/3/sources
|
XERCES_SITE = http://archive.apache.org/dist/xerces/c/3/sources
|
||||||
XERCES_LICENSE = Apache-2.0
|
XERCES_LICENSE = Apache-2.0
|
||||||
XERCES_LICENSE_FILES = LICENSE
|
XERCES_LICENSE_FILES = LICENSE
|
||||||
XERCES_INSTALL_STAGING = YES
|
XERCES_INSTALL_STAGING = YES
|
||||||
XERCES_CONF_OPTS = --with-gnu-ld
|
|
||||||
|
|
||||||
define XERCES_DISABLE_SAMPLES
|
define XERCES_DISABLE_SAMPLES
|
||||||
$(SED) 's/ samples//' $(@D)/Makefile.in
|
$(SED) 's/add_subdirectory(samples)//' $(@D)/CMakeLists.txt
|
||||||
endef
|
endef
|
||||||
|
|
||||||
XERCES_POST_PATCH_HOOKS += XERCES_DISABLE_SAMPLES
|
XERCES_POST_PATCH_HOOKS += XERCES_DISABLE_SAMPLES
|
||||||
|
|
||||||
ifeq ($(BR2_PACKAGE_ICU),y)
|
ifeq ($(BR2_PACKAGE_ICU),y)
|
||||||
XERCES_CONF_OPTS += --with-icu=$(STAGING_DIR)/usr
|
|
||||||
XERCES_DEPENDENCIES += icu
|
XERCES_DEPENDENCIES += icu
|
||||||
else
|
|
||||||
XERCES_CONF_OPTS += --without-icu
|
|
||||||
endif
|
endif
|
||||||
|
|
||||||
ifeq ($(BR2_PACKAGE_LIBICONV),y)
|
ifeq ($(BR2_PACKAGE_LIBICONV),y)
|
||||||
@ -31,16 +27,16 @@ XERCES_DEPENDENCIES += libiconv
|
|||||||
endif
|
endif
|
||||||
|
|
||||||
ifeq ($(BR2_PACKAGE_LIBCURL),y)
|
ifeq ($(BR2_PACKAGE_LIBCURL),y)
|
||||||
XERCES_CONF_OPTS += --enable-netaccessor-curl --with-curl=$(STAGING_DIR)/usr/lib
|
XERCES_CONF_OPTS += -Dnetwork-accessor=curl
|
||||||
XERCES_DEPENDENCIES += libcurl
|
XERCES_DEPENDENCIES += libcurl
|
||||||
else
|
else
|
||||||
XERCES_CONF_OPTS += --disable-netaccessor-curl
|
XERCES_CONF_OPTS += -Dnetwork-accessor=socket
|
||||||
endif
|
endif
|
||||||
|
|
||||||
ifeq ($(BR2_TOOLCHAIN_HAS_THREADS),y)
|
ifeq ($(BR2_TOOLCHAIN_HAS_THREADS),y)
|
||||||
XERCES_CONF_OPTS += --enable-threads
|
XERCES_CONF_OPTS += -Dthreads=ON
|
||||||
else
|
else
|
||||||
XERCES_CONF_OPTS += --disable-threads
|
XERCES_CONF_OPTS += -Dthreads=OFF
|
||||||
endif
|
endif
|
||||||
|
|
||||||
$(eval $(autotools-package))
|
$(eval $(cmake-package))
|
||||||
|
Loading…
Reference in New Issue
Block a user