package/fluent-bit: bump to v3.0.0

Release Notes:
- https://fluentbit.io/announcements/v3.0.0/

Also drop 0004-wasm-restore-support-for-some-targets-8401.patch,
which was accepted upstream.
(See: 40bb0fbe17)

Signed-off-by: Thomas Devoogdt <thomas@devoogdt.com>
Signed-off-by: Arnout Vandecappelle <arnout@mind.be>
This commit is contained in:
Thomas Devoogdt 2024-03-24 00:21:16 +01:00 committed by Arnout Vandecappelle
parent 9496ff57e5
commit 94e072849e
3 changed files with 2 additions and 45 deletions

View File

@ -1,43 +0,0 @@
From 4a6c5f56cd1a979b91c168fb8e245587c2927aca Mon Sep 17 00:00:00 2001
From: Thomas Devoogdt <thomas@devoogdt.com>
Date: Mon, 22 Jan 2024 19:27:56 +0100
Subject: [PATCH] wasm: restore support for some targets (#8401)
Somehow, support for ARC, MIPS, and XTENSA got dropped by bumping to v1.3.0,
so restore it now. Remark that those targets are mentioned in the section above.
See commit fa6a248746f9f481b5f6aef49716141fa0222650.
Upstream: https://github.com/fluent/fluent-bit/pull/8401
Signed-off-by: Thomas Devoogdt <thomas@devoogdt.com>
---
src/wasm/CMakeLists.txt | 6 ++++++
1 file changed, 6 insertions(+)
diff --git a/src/wasm/CMakeLists.txt b/src/wasm/CMakeLists.txt
index a258dc063..4ea7eba65 100644
--- a/src/wasm/CMakeLists.txt
+++ b/src/wasm/CMakeLists.txt
@@ -51,6 +51,10 @@ elseif (WAMR_BUILD_TARGET MATCHES "AARCH64.*")
elseif (WAMR_BUILD_TARGET MATCHES "ARM.*")
add_definitions(-DBUILD_TARGET_ARM)
add_definitions(-DBUILD_TARGET="${WAMR_BUILD_TARGET}")
+elseif (WAMR_BUILD_TARGET STREQUAL "MIPS")
+ add_definitions(-DBUILD_TARGET_MIPS)
+elseif (WAMR_BUILD_TARGET STREQUAL "XTENSA")
+ add_definitions(-DBUILD_TARGET_XTENSA)
elseif (WAMR_BUILD_TARGET STREQUAL "RISCV64" OR WAMR_BUILD_TARGET STREQUAL "RISCV64_LP64D")
add_definitions(-DBUILD_TARGET_RISCV64_LP64D)
elseif (WAMR_BUILD_TARGET STREQUAL "RISCV64_LP64")
@@ -59,6 +63,8 @@ elseif (WAMR_BUILD_TARGET STREQUAL "RISCV32" OR WAMR_BUILD_TARGET STREQUAL "RISC
add_definitions(-DBUILD_TARGET_RISCV32_ILP32D)
elseif (WAMR_BUILD_TARGET STREQUAL "RISCV32_ILP32")
add_definitions(-DBUILD_TARGET_RISCV32_ILP32)
+elseif (WAMR_BUILD_TARGET STREQUAL "ARC")
+ add_definitions(-DBUILD_TARGET_ARC)
else ()
message (FATAL_ERROR "-- Build target isn't set")
endif ()
--
2.34.1

View File

@ -1,3 +1,3 @@
# Locally computed
sha256 8e7e951b2907e9d29508699c71c8949a4a22d750d54ffa5ee5b96537e59371dd fluent-bit-2.2.2.tar.gz
sha256 e70ae5be2f0ca1cb842a1c8d2762437907c522765f79b5c0c391eaa1b57c9f4c fluent-bit-3.0.0.tar.gz
sha256 0d542e0c8804e39aa7f37eb00da5a762149dc682d7829451287e11b938e94594 LICENSE

View File

@ -4,7 +4,7 @@
#
################################################################################
FLUENT_BIT_VERSION = 2.2.2
FLUENT_BIT_VERSION = 3.0.0
FLUENT_BIT_SITE = $(call github,fluent,fluent-bit,v$(FLUENT_BIT_VERSION))
FLUENT_BIT_LICENSE = Apache-2.0
FLUENT_BIT_LICENSE_FILES = LICENSE