python: enable IPv6 socket support

Added patch to disable buggy_getaddrinfo test during configure when
cross-compiling.

[Peter: Remove --enable-ipv6 which is now handled globally]
Signed-off-by: Vanya Sergeev <vsergeev at gmail.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
This commit is contained in:
vsergeev 2012-04-22 01:03:16 +00:00 committed by Peter Korsgaard
parent 2a10c9d0a2
commit 94c297c448

View File

@ -0,0 +1,15 @@
Disable buggy_getaddrinfo configure test when cross-compiling with IPv6 support
Signed-off-by: Vanya Sergeev <vsergeev at gmail.com>
--- python-2.7.2.orig/configure.in 2012-04-22 06:52:09.361809545 -0400
+++ python-2.7.2/configure.in 2012-04-22 06:56:37.900634194 -0400
@@ -3128,7 +3128,7 @@
AC_MSG_RESULT($ac_cv_buggy_getaddrinfo)
-if test $have_getaddrinfo = no -o "$ac_cv_buggy_getaddrinfo" = yes
+if test $have_getaddrinfo = no || test "$cross_compiling" != "yes" -a "$ac_cv_buggy_getaddrinfo" = yes
then
if test $ipv6 = yes
then