diff --git a/package/boost/0001-unordered-fix-copy-assign.patch b/package/boost/0001-unordered-fix-copy-assign.patch
new file mode 100644
index 0000000000..670552535a
--- /dev/null
+++ b/package/boost/0001-unordered-fix-copy-assign.patch
@@ -0,0 +1,22 @@
+Upstream Patch for Unordered
+
+Prevent erroneous copying of groups data, update max load to properly propagate
+
+Signed-off-by: Michael Nosthoff <buildroot@heine.tech>
+Upstream: https://github.com/boostorg/unordered/commit/067884a4e213352e7c81c441f1453c54735c39f3
+diff --git a/include/boost/unordered/detail/foa/core.hpp b/include/boost/unordered/detail/foa/core.hpp
+index 239d05d3..7ae9f2c8 100644
+--- a/boost/unordered/detail/foa/core.hpp
++++ b/boost/unordered/detail/foa/core.hpp
+@@ -1870,9 +1870,10 @@ private:
+ 
+   void fast_copy_elements_from(const table_core& x)
+   {
+-    if(arrays.elements){
++    if(arrays.elements&&x.arrays.elements){
+       copy_elements_array_from(x);
+       copy_groups_array_from(x);
++      size_ctrl.ml=std::size_t(x.size_ctrl.ml);
+       size_ctrl.size=std::size_t(x.size_ctrl.size);
+     }
+   }
diff --git a/package/boost/boost.hash b/package/boost/boost.hash
index 36de2b9b06..14403758ac 100644
--- a/package/boost/boost.hash
+++ b/package/boost/boost.hash
@@ -1,5 +1,5 @@
-# From https://www.boost.org/users/history/version_1_82_0.html
-sha256  a6e1ab9b0860e6a2881dd7b21fe9f737a095e5f33a3a874afc6a345228597ee6  boost_1_82_0.tar.bz2
+# From https://www.boost.org/users/history/version_1_83_0.html
+sha256  6478edfe2f3305127cffe8caf73ea0176c53769f4bf1585be237eb30798c3b8e  boost_1_83_0.tar.bz2
 
 # Locally computed
 sha256  c9bff75738922193e67fa726fa225535870d2aa1059f91452c411736284ad566  LICENSE_1_0.txt
diff --git a/package/boost/boost.mk b/package/boost/boost.mk
index d432ab48cc..9b1baec5bf 100644
--- a/package/boost/boost.mk
+++ b/package/boost/boost.mk
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-BOOST_VERSION = 1.82.0
+BOOST_VERSION = 1.83.0
 BOOST_SOURCE = boost_$(subst .,_,$(BOOST_VERSION)).tar.bz2
 BOOST_SITE = https://boostorg.jfrog.io/artifactory/main/release/$(BOOST_VERSION)/source
 BOOST_INSTALL_STAGING = YES