package/libubootenv: bump to version 0.3.4

Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
This commit is contained in:
Francois Perrad 2023-07-25 12:31:40 +02:00 committed by Yann E. MORIN
parent 4b285598e8
commit 9325ba4754
3 changed files with 7 additions and 8 deletions

View File

@ -29,7 +29,7 @@ diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 4b71bc5..0b515f4 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -12,18 +12,16 @@ SET(include_HEADERS
@@ -15,17 +15,15 @@ SET(include_HEADERS
include(GNUInstallDirs) # for the CMAKE_INSTALL_LIBDIR variable
@ -40,16 +40,15 @@ index 4b71bc5..0b515f4 100644
-ADD_LIBRARY(ubootenv_static STATIC ${libubootenv_SOURCES} ${include_HEADERS})
-SET_TARGET_PROPERTIES(ubootenv_static PROPERTIES OUTPUT_NAME ubootenv)
add_executable(fw_printenv fw_printenv.c)
add_executable(fw_setenv fw_setenv.c)
target_link_libraries(ubootenv z)
target_link_libraries(ubootenv z yaml)
target_link_libraries(fw_printenv ubootenv)
target_link_libraries(fw_setenv ubootenv)
add_custom_target(fw_setenv ALL ${CMAKE_COMMAND} -E create_symlink fw_printenv fw_setenv)
-install (TARGETS ubootenv ubootenv_static DESTINATION ${CMAKE_INSTALL_LIBDIR})
+install (TARGETS ubootenv DESTINATION ${CMAKE_INSTALL_LIBDIR})
install (FILES libuboot.h DESTINATION ${CMAKE_INSTALL_INCLUDEDIR})
install (TARGETS fw_printenv DESTINATION ${CMAKE_INSTALL_BINDIR})
install (TARGETS fw_setenv DESTINATION ${CMAKE_INSTALL_BINDIR})
install (PROGRAMS ${CMAKE_CURRENT_BINARY_DIR}/fw_setenv DESTINATION ${CMAKE_INSTALL_BINDIR})
--
2.30.2

View File

@ -1,5 +1,5 @@
# Locally calculated
sha256 8fc9498b557bbf4ae4d39a2dbd15a2ef44f8ea8de4686cc971c6788a65cd1ec0 libubootenv-0.3.3.tar.gz
sha256 78faadcfac67e50273e5d4e95e6cf6fee3d486ce9dc568d1fe25312271a88768 libubootenv-0.3.4.tar.gz
sha256 0558101984550fa84d1d13c2af11d116c20079d2be58711e8d99cadce7009192 LICENSES/CC0-1.0.txt
sha256 dc626520dcd53a22f727af3ee42c770e56c97a64fe3adb063799d8ab032fe551 LICENSES/LGPL-2.1-or-later.txt
sha256 89807acf2309bd285f033404ee78581602f3cd9b819a16ac2f0e5f60ff4a473e LICENSES/MIT.txt

View File

@ -4,7 +4,7 @@
#
################################################################################
LIBUBOOTENV_VERSION = 0.3.3
LIBUBOOTENV_VERSION = 0.3.4
LIBUBOOTENV_SITE = $(call github,sbabic,libubootenv,v$(LIBUBOOTENV_VERSION))
LIBUBOOTENV_LICENSE = LGPL-2.1+, MIT, CC0-1.0
LIBUBOOTENV_LICENSE_FILES = LICENSES/CC0-1.0.txt \
@ -12,6 +12,6 @@ LIBUBOOTENV_LICENSE_FILES = LICENSES/CC0-1.0.txt \
LICENSES/MIT.txt
LIBUBOOTENV_INSTALL_STAGING = YES
LIBUBOOTENV_DEPENDENCIES = zlib
LIBUBOOTENV_DEPENDENCIES = libyaml zlib
$(eval $(cmake-package))