- import gcc-4.2.0
libmudflap is disabled for now. copied from 4.1.0 with slight adjustments
This commit is contained in:
parent
b2dcdf3218
commit
92834c5674
465
toolchain/gcc/4.2.0/100-uclibc-conf.patch
Normal file
465
toolchain/gcc/4.2.0/100-uclibc-conf.patch
Normal file
@ -0,0 +1,465 @@
|
||||
diff -ruNp gcc-4.2.0.oorig/boehm-gc/configure gcc-4.2.0/boehm-gc/configure
|
||||
--- gcc-4.2.0.oorig/boehm-gc/configure 2005-10-31 18:09:11.000000000 +0100
|
||||
+++ gcc-4.2.0/boehm-gc/configure 2005-12-02 18:38:22.000000000 +0100
|
||||
@@ -4320,6 +4320,11 @@ linux-gnu*)
|
||||
lt_cv_deplibs_check_method=pass_all
|
||||
;;
|
||||
|
||||
+linux-uclibc*)
|
||||
+ lt_cv_deplibs_check_method=pass_all
|
||||
+ lt_cv_file_magic_test_file=`echo /lib/libuClibc-*.so`
|
||||
+ ;;
|
||||
+
|
||||
netbsd* | knetbsd*-gnu)
|
||||
if echo __ELF__ | $CC -E - | grep __ELF__ > /dev/null; then
|
||||
lt_cv_deplibs_check_method='match_pattern /lib[^/\.]+\.so\.[0-9]+\.[0-9]+$'
|
||||
diff -ruNp gcc-4.2.0.oorig/configure gcc-4.2.0/configure
|
||||
--- gcc-4.2.0.oorig/configure 2005-11-30 20:49:49.000000000 +0100
|
||||
+++ gcc-4.2.0/configure 2005-12-02 18:38:22.000000000 +0100
|
||||
@@ -1133,7 +1133,7 @@ no)
|
||||
;;
|
||||
"")
|
||||
case "${target}" in
|
||||
- *-*-linux*-gnu | *-*-gnu* | *-*-k*bsd*-gnu)
|
||||
+ *-*-linux*-gnu | *-*-gnu* | *-*-k*bsd*-gnu | *-*-linux-uclibc*)
|
||||
# Enable libmudflap by default in GNU and friends.
|
||||
;;
|
||||
*-*-freebsd*)
|
||||
diff -ruNp gcc-4.2.0.oorig/configure.in gcc-4.2.0/configure.in
|
||||
--- gcc-4.2.0.oorig/configure.in 2005-11-30 20:49:49.000000000 +0100
|
||||
+++ gcc-4.2.0/configure.in 2005-12-02 18:38:22.000000000 +0100
|
||||
@@ -341,7 +341,7 @@ no)
|
||||
;;
|
||||
"")
|
||||
case "${target}" in
|
||||
- *-*-linux*-gnu | *-*-gnu* | *-*-k*bsd*-gnu)
|
||||
+ *-*-linux*-gnu | *-*-gnu* | *-*-k*bsd*-gnu | *-*-linux-uclibc*)
|
||||
# Enable libmudflap by default in GNU and friends.
|
||||
;;
|
||||
*-*-freebsd*)
|
||||
diff -ruNp gcc-4.2.0.oorig/contrib/regression/objs-gcc.sh gcc-4.2.0/contrib/regression/objs-gcc.sh
|
||||
--- gcc-4.2.0.oorig/contrib/regression/objs-gcc.sh 2005-10-31 18:10:00.000000000 +0100
|
||||
+++ gcc-4.2.0/contrib/regression/objs-gcc.sh 2005-12-02 18:38:22.000000000 +0100
|
||||
@@ -105,6 +105,10 @@ if [ $H_REAL_TARGET = $H_REAL_HOST -a $H
|
||||
then
|
||||
make all-gdb all-dejagnu all-ld || exit 1
|
||||
make install-gdb install-dejagnu install-ld || exit 1
|
||||
+elif [ $H_REAL_TARGET = $H_REAL_HOST -a $H_REAL_TARGET = i686-pc-linux-uclibc ]
|
||||
+ then
|
||||
+ make all-gdb all-dejagnu all-ld || exit 1
|
||||
+ make install-gdb install-dejagnu install-ld || exit 1
|
||||
elif [ $H_REAL_TARGET = $H_REAL_HOST ] ; then
|
||||
make bootstrap || exit 1
|
||||
make install || exit 1
|
||||
diff -ruNp gcc-4.2.0.oorig/gcc/config/alpha/linux-elf.h gcc-4.2.0/gcc/config/alpha/linux-elf.h
|
||||
--- gcc-4.2.0.oorig/gcc/config/alpha/linux-elf.h 2005-10-31 18:00:45.000000000 +0100
|
||||
+++ gcc-4.2.0/gcc/config/alpha/linux-elf.h 2005-12-02 18:38:22.000000000 +0100
|
||||
@@ -27,7 +27,11 @@ Boston, MA 02110-1301, USA. */
|
||||
#define SUBTARGET_EXTRA_SPECS \
|
||||
{ "elf_dynamic_linker", ELF_DYNAMIC_LINKER },
|
||||
|
||||
+#if defined USE_UCLIBC
|
||||
+#define ELF_DYNAMIC_LINKER "/lib/ld-uClibc.so.0"
|
||||
+#else
|
||||
#define ELF_DYNAMIC_LINKER "/lib/ld-linux.so.2"
|
||||
+#endif
|
||||
|
||||
#define LINK_SPEC "-m elf64alpha %{G*} %{relax:-relax} \
|
||||
%{O*:-O3} %{!O*:-O1} \
|
||||
diff -ruNp gcc-4.2.0.oorig/gcc/config/arm/linux-elf.h gcc-4.2.0/gcc/config/arm/linux-elf.h
|
||||
--- gcc-4.2.0.oorig/gcc/config/arm/linux-elf.h 2005-11-22 14:56:32.000000000 +0100
|
||||
+++ gcc-4.2.0/gcc/config/arm/linux-elf.h 2005-12-02 18:35:28.000000000 +0100
|
||||
@@ -51,7 +51,11 @@
|
||||
|
||||
#define LIBGCC_SPEC "%{msoft-float:-lfloat} %{mfloat-abi=soft*:-lfloat} -lgcc"
|
||||
|
||||
+#ifdef USE_UCLIBC
|
||||
+#define LINUX_TARGET_INTERPRETER "/lib/ld-uClibc.so.0"
|
||||
+#else
|
||||
#define LINUX_TARGET_INTERPRETER "/lib/ld-linux.so.2"
|
||||
+#endif
|
||||
|
||||
#define LINUX_TARGET_LINK_SPEC "%{h*} %{version:-v} \
|
||||
%{b} \
|
||||
diff -ruNp gcc-4.2.0.oorig/gcc/config/cris/linux.h gcc-4.2.0/gcc/config/cris/linux.h
|
||||
--- gcc-4.2.0.oorig/gcc/config/cris/linux.h 2005-11-22 14:56:32.000000000 +0100
|
||||
+++ gcc-4.2.0/gcc/config/cris/linux.h 2005-12-02 18:38:22.000000000 +0100
|
||||
@@ -73,6 +73,25 @@ Boston, MA 02110-1301, USA. */
|
||||
#undef CRIS_DEFAULT_CPU_VERSION
|
||||
#define CRIS_DEFAULT_CPU_VERSION CRIS_CPU_NG
|
||||
|
||||
+#ifdef USE_UCLIBC
|
||||
+
|
||||
+#undef CRIS_SUBTARGET_VERSION
|
||||
+#define CRIS_SUBTARGET_VERSION " - cris-axis-linux-uclibc"
|
||||
+
|
||||
+#undef CRIS_LINK_SUBTARGET_SPEC
|
||||
+#define CRIS_LINK_SUBTARGET_SPEC \
|
||||
+ "-mcrislinux\
|
||||
+ -rpath-link include/asm/../..%s\
|
||||
+ %{shared} %{static}\
|
||||
+ %{symbolic:-Bdynamic} %{shlib:-Bdynamic} %{static:-Bstatic}\
|
||||
+ %{!shared: \
|
||||
+ %{!static: \
|
||||
+ %{rdynamic:-export-dynamic} \
|
||||
+ %{!dynamic-linker:-dynamic-linker /lib/ld-uClibc.so.0}}} \
|
||||
+ %{!r:%{O2|O3: --gc-sections}}"
|
||||
+
|
||||
+#else /* USE_UCLIBC */
|
||||
+
|
||||
#undef CRIS_SUBTARGET_VERSION
|
||||
#define CRIS_SUBTARGET_VERSION " - cris-axis-linux-gnu"
|
||||
|
||||
@@ -87,6 +106,8 @@ Boston, MA 02110-1301, USA. */
|
||||
%{!shared:%{!static:%{rdynamic:-export-dynamic}}}\
|
||||
%{!r:%{O2|O3: --gc-sections}}"
|
||||
|
||||
+#endif /* USE_UCLIBC */
|
||||
+
|
||||
|
||||
/* Node: Run-time Target */
|
||||
|
||||
diff -ruNp gcc-4.2.0.oorig/gcc/config/cris/t-linux-uclibc gcc-4.2.0/gcc/config/cris/t-linux-uclibc
|
||||
--- gcc-4.2.0.oorig/gcc/config/cris/t-linux-uclibc 1970-01-01 01:00:00.000000000 +0100
|
||||
+++ gcc-4.2.0/gcc/config/cris/t-linux-uclibc 2005-12-02 18:38:22.000000000 +0100
|
||||
@@ -0,0 +1,3 @@
|
||||
+T_CFLAGS = -DUSE_UCLIBC
|
||||
+TARGET_LIBGCC2_CFLAGS += -fPIC
|
||||
+CRTSTUFF_T_CFLAGS_S = $(TARGET_LIBGCC2_CFLAGS)
|
||||
diff -ruNp gcc-4.2.0.oorig/gcc/config/i386/linux64.h gcc-4.2.0/gcc/config/i386/linux64.h
|
||||
--- gcc-4.2.0.oorig/gcc/config/i386/linux64.h 2005-11-22 14:56:29.000000000 +0100
|
||||
+++ gcc-4.2.0/gcc/config/i386/linux64.h 2005-12-02 18:38:22.000000000 +0100
|
||||
@@ -50,6 +50,15 @@ Boston, MA 02110-1301, USA. */
|
||||
done. */
|
||||
|
||||
#undef LINK_SPEC
|
||||
+#if defined USE_UCLIBC
|
||||
+#define LINK_SPEC "%{!m32:-m elf_x86_64} %{m32:-m elf_i386} \
|
||||
+ %{shared:-shared} \
|
||||
+ %{!shared: \
|
||||
+ %{!static: \
|
||||
+ %{rdynamic:-export-dynamic} \
|
||||
+ %{!dynamic-linker:-dynamic-linker /lib/ld-uClibc.so.0}} \
|
||||
+ %{static:-static}}"
|
||||
+#else
|
||||
#define LINK_SPEC "%{!m32:-m elf_x86_64} %{m32:-m elf_i386} \
|
||||
%{shared:-shared} \
|
||||
%{!shared: \
|
||||
@@ -58,6 +67,7 @@ Boston, MA 02110-1301, USA. */
|
||||
%{m32:%{!dynamic-linker:-dynamic-linker /lib/ld-linux.so.2}} \
|
||||
%{!m32:%{!dynamic-linker:-dynamic-linker /lib64/ld-linux-x86-64.so.2}}} \
|
||||
%{static:-static}}"
|
||||
+#endif
|
||||
|
||||
/* Similar to standard Linux, but adding -ffast-math support. */
|
||||
#undef ENDFILE_SPEC
|
||||
diff -ruNp gcc-4.2.0.oorig/gcc/config/i386/linux.h gcc-4.2.0/gcc/config/i386/linux.h
|
||||
--- gcc-4.2.0.oorig/gcc/config/i386/linux.h 2005-11-22 14:56:29.000000000 +0100
|
||||
+++ gcc-4.2.0/gcc/config/i386/linux.h 2005-12-02 18:38:22.000000000 +0100
|
||||
@@ -102,6 +102,11 @@ Boston, MA 02110-1301, USA. */
|
||||
#define LINK_EMULATION "elf_i386"
|
||||
#define DYNAMIC_LINKER "/lib/ld-linux.so.2"
|
||||
|
||||
+#if defined USE_UCLIBC
|
||||
+#undef DYNAMIC_LINKER
|
||||
+#define DYNAMIC_LINKER "/lib/ld-uClibc.so.0"
|
||||
+#endif
|
||||
+
|
||||
#undef SUBTARGET_EXTRA_SPECS
|
||||
#define SUBTARGET_EXTRA_SPECS \
|
||||
{ "link_emulation", LINK_EMULATION },\
|
||||
diff -ruNp gcc-4.2.0.oorig/gcc/config/mips/linux.h gcc-4.2.0/gcc/config/mips/linux.h
|
||||
--- gcc-4.2.0.oorig/gcc/config/mips/linux.h 2005-11-22 14:56:32.000000000 +0100
|
||||
+++ gcc-4.2.0/gcc/config/mips/linux.h 2005-12-02 18:38:22.000000000 +0100
|
||||
@@ -100,6 +100,17 @@ Boston, MA 02110-1301, USA. */
|
||||
|
||||
/* Borrowed from sparc/linux.h */
|
||||
#undef LINK_SPEC
|
||||
+#ifdef USE_UCLIBC
|
||||
+#define LINK_SPEC \
|
||||
+ "%(endian_spec) \
|
||||
+ %{shared:-shared} \
|
||||
+ %{!shared: \
|
||||
+ %{!ibcs: \
|
||||
+ %{!static: \
|
||||
+ %{rdynamic:-export-dynamic} \
|
||||
+ %{!dynamic-linker:-dynamic-linker /lib/ld-uClibc.so.0}} \
|
||||
+ %{static:-static}}}"
|
||||
+#else
|
||||
#define LINK_SPEC \
|
||||
"%(endian_spec) \
|
||||
%{shared:-shared} \
|
||||
@@ -109,6 +120,7 @@ Boston, MA 02110-1301, USA. */
|
||||
%{rdynamic:-export-dynamic} \
|
||||
%{!dynamic-linker:-dynamic-linker /lib/ld.so.1}} \
|
||||
%{static:-static}}}"
|
||||
+#endif
|
||||
|
||||
#undef SUBTARGET_ASM_SPEC
|
||||
#define SUBTARGET_ASM_SPEC "%{mabi=64: -64} %{!mno-abicalls:-KPIC}"
|
||||
diff -ruNp gcc-4.2.0.oorig/gcc/config/rs6000/linux.h gcc-4.2.0/gcc/config/rs6000/linux.h
|
||||
--- gcc-4.2.0.oorig/gcc/config/rs6000/linux.h 2005-10-31 18:01:48.000000000 +0100
|
||||
+++ gcc-4.2.0/gcc/config/rs6000/linux.h 2005-12-02 18:38:22.000000000 +0100
|
||||
@@ -72,7 +72,11 @@
|
||||
#define LINK_START_DEFAULT_SPEC "%(link_start_linux)"
|
||||
|
||||
#undef LINK_OS_DEFAULT_SPEC
|
||||
+#ifdef USE_UCLIBC
|
||||
+#define LINK_OS_DEFAULT_SPEC "%(link_os_linux_uclibc)"
|
||||
+#else
|
||||
#define LINK_OS_DEFAULT_SPEC "%(link_os_linux)"
|
||||
+#endif
|
||||
|
||||
#define LINK_GCC_C_SEQUENCE_SPEC \
|
||||
"%{static:--start-group} %G %L %{static:--end-group}%{!static:%G}"
|
||||
diff -ruNp gcc-4.2.0.oorig/gcc/config/rs6000/sysv4.h gcc-4.2.0/gcc/config/rs6000/sysv4.h
|
||||
--- gcc-4.2.0.oorig/gcc/config/rs6000/sysv4.h 2005-11-28 19:45:18.000000000 +0100
|
||||
+++ gcc-4.2.0/gcc/config/rs6000/sysv4.h 2005-12-02 18:38:22.000000000 +0100
|
||||
@@ -850,6 +850,7 @@ extern int fixuplabelno;
|
||||
mcall-linux : %(link_os_linux) ; \
|
||||
mcall-gnu : %(link_os_gnu) ; \
|
||||
mcall-netbsd : %(link_os_netbsd) ; \
|
||||
+ mcall-linux-uclibc : %(link_os_linux_uclibc); \
|
||||
mcall-openbsd: %(link_os_openbsd) ; \
|
||||
: %(link_os_default) }"
|
||||
|
||||
@@ -1027,6 +1028,10 @@ extern int fixuplabelno;
|
||||
%{rdynamic:-export-dynamic} \
|
||||
%{!dynamic-linker:-dynamic-linker /lib/ld.so.1}}}"
|
||||
|
||||
+#define LINK_OS_LINUX_UCLIBC_SPEC "-m elf32ppclinux %{!shared: %{!static: \
|
||||
+ %{rdynamic:-export-dynamic} \
|
||||
+ %{!dynamic-linker:-dynamic-linker /lib/ld-uClibc.so.0}}}"
|
||||
+
|
||||
#if defined(HAVE_LD_EH_FRAME_HDR)
|
||||
# define LINK_EH_SPEC "%{!static:--eh-frame-hdr} "
|
||||
#endif
|
||||
@@ -1193,6 +1198,7 @@ ncrtn.o%s"
|
||||
{ "link_os_sim", LINK_OS_SIM_SPEC }, \
|
||||
{ "link_os_freebsd", LINK_OS_FREEBSD_SPEC }, \
|
||||
{ "link_os_linux", LINK_OS_LINUX_SPEC }, \
|
||||
+ { "link_os_linux_uclibc", LINK_OS_LINUX_UCLIBC_SPEC }, \
|
||||
{ "link_os_gnu", LINK_OS_GNU_SPEC }, \
|
||||
{ "link_os_netbsd", LINK_OS_NETBSD_SPEC }, \
|
||||
{ "link_os_openbsd", LINK_OS_OPENBSD_SPEC }, \
|
||||
diff -ruNp gcc-4.2.0.oorig/gcc/config/sh/linux.h gcc-4.2.0/gcc/config/sh/linux.h
|
||||
--- gcc-4.2.0.oorig/gcc/config/sh/linux.h 2005-11-22 14:56:32.000000000 +0100
|
||||
+++ gcc-4.2.0/gcc/config/sh/linux.h 2005-12-02 18:38:22.000000000 +0100
|
||||
@@ -51,12 +51,21 @@ Boston, MA 02110-1301, USA. */
|
||||
#undef SUBTARGET_LINK_EMUL_SUFFIX
|
||||
#define SUBTARGET_LINK_EMUL_SUFFIX "_linux"
|
||||
#undef SUBTARGET_LINK_SPEC
|
||||
+#ifdef USE_UCLIBC
|
||||
+#define SUBTARGET_LINK_SPEC \
|
||||
+ "%{shared:-shared} \
|
||||
+ %{!static: \
|
||||
+ %{rdynamic:-export-dynamic} \
|
||||
+ %{!dynamic-linker:-dynamic-linker /lib/ld-uClibc.so.0}} \
|
||||
+ %{static:-static}"
|
||||
+#else
|
||||
#define SUBTARGET_LINK_SPEC \
|
||||
"%{shared:-shared} \
|
||||
%{!static: \
|
||||
%{rdynamic:-export-dynamic} \
|
||||
%{!dynamic-linker:-dynamic-linker /lib/ld-linux.so.2}} \
|
||||
%{static:-static}"
|
||||
+#endif
|
||||
|
||||
/* Output assembler code to STREAM to call the profiler. */
|
||||
|
||||
diff -ruNp gcc-4.2.0.oorig/gcc/config/t-linux-uclibc gcc-4.2.0/gcc/config/t-linux-uclibc
|
||||
--- gcc-4.2.0.oorig/gcc/config/t-linux-uclibc 1970-01-01 01:00:00.000000000 +0100
|
||||
+++ gcc-4.2.0/gcc/config/t-linux-uclibc 2005-12-02 18:38:22.000000000 +0100
|
||||
@@ -0,0 +1,15 @@
|
||||
+T_CFLAGS = -DUSE_UCLIBC
|
||||
+
|
||||
+# Compile crtbeginS.o and crtendS.o with pic.
|
||||
+CRTSTUFF_T_CFLAGS_S = $(CRTSTUFF_T_CFLAGS) -fPIC
|
||||
+# Compile libgcc2.a with pic.
|
||||
+TARGET_LIBGCC2_CFLAGS = -fPIC
|
||||
+
|
||||
+# Override t-slibgcc-elf-ver to export some libgcc symbols with
|
||||
+# the symbol versions that glibc used.
|
||||
+#SHLIB_MAPFILES += $(srcdir)/config/libgcc-glibc.ver
|
||||
+
|
||||
+# Use unwind-dw2-fde
|
||||
+LIB2ADDEH = $(srcdir)/unwind-dw2.c $(srcdir)/unwind-dw2-fde.c \
|
||||
+ $(srcdir)/unwind-sjlj.c $(srcdir)/gthr-gnat.c $(srcdir)/unwind-c.c
|
||||
+LIB2ADDEHDEP = unwind.inc unwind-dw2-fde.h
|
||||
diff -ruNp gcc-4.2.0.oorig/gcc/config.gcc gcc-4.2.0/gcc/config.gcc
|
||||
--- gcc-4.2.0.oorig/gcc/config.gcc 2005-11-30 20:49:48.000000000 +0100
|
||||
+++ gcc-4.2.0/gcc/config.gcc 2005-12-02 18:38:22.000000000 +0100
|
||||
@@ -451,7 +451,12 @@ case ${target} in
|
||||
case ${enable_threads} in
|
||||
"" | yes | posix) thread_file='posix' ;;
|
||||
esac
|
||||
- tmake_file="t-slibgcc-elf-ver t-linux"
|
||||
+ case ${target} in
|
||||
+ *-*-linux-uclibc*)
|
||||
+ tmake_file="t-slibgcc-elf-ver t-linux-uclibc" ;;
|
||||
+ *)
|
||||
+ tmake_file="t-slibgcc-elf-ver t-linux" ;;
|
||||
+ esac
|
||||
;;
|
||||
*-*-gnu*)
|
||||
# On the Hurd, the setup is just about the same on
|
||||
@@ -789,6 +794,10 @@ cris-*-elf | cris-*-none)
|
||||
gas=yes
|
||||
extra_options="${extra_options} cris/elf.opt"
|
||||
;;
|
||||
+cris-*-linux-uclibc*)
|
||||
+ tm_file="dbxelf.h elfos.h svr4.h ${tm_file} linux.h cris/linux.h"
|
||||
+ tmake_file="cris/t-cris t-slibgcc-elf-ver cris/t-linux-uclibc"
|
||||
+ ;;
|
||||
cris-*-linux*)
|
||||
tm_file="dbxelf.h elfos.h svr4.h ${tm_file} linux.h cris/linux.h"
|
||||
# We need to avoid using t-linux, so override default tmake_file
|
||||
@@ -1876,7 +1885,7 @@ s390x-ibm-tpf*)
|
||||
;;
|
||||
sh-*-elf* | sh[12346l]*-*-elf* | sh*-*-kaos* | \
|
||||
sh-*-symbianelf* | sh[12346l]*-*-symbianelf* | \
|
||||
- sh-*-linux* | sh[346lbe]*-*-linux* | \
|
||||
+ sh*-*-linux* | sh[346lbe]*-*-linux* | \
|
||||
sh-*-netbsdelf* | shl*-*-netbsdelf* | sh5-*-netbsd* | sh5l*-*-netbsd* | \
|
||||
sh64-*-netbsd* | sh64l*-*-netbsd*)
|
||||
tmake_file="${tmake_file} sh/t-sh sh/t-elf"
|
||||
diff -ruNp gcc-4.2.0.oorig/libffi/configure gcc-4.2.0/libffi/configure
|
||||
--- gcc-4.2.0.oorig/libffi/configure 2005-10-31 18:09:56.000000000 +0100
|
||||
+++ gcc-4.2.0/libffi/configure 2005-12-02 18:38:22.000000000 +0100
|
||||
@@ -3457,6 +3457,11 @@ linux-gnu*)
|
||||
lt_cv_deplibs_check_method=pass_all
|
||||
;;
|
||||
|
||||
+linux-uclibc*)
|
||||
+ lt_cv_deplibs_check_method=pass_all
|
||||
+ lt_cv_file_magic_test_file=`echo /lib/libuClibc-*.so`
|
||||
+ ;;
|
||||
+
|
||||
netbsd* | knetbsd*-gnu)
|
||||
if echo __ELF__ | $CC -E - | grep __ELF__ > /dev/null; then
|
||||
lt_cv_deplibs_check_method='match_pattern /lib[^/\.]+\.so\.[0-9]+\.[0-9]+$'
|
||||
diff -ruNp gcc-4.2.0.oorig/libgfortran/configure gcc-4.2.0/libgfortran/configure
|
||||
--- gcc-4.2.0.oorig/libgfortran/configure 2005-11-30 20:49:48.000000000 +0100
|
||||
+++ gcc-4.2.0/libgfortran/configure 2005-12-02 18:38:22.000000000 +0100
|
||||
@@ -3669,6 +3669,11 @@ linux-gnu*)
|
||||
lt_cv_deplibs_check_method=pass_all
|
||||
;;
|
||||
|
||||
+linux-uclibc*)
|
||||
+ lt_cv_deplibs_check_method=pass_all
|
||||
+ lt_cv_file_magic_test_file=`echo /lib/libuClibc-*.so`
|
||||
+ ;;
|
||||
+
|
||||
netbsd* | knetbsd*-gnu)
|
||||
if echo __ELF__ | $CC -E - | grep __ELF__ > /dev/null; then
|
||||
lt_cv_deplibs_check_method='match_pattern /lib[^/\.]+\.so\.[0-9]+\.[0-9]+$'
|
||||
diff -ruNp gcc-4.2.0.oorig/libjava/configure gcc-4.2.0/libjava/configure
|
||||
--- gcc-4.2.0.oorig/libjava/configure 2005-11-25 18:32:38.000000000 +0100
|
||||
+++ gcc-4.2.0/libjava/configure 2005-12-02 18:38:22.000000000 +0100
|
||||
@@ -5137,6 +5137,11 @@ linux-gnu*)
|
||||
lt_cv_deplibs_check_method=pass_all
|
||||
;;
|
||||
|
||||
+linux-uclibc*)
|
||||
+ lt_cv_deplibs_check_method=pass_all
|
||||
+ lt_cv_file_magic_test_file=`echo /lib/libuClibc-*.so`
|
||||
+ ;;
|
||||
+
|
||||
netbsd* | knetbsd*-gnu)
|
||||
if echo __ELF__ | $CC -E - | grep __ELF__ > /dev/null; then
|
||||
lt_cv_deplibs_check_method='match_pattern /lib[^/\.]+\.so\.[0-9]+\.[0-9]+$'
|
||||
diff -ruNp gcc-4.2.0.oorig/libmudflap/configure gcc-4.2.0/libmudflap/configure
|
||||
--- gcc-4.2.0.oorig/libmudflap/configure 2005-10-31 18:08:44.000000000 +0100
|
||||
+++ gcc-4.2.0/libmudflap/configure 2005-12-02 18:38:22.000000000 +0100
|
||||
@@ -5382,6 +5382,11 @@ linux-gnu*)
|
||||
lt_cv_deplibs_check_method=pass_all
|
||||
;;
|
||||
|
||||
+linux-uclibc*)
|
||||
+ lt_cv_deplibs_check_method=pass_all
|
||||
+ lt_cv_file_magic_test_file=`echo /lib/libuClibc-*.so`
|
||||
+ ;;
|
||||
+
|
||||
netbsd* | knetbsd*-gnu)
|
||||
if echo __ELF__ | $CC -E - | grep __ELF__ > /dev/null; then
|
||||
lt_cv_deplibs_check_method='match_pattern /lib[^/\.]+\.so\.[0-9]+\.[0-9]+$'
|
||||
diff -ruNp gcc-4.2.0.oorig/libobjc/configure gcc-4.2.0/libobjc/configure
|
||||
--- gcc-4.2.0.oorig/libobjc/configure 2005-11-20 13:52:50.000000000 +0100
|
||||
+++ gcc-4.2.0/libobjc/configure 2005-12-02 18:38:22.000000000 +0100
|
||||
@@ -3312,6 +3312,11 @@ linux-gnu*)
|
||||
lt_cv_deplibs_check_method=pass_all
|
||||
;;
|
||||
|
||||
+linux-uclibc*)
|
||||
+ lt_cv_deplibs_check_method=pass_all
|
||||
+ lt_cv_file_magic_test_file=`echo /lib/libuClibc-*.so`
|
||||
+ ;;
|
||||
+
|
||||
netbsd* | knetbsd*-gnu)
|
||||
if echo __ELF__ | $CC -E - | grep __ELF__ > /dev/null; then
|
||||
lt_cv_deplibs_check_method='match_pattern /lib[^/\.]+\.so\.[0-9]+\.[0-9]+$'
|
||||
diff -ruNp gcc-4.2.0.oorig/libtool.m4 gcc-4.2.0/libtool.m4
|
||||
--- gcc-4.2.0.oorig/libtool.m4 2005-10-31 18:19:54.000000000 +0100
|
||||
+++ gcc-4.2.0/libtool.m4 2005-12-02 18:38:22.000000000 +0100
|
||||
@@ -743,6 +743,11 @@ linux-gnu*)
|
||||
lt_cv_deplibs_check_method=pass_all
|
||||
;;
|
||||
|
||||
+linux-uclibc*)
|
||||
+ lt_cv_deplibs_check_method=pass_all
|
||||
+ lt_cv_file_magic_test_file=`echo /lib/libuClibc-*.so`
|
||||
+ ;;
|
||||
+
|
||||
netbsd* | knetbsd*-gnu)
|
||||
if echo __ELF__ | $CC -E - | grep __ELF__ > /dev/null; then
|
||||
[lt_cv_deplibs_check_method='match_pattern /lib[^/\.]+\.so\.[0-9]+\.[0-9]+$']
|
||||
diff -ruNp gcc-4.2.0.oorig/ltconfig gcc-4.2.0/ltconfig
|
||||
--- gcc-4.2.0.oorig/ltconfig 2005-10-31 18:19:54.000000000 +0100
|
||||
+++ gcc-4.2.0/ltconfig 2005-12-02 18:38:22.000000000 +0100
|
||||
@@ -603,6 +603,7 @@ host_os=`echo $host | sed 's/^\([^-]*\)-
|
||||
|
||||
# Transform linux* to *-*-linux-gnu*, to support old configure scripts.
|
||||
case $host_os in
|
||||
+linux-uclibc*) ;;
|
||||
linux-gnu*) ;;
|
||||
linux*) host=`echo $host | sed 's/^\(.*-.*-linux\)\(.*\)$/\1-gnu\2/'`
|
||||
esac
|
||||
@@ -1274,6 +1275,23 @@ linux-gnu*)
|
||||
dynamic_linker='GNU/Linux ld.so'
|
||||
;;
|
||||
|
||||
+linux-uclibc*)
|
||||
+ version_type=linux
|
||||
+ need_lib_prefix=no
|
||||
+ need_version=no
|
||||
+ library_names_spec='${libname}${release}.so$versuffix ${libname}${release}.so$major $libname.so'
|
||||
+ soname_spec='${libname}${release}.so$major'
|
||||
+ finish_cmds='PATH="\$PATH:/sbin" ldconfig -n $libdir'
|
||||
+ shlibpath_var=LD_LIBRARY_PATH
|
||||
+ shlibpath_overrides_runpath=no
|
||||
+ # This implies no fast_install, which is unacceptable.
|
||||
+ # Some rework will be needed to allow for fast_install
|
||||
+ # before this can be enabled.
|
||||
+ hardcode_into_libs=yes
|
||||
+ # Assume using the uClibc dynamic linker.
|
||||
+ dynamic_linker="uClibc ld.so"
|
||||
+ ;;
|
||||
+
|
||||
netbsd*)
|
||||
need_lib_prefix=no
|
||||
need_version=no
|
||||
diff -ruNp gcc-4.2.0.oorig/zlib/configure gcc-4.2.0/zlib/configure
|
||||
--- gcc-4.2.0.oorig/zlib/configure 2005-10-31 18:07:37.000000000 +0100
|
||||
+++ gcc-4.2.0/zlib/configure 2005-12-02 18:38:22.000000000 +0100
|
||||
@@ -3426,6 +3426,11 @@ linux-gnu*)
|
||||
lt_cv_deplibs_check_method=pass_all
|
||||
;;
|
||||
|
||||
+linux-uclibc*)
|
||||
+ lt_cv_deplibs_check_method=pass_all
|
||||
+ lt_cv_file_magic_test_file=`echo /lib/libuClibc-*.so`
|
||||
+ ;;
|
||||
+
|
||||
netbsd* | knetbsd*-gnu)
|
||||
if echo __ELF__ | $CC -E - | grep __ELF__ > /dev/null; then
|
||||
lt_cv_deplibs_check_method='match_pattern /lib[^/\.]+\.so\.[0-9]+\.[0-9]+$'
|
3246
toolchain/gcc/4.2.0/200-uclibc-locale.patch
Normal file
3246
toolchain/gcc/4.2.0/200-uclibc-locale.patch
Normal file
File diff suppressed because it is too large
Load Diff
46
toolchain/gcc/4.2.0/300-libstdc++-pic.patch
Normal file
46
toolchain/gcc/4.2.0/300-libstdc++-pic.patch
Normal file
@ -0,0 +1,46 @@
|
||||
# DP: Build and install libstdc++_pic.a library.
|
||||
|
||||
--- gcc-4.1.0/libstdc++-v3/src/Makefile.am 2004-11-15 17:33:05.000000000 -0600
|
||||
+++ gcc-4.1.0-patched/libstdc++-v3/src/Makefile.am 2005-04-25 20:05:59.186930896 -0500
|
||||
@@ -214,6 +214,10 @@
|
||||
$(OPT_LDFLAGS) $(SECTION_LDFLAGS) $(AM_CXXFLAGS) $(LDFLAGS) -o $@
|
||||
|
||||
|
||||
+install-exec-local:
|
||||
+ $(AR) cru libstdc++_pic.a .libs/*.o $(top_builddir)/libsupc++/*.o
|
||||
+ $(INSTALL_DATA) libstdc++_pic.a $(DESTDIR)$(toolexeclibdir)
|
||||
+
|
||||
# Added bits to build debug library.
|
||||
if GLIBCXX_BUILD_DEBUG
|
||||
all-local: build_debug
|
||||
--- gcc-4.1.0/libstdc++-v3/src/Makefile.in 2005-04-11 19:13:08.000000000 -0500
|
||||
+++ gcc-4.1.0-patched/libstdc++-v3/src/Makefile.in 2005-04-25 20:12:33.284316275 -0500
|
||||
@@ -627,7 +627,7 @@
|
||||
|
||||
install-data-am: install-data-local
|
||||
|
||||
-install-exec-am: install-toolexeclibLTLIBRARIES
|
||||
+install-exec-am: install-toolexeclibLTLIBRARIES install-exec-local
|
||||
|
||||
install-info: install-info-am
|
||||
|
||||
@@ -660,6 +660,7 @@
|
||||
distclean-libtool distclean-tags distdir dvi dvi-am html \
|
||||
html-am info info-am install install-am install-data \
|
||||
install-data-am install-data-local install-exec \
|
||||
+ install-exec-local \
|
||||
install-exec-am install-info install-info-am install-man \
|
||||
install-strip install-toolexeclibLTLIBRARIES installcheck \
|
||||
installcheck-am installdirs maintainer-clean \
|
||||
@@ -745,6 +746,11 @@
|
||||
install_debug:
|
||||
(cd ${debugdir} && $(MAKE) \
|
||||
toolexeclibdir=$(glibcxx_toolexeclibdir)/debug install)
|
||||
+
|
||||
+install-exec-local:
|
||||
+ $(AR) cru libstdc++_pic.a .libs/*.o $(top_builddir)/libsupc++/*.o
|
||||
+ $(INSTALL_DATA) libstdc++_pic.a $(DESTDIR)$(toolexeclibdir)
|
||||
+
|
||||
# Tell versions [3.59,3.63) of GNU make to not export all variables.
|
||||
# Otherwise a system limit (for SysV at least) may be exceeded.
|
||||
.NOEXPORT:
|
11
toolchain/gcc/4.2.0/301-missing-execinfo_h.patch
Normal file
11
toolchain/gcc/4.2.0/301-missing-execinfo_h.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- gcc-4.0.0/boehm-gc/include/gc.h-orig 2005-04-28 22:28:57.000000000 -0500
|
||||
+++ gcc-4.0.0/boehm-gc/include/gc.h 2005-04-28 22:30:38.000000000 -0500
|
||||
@@ -500,7 +500,7 @@
|
||||
#ifdef __linux__
|
||||
# include <features.h>
|
||||
# if (__GLIBC__ == 2 && __GLIBC_MINOR__ >= 1 || __GLIBC__ > 2) \
|
||||
- && !defined(__ia64__)
|
||||
+ && !defined(__ia64__) && !defined(__UCLIBC__)
|
||||
# ifndef GC_HAVE_BUILTIN_BACKTRACE
|
||||
# define GC_HAVE_BUILTIN_BACKTRACE
|
||||
# endif
|
11
toolchain/gcc/4.2.0/302-c99-snprintf.patch
Normal file
11
toolchain/gcc/4.2.0/302-c99-snprintf.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- gcc-4.0.0/libstdc++-v3/include/c_std/std_cstdio.h-orig 2005-04-29 00:08:41.000000000 -0500
|
||||
+++ gcc-4.0.0/libstdc++-v3/include/c_std/std_cstdio.h 2005-04-29 00:08:45.000000000 -0500
|
||||
@@ -142,7 +142,7 @@
|
||||
using ::vsprintf;
|
||||
}
|
||||
|
||||
-#if _GLIBCXX_USE_C99
|
||||
+#if _GLIBCXX_USE_C99 || defined(__UCLIBC__)
|
||||
|
||||
#undef snprintf
|
||||
#undef vfscanf
|
12
toolchain/gcc/4.2.0/303-c99-complex-ugly-hack.patch
Normal file
12
toolchain/gcc/4.2.0/303-c99-complex-ugly-hack.patch
Normal file
@ -0,0 +1,12 @@
|
||||
--- gcc-4.0.0/libstdc++-v3/configure-old 2005-04-30 22:04:48.061603912 -0500
|
||||
+++ gcc-4.0.0/libstdc++-v3/configure 2005-04-30 22:06:13.678588152 -0500
|
||||
@@ -7194,6 +7194,9 @@
|
||||
cat >>conftest.$ac_ext <<_ACEOF
|
||||
/* end confdefs.h. */
|
||||
#include <complex.h>
|
||||
+#ifdef __UCLIBC__
|
||||
+#error ugly hack to make sure configure test fails here for cross until uClibc supports the complex funcs
|
||||
+#endif
|
||||
int
|
||||
main ()
|
||||
{
|
20
toolchain/gcc/4.2.0/602-sdk-libstdc++-includes.patch
Normal file
20
toolchain/gcc/4.2.0/602-sdk-libstdc++-includes.patch
Normal file
@ -0,0 +1,20 @@
|
||||
--- gcc-4.1.0/libstdc++-v3/fragment.am 2005-03-21 11:40:14.000000000 -0600
|
||||
+++ gcc-4.1.0-patched/libstdc++-v3/fragment.am 2005-04-25 20:14:39.856251785 -0500
|
||||
@@ -21,5 +21,5 @@
|
||||
$(WARN_FLAGS) $(WERROR) -fdiagnostics-show-location=once
|
||||
|
||||
# -I/-D flags to pass when compiling.
|
||||
-AM_CPPFLAGS = $(GLIBCXX_INCLUDES)
|
||||
+AM_CPPFLAGS = $(GLIBCXX_INCLUDES) -I$(toplevel_srcdir)/include
|
||||
|
||||
--- gcc-4.1.0/libstdc++-v3/libmath/Makefile.am 2005-03-21 11:40:18.000000000 -0600
|
||||
+++ gcc-4.1.0-patched/libstdc++-v3/libmath/Makefile.am 2005-04-25 20:14:39.682280735 -0500
|
||||
@@ -35,7 +35,7 @@
|
||||
|
||||
libmath_la_SOURCES = stubs.c
|
||||
|
||||
-AM_CPPFLAGS = $(CANADIAN_INCLUDES)
|
||||
+AM_CPPFLAGS = $(CANADIAN_INCLUDES) -I$(toplevel_srcdir)/include
|
||||
|
||||
# Only compiling "C" sources in this directory.
|
||||
LIBTOOL = @LIBTOOL@ --tag CC
|
@ -38,6 +38,9 @@ choice
|
||||
config BR2_GCC_VERSION_4_1_0
|
||||
bool "gcc 4.1.0"
|
||||
|
||||
config BR2_GCC_VERSION_4_2_0
|
||||
bool "gcc 4.2.0"
|
||||
|
||||
endchoice
|
||||
|
||||
config BR2_GCC_VERSION
|
||||
@ -52,6 +55,7 @@ config BR2_GCC_VERSION
|
||||
default "4.0.1" if BR2_GCC_VERSION_4_0_1
|
||||
default "4.0.2" if BR2_GCC_VERSION_4_0_2
|
||||
default "4.1.0" if BR2_GCC_VERSION_4_1_0
|
||||
default "4.2.0" if BR2_GCC_VERSION_4_2_0
|
||||
|
||||
|
||||
config BR2_GCC_USE_SJLJ_EXCEPTIONS
|
||||
|
@ -52,6 +52,10 @@ ifeq ($(BR2_INSTALL_OBJC),y)
|
||||
TARGET_LANGUAGES:=$(TARGET_LANGUAGES),objc
|
||||
endif
|
||||
|
||||
ifeq ($(BR2_INSTALL_FORTRAN),y)
|
||||
TARGET_LANGUAGES:=$(TARGET_LANGUAGES),fortran
|
||||
endif
|
||||
|
||||
#############################################################
|
||||
#
|
||||
# build the first pass gcc compiler
|
||||
@ -92,9 +96,12 @@ endif
|
||||
endif
|
||||
touch $(GCC_DIR)/.patched
|
||||
|
||||
ifeq ("$(GCC_VERSION)","4.2.0")
|
||||
EXTRA_GCC_CONFIG_OPTIONS+= --disable-libmudflap
|
||||
endif
|
||||
# The --without-headers option stopped working with gcc 3.0 and has never been
|
||||
# # fixed, so we need to actually have working C library header files prior to
|
||||
# # the step or libgcc will not build...
|
||||
# fixed, so we need to actually have working C library header files prior to
|
||||
# the step or libgcc will not build...
|
||||
|
||||
$(GCC_BUILD_DIR1)/.configured: $(GCC_DIR)/.patched
|
||||
mkdir -p $(GCC_BUILD_DIR1)
|
||||
@ -311,6 +318,9 @@ endif
|
||||
ifeq ($(findstring 4.1.,$(GCC_VERSION)),4.1.)
|
||||
GCC_LIB_SUBDIR=lib/gcc/$(REAL_GNU_TARGET_NAME)/$(GCC_VERSION)
|
||||
endif
|
||||
ifeq ($(findstring 4.2.,$(GCC_VERSION)),4.2.)
|
||||
GCC_LIB_SUBDIR=lib/gcc/$(REAL_GNU_TARGET_NAME)/$(GCC_VERSION)
|
||||
endif
|
||||
|
||||
$(TARGET_DIR)/usr/bin/gcc: $(GCC_BUILD_DIR3)/.compiled
|
||||
PATH=$(TARGET_PATH) \
|
||||
@ -341,8 +351,8 @@ endif
|
||||
#rm -rf $(TARGET_DIR)/share/locale $(TARGET_DIR)/usr/info \
|
||||
# $(TARGET_DIR)/usr/man $(TARGET_DIR)/usr/share/doc
|
||||
# Work around problem of missing syslimits.h
|
||||
@if [ ! -f $(TARGET_DIR)/usr/$(GCC_LIB_SUBDIR)/include/syslimits.h ] ; then \
|
||||
echo "warning: working around missing syslimits.h" ; \
|
||||
if [ ! -f $(TARGET_DIR)/usr/$(GCC_LIB_SUBDIR)/include/syslimits.h ] ; then \
|
||||
@echo "warning: working around missing syslimits.h" ; \
|
||||
cp -f $(STAGING_DIR)/$(GCC_LIB_SUBDIR)/include/syslimits.h \
|
||||
$(TARGET_DIR)/usr/$(GCC_LIB_SUBDIR)/include/ ; \
|
||||
fi
|
||||
|
Loading…
Reference in New Issue
Block a user