package/python-magic-wormhole-mailbox-server: new package
This package is the main server that Magic-Wormhole clients connect to. The server performs store-and-forward delivery for small key-exchange and control messages. Bulk data is sent over a direct TCP connection, or through a transit-relay. https://github.com/magic-wormhole/magic-wormhole-mailbox-server Signed-off-by: Julien Olivain <ju.o@free.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
This commit is contained in:
parent
eb013c3757
commit
9244052f28
@ -1695,6 +1695,7 @@ F: package/python-distro/
|
||||
F: package/python-gnupg/
|
||||
F: package/python-hkdf/
|
||||
F: package/python-magic-wormhole/
|
||||
F: package/python-magic-wormhole-mailbox-server/
|
||||
F: package/python-pyalsa/
|
||||
F: package/python-spake2/
|
||||
F: package/rdma-core/
|
||||
|
@ -1121,6 +1121,7 @@ menu "External python modules"
|
||||
source "package/python-lxml/Config.in"
|
||||
source "package/python-m2crypto/Config.in"
|
||||
source "package/python-magic-wormhole/Config.in"
|
||||
source "package/python-magic-wormhole-mailbox-server/Config.in"
|
||||
source "package/python-mako/Config.in"
|
||||
source "package/python-markdown/Config.in"
|
||||
source "package/python-markdown2/Config.in"
|
||||
|
@ -0,0 +1,39 @@
|
||||
From df6126ee86c1f84c7e0c25fcf69543b83b1b32c6 Mon Sep 17 00:00:00 2001
|
||||
From: Julien Olivain <ju.o@free.fr>
|
||||
Date: Sat, 5 Nov 2022 13:06:07 +0100
|
||||
Subject: [PATCH] setup.py: remove the 'U' open mode removed in Python 3.11
|
||||
|
||||
The 'U' open mode was removed in Python 3.11. See:
|
||||
https://docs.python.org/3.11/library/functions.html#open
|
||||
|
||||
Installing with Python 3.11 fails with:
|
||||
|
||||
/path/to/python-magic-wormhole-mailbox-server-0.4.1/setup.py", line 20, in <module>
|
||||
long_description=open('README.md', 'rU').read(),
|
||||
^^^^^^^^^^^^^^^^^^^^^^^
|
||||
ValueError: invalid mode: 'rU'
|
||||
|
||||
This patch removes the 'U' open mode.
|
||||
|
||||
Upstream: https://github.com/magic-wormhole/magic-wormhole-mailbox-server/commit/df6126ee86c1f84c7e0c25fcf69543b83b1b32c6
|
||||
Signed-off-by: Julien Olivain <ju.o@free.fr>
|
||||
---
|
||||
setup.py | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/setup.py b/setup.py
|
||||
index 6ef292f..ad9ff5a 100644
|
||||
--- a/setup.py
|
||||
+++ b/setup.py
|
||||
@@ -17,7 +17,7 @@ trove_classifiers = [
|
||||
setup(name="magic-wormhole-mailbox-server",
|
||||
version=versioneer.get_version(),
|
||||
description="Securely transfer data between computers",
|
||||
- long_description=open('README.md', 'rU').read(),
|
||||
+ long_description=open('README.md', 'r').read(),
|
||||
long_description_content_type='text/markdown',
|
||||
author="Brian Warner",
|
||||
author_email="warner-magic-wormhole@lothar.com",
|
||||
--
|
||||
2.38.1
|
||||
|
15
package/python-magic-wormhole-mailbox-server/Config.in
Normal file
15
package/python-magic-wormhole-mailbox-server/Config.in
Normal file
@ -0,0 +1,15 @@
|
||||
config BR2_PACKAGE_PYTHON_MAGIC_WORMHOLE_MAILBOX_SERVER
|
||||
bool "python-magic-wormhole-mailbox-server"
|
||||
select BR2_PACKAGE_PYTHON3_SQLITE # runtime
|
||||
select BR2_PACKAGE_PYTHON_ATTRS # runtime
|
||||
select BR2_PACKAGE_PYTHON_AUTOBAHN # runtime
|
||||
select BR2_PACKAGE_PYTHON_SIX # runtime
|
||||
select BR2_PACKAGE_PYTHON_TWISTED # runtime
|
||||
help
|
||||
This package is the main server that Magic-Wormhole clients
|
||||
connect to. The server performs store-and-forward delivery
|
||||
for small key-exchange and control messages. Bulk data is
|
||||
sent over a direct TCP connection, or through a
|
||||
transit-relay.
|
||||
|
||||
https://github.com/magic-wormhole/magic-wormhole-mailbox-server
|
@ -0,0 +1,5 @@
|
||||
# md5, sha256 from https://pypi.org/pypi/magic-wormhole-mailbox-server/json
|
||||
md5 3da441df1f354a8399a728da3421ac8f magic-wormhole-mailbox-server-0.4.1.tar.gz
|
||||
sha256 1af10592909caaf519c00e706eac842c5e77f8d4356215fe9c61c7b2258a88fb magic-wormhole-mailbox-server-0.4.1.tar.gz
|
||||
# Locally computed sha256 checksums
|
||||
sha256 4a9cc2415c52cef591b6822eee68fed36d7e6d80284b09638cff61d762d99060 LICENSE
|
@ -0,0 +1,14 @@
|
||||
################################################################################
|
||||
#
|
||||
# python-magic-wormhole-mailbox-server
|
||||
#
|
||||
################################################################################
|
||||
|
||||
PYTHON_MAGIC_WORMHOLE_MAILBOX_SERVER_VERSION = 0.4.1
|
||||
PYTHON_MAGIC_WORMHOLE_MAILBOX_SERVER_SOURCE = magic-wormhole-mailbox-server-$(PYTHON_MAGIC_WORMHOLE_MAILBOX_SERVER_VERSION).tar.gz
|
||||
PYTHON_MAGIC_WORMHOLE_MAILBOX_SERVER_SITE = https://files.pythonhosted.org/packages/5b/ba/cbb211bc8f8bfdf7fb620d33331f07bcd889c7a28e7fd8a0de9029bb5a2f
|
||||
PYTHON_MAGIC_WORMHOLE_MAILBOX_SERVER_SETUP_TYPE = setuptools
|
||||
PYTHON_MAGIC_WORMHOLE_MAILBOX_SERVER_LICENSE = MIT
|
||||
PYTHON_MAGIC_WORMHOLE_MAILBOX_SERVER_LICENSE_FILES = LICENSE
|
||||
|
||||
$(eval $(python-package))
|
Loading…
Reference in New Issue
Block a user