package/gli: bump to latest commit

- Drop patch (already in version)
- Update hash of manual.md (update in year:
  53106f0b8a)

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
This commit is contained in:
Fabrice Fontaine 2024-01-02 15:05:26 +01:00 committed by Thomas Petazzoni
parent 01ad113431
commit 92040c4bf7
4 changed files with 3 additions and 49 deletions

View File

@ -491,7 +491,6 @@ package/gerbera/S99gerbera Indent
package/giblib/0001-fix-imlib2-detection.patch Upstream
package/giflib/0001-Makefile-add-targets-to-manage-static-building.patch Upstream
package/git-crypt/0001-fix-build-with-libressl-3.5.0.patch Upstream
package/gli/0001-Optional-building-tests.patch Upstream
package/glog/0001-added-emscripten-support.patch Upstream
package/glorytun/0001-Add-support-for-Apple-silicon.patch Upstream
package/glorytun/0002-aegis256.c-fix-aarch64-build-with-uclibc.patch Upstream

View File

@ -1,45 +0,0 @@
From 629fc81ce73114a5925484937df796467adbe8c7 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Jo=C3=A3o=20Pereira?= <pereira.john94@gmail.com>
Date: Fri, 22 Mar 2019 22:58:17 +0000
Subject: [PATCH] Optional building tests
[Retrieved from:
https://github.com/g-truc/gli/commit/629fc81ce73114a5925484937df796467adbe8c7]
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
CMakeLists.txt | 1 +
test/CMakeLists.txt | 8 +++++---
2 files changed, 6 insertions(+), 3 deletions(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6eb1a68b..bcff7ef0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -13,6 +13,7 @@ include(GNUInstallDirs)
include(CMakePackageConfigHelpers)
enable_testing()
+option(GLI_TEST_ENABLE "Build unit tests" ON)
add_definitions(-D_CRT_SECURE_NO_WARNINGS)
add_definitions(-DSOURCE_DIR="${CMAKE_CURRENT_SOURCE_DIR}")
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 6b1d4826..e51a3181 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -19,10 +19,12 @@ function(glmCreateTestGTC NAME)
set(SAMPLE_NAME test-${NAME})
add_executable(${SAMPLE_NAME} ${NAME}.cpp)
target_link_libraries(${SAMPLE_NAME} gli)
- add_test(
+ add_test(
NAME ${SAMPLE_NAME}
COMMAND $<TARGET_FILE:${SAMPLE_NAME}> )
endfunction()
-add_subdirectory(bug)
-add_subdirectory(core)
+if(GLI_TEST_ENABLE)
+ add_subdirectory(bug)
+ add_subdirectory(core)
+endif()

View File

@ -1,3 +1,3 @@
# Locally calculated
sha256 9374f3cf6441dac0154f7e5ae9ad9ae99f4c4a36f8eb6de23f54a1996b9f2769 gli-559cbe1ec38878e182507d331e0780fbae5baf15.tar.gz
sha256 e26459f62353e631d18379668c82b85f9fd2fd993f2818277e4fce21e957f87a manual.md
sha256 2f4f67ac4d1673216f03ff37e406bb403689b39a2df3d2efad501448705bbb3f gli-779b99ac6656e4d30c3b24e96e0136a59649a869.tar.gz
sha256 474c5f04064507cf5ac991fc3d4b990e5e34b15705d38d2062f8844c102113cf manual.md

View File

@ -4,7 +4,7 @@
#
################################################################################
GLI_VERSION = 559cbe1ec38878e182507d331e0780fbae5baf15
GLI_VERSION = 779b99ac6656e4d30c3b24e96e0136a59649a869
GLI_SITE = $(call github,g-truc,gli,$(GLI_VERSION))
GLI_LICENSE = MIT
GLI_LICENSE_FILES = manual.md