dtc: don't treat warnings as errors
Fixes: http://autobuild.buildroot.net/results/c1e/c1e0764f27e6c842a2a324b7b2dc5052ff10f13b/ Signed-off-by: Baruch Siach <baruch@tkos.co.il> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
This commit is contained in:
parent
0a0947ce96
commit
913cf72c80
@ -13,12 +13,16 @@ Patch not sent upstream.
|
||||
Although not specific to buildroot, I am not sure this is the best
|
||||
way to handle user-supplied CFLAGS.
|
||||
|
||||
diff -durN dtc-e4b497f367a3b2ae99cc52089a14a221b13a76ef.orig/Makefile dtc-e4b497f367a3b2ae99cc52089a14a221b13a76ef/Makefile
|
||||
--- dtc-e4b497f367a3b2ae99cc52089a14a221b13a76ef.orig/Makefile 2012-10-22 22:02:47.541240846 +0200
|
||||
+++ dtc-e4b497f367a3b2ae99cc52089a14a221b13a76ef/Makefile 2012-10-22 22:03:21.151047833 +0200
|
||||
@@ -18,7 +18,8 @@
|
||||
diff --git a/Makefile b/Makefile
|
||||
index 962f94eba661..bf6b317158cf 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -16,9 +16,10 @@ LOCAL_VERSION =
|
||||
CONFIG_LOCALVERSION =
|
||||
|
||||
CPPFLAGS = -I libfdt -I .
|
||||
WARNINGS = -Werror -Wall -Wpointer-arith -Wcast-qual -Wnested-externs \
|
||||
-WARNINGS = -Werror -Wall -Wpointer-arith -Wcast-qual -Wnested-externs \
|
||||
+WARNINGS = -Wall -Wpointer-arith -Wcast-qual -Wnested-externs \
|
||||
-Wstrict-prototypes -Wmissing-prototypes -Wredundant-decls
|
||||
-CFLAGS = -g -Os -fPIC -Werror $(WARNINGS)
|
||||
+CFLAGS ?= -g -Os
|
||||
|
Loading…
Reference in New Issue
Block a user