Revert "package/fakeroot: remove"
This reverts commit 325cff36f7
.
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
This commit is contained in:
parent
4c6d5e33ae
commit
907ea41c52
34
package/fakeroot/0001-hide-dlsym-error.patch
Normal file
34
package/fakeroot/0001-hide-dlsym-error.patch
Normal file
@ -0,0 +1,34 @@
|
||||
Description: Hide error from dlsym()
|
||||
dlsym(), starting in glibc 2.24 actually reports errors. In our case,
|
||||
we try to get ACL functions which are not in the glibc. This causes
|
||||
failures in test suites, so hide those messages for non-debugging
|
||||
purposes for now. It also makes the build logs annoying to read.
|
||||
Author: Julian Andres Klode <juliank@ubuntu.com>
|
||||
Origin: vendor
|
||||
Bug-Debian: https://bugs.debian.org/830912
|
||||
Forwarded: no
|
||||
Last-Update: 2016-08-12
|
||||
|
||||
Signed-off-by: Maxime Hadjinlian <maxime.hadjinlian@gmail.com>
|
||||
|
||||
--- a/libfakeroot.c
|
||||
+++ b/libfakeroot.c
|
||||
@@ -256,10 +256,16 @@ void load_library_symbols(void){
|
||||
/* clear dlerror() just in case dlsym() legitimately returns NULL */
|
||||
msg = dlerror();
|
||||
*(next_wrap[i].doit)=dlsym(get_libc(), next_wrap[i].name);
|
||||
+
|
||||
if ( (msg = dlerror()) != NULL){
|
||||
- fprintf (stderr, "dlsym(%s): %s\n", next_wrap[i].name, msg);
|
||||
-/* abort ();*/
|
||||
+#ifdef LIBFAKEROOT_DEBUGGING
|
||||
+ if (fakeroot_debug) {
|
||||
+ fprintf (stderr, "dlsym(%s): %s\n", next_wrap[i].name, msg);
|
||||
+/* abort ();*/
|
||||
+ }
|
||||
+#endif
|
||||
}
|
||||
+
|
||||
}
|
||||
}
|
||||
|
4
package/fakeroot/fakeroot.hash
Normal file
4
package/fakeroot/fakeroot.hash
Normal file
@ -0,0 +1,4 @@
|
||||
# From http://snapshot.debian.org/package/fakeroot/1.20.2-1/
|
||||
sha1 367040df07043edb630942b21939e493f3fad888 fakeroot_1.20.2.orig.tar.bz2
|
||||
# Calculated based on the hash above
|
||||
sha256 7c0a164d19db3efa9e802e0fc7cdfeff70ec6d26cdbdc4338c9c2823c5ea230c fakeroot_1.20.2.orig.tar.bz2
|
20
package/fakeroot/fakeroot.mk
Normal file
20
package/fakeroot/fakeroot.mk
Normal file
@ -0,0 +1,20 @@
|
||||
################################################################################
|
||||
#
|
||||
# fakeroot
|
||||
#
|
||||
################################################################################
|
||||
|
||||
FAKEROOT_VERSION = 1.20.2
|
||||
FAKEROOT_SOURCE = fakeroot_$(FAKEROOT_VERSION).orig.tar.bz2
|
||||
FAKEROOT_SITE = http://snapshot.debian.org/archive/debian/20141005T221953Z/pool/main/f/fakeroot
|
||||
# Force capabilities detection off
|
||||
# For now these are process capabilities (faked) rather than file
|
||||
# so they're of no real use
|
||||
HOST_FAKEROOT_CONF_ENV = \
|
||||
ac_cv_header_sys_capability_h=no \
|
||||
ac_cv_func_capset=no
|
||||
|
||||
FAKEROOT_LICENSE = GPLv3+
|
||||
FAKEROOT_LICENSE_FILES = COPYING
|
||||
|
||||
$(eval $(host-autotools-package))
|
Loading…
Reference in New Issue
Block a user