Update to latest and modify patch so it builds.

This commit is contained in:
Manuel Novoa III 2004-04-01 04:23:18 +00:00
parent f0ebe8ab21
commit 8f6ec3d521
2 changed files with 22 additions and 6 deletions

View File

@ -5,9 +5,9 @@
#############################################################
NETSNMP_URL:=http://aleron.dl.sourceforge.net/sourceforge/net-snmp/
NETSNMP_DIR:=$(BUILD_DIR)/net-snmp-5.0.7
NETSNMP_SOURCE:=net-snmp-5.0.7.tar.gz
NETSNMP_PATCH1:=net-snmp_5.0.7-1.1.diff.gz
NETSNMP_DIR:=$(BUILD_DIR)/net-snmp-5.1
NETSNMP_SOURCE:=net-snmp-5.1.tar.gz
NETSNMP_PATCH1:=net-snmp_5.1-5.diff.gz
NETSNMP_PATCH1_URL:=http://ftp.debian.org/debian/pool/main/n/net-snmp/
NETSNMP_PATCH2:=$(SOURCE_DIR)/netsnmp.patch

View File

@ -1,6 +1,22 @@
--- net-snmp-5.0.7/configure.in.orig 2003-06-09 14:54:18.000000000 -0600
+++ net-snmp-5.0.7/configure.in 2003-06-09 14:54:42.000000000 -0600
@@ -1710,13 +1710,8 @@
diff -urN net-snmp-5.1-dist/agent/mibgroup/host/hr_system.c net-snmp-5.1/agent/mibgroup/host/hr_system.c
--- net-snmp-5.1-dist/agent/mibgroup/host/hr_system.c 2003-02-28 22:35:13.000000000 -0600
+++ net-snmp-5.1/agent/mibgroup/host/hr_system.c 2004-03-31 22:06:05.000000000 -0600
@@ -286,7 +286,11 @@
current user */
if (kill(utmp_p->ut_pid, 0) == -1 && errno == ESRCH) {
utmp_p->ut_type = DEAD_PROCESS;
+#if HAVE_UTMPX_H
pututxline(utmp_p);
+#else
+ pututline(utmp_p);
+#endif
continue;
}
++total;
diff -urN net-snmp-5.1-dist/configure.in net-snmp-5.1/configure.in
--- net-snmp-5.1-dist/configure.in 2004-03-31 21:59:14.000000000 -0600
+++ net-snmp-5.1/configure.in 2004-03-31 22:06:05.000000000 -0600
@@ -1865,13 +1865,8 @@
if test $cross_compiling = yes; then
if test $with_endianness = "big"; then
AC_DEFINE(WORDS_BIGENDIAN)