package/monit: update to 5.33.0

This commit updates monit to the latest 5.33.0 version which also
requires an additional patch to configure.ac as well as enabled ipv6
support.

Signed-off-by: Jens Maus <mail@jens-maus.de>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
This commit is contained in:
Jens Maus 2023-09-22 21:47:54 +02:00 committed by Peter Korsgaard
parent c076f3f1a6
commit 8cedb39764
3 changed files with 52 additions and 6 deletions

View File

@ -0,0 +1,44 @@
From 2c06ecdc02de75a9e7e1e30e9c3d7d3a64269b7c Mon Sep 17 00:00:00 2001
From: Jens Maus <mail@jens-maus.de>
Date: Fri, 22 Sep 2023 21:32:18 +0200
Subject: [PATCH] configure.ac: fixes missing config macro dir
This adds the config dir to the AC_CONFIG_MACRO_DIRS in configure.ac
so that m4 macros are properly loaded upon autoreconf use.
Upstream: N/A (specific to buildroot)
Signed-off-by: Jens Maus <mail@jens-maus.de>
---
configure.ac | 2 +-
libmonit/configure.ac | 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/configure.ac b/configure.ac
index 3c3d30a2..f4c5ea07 100644
--- a/configure.ac
+++ b/configure.ac
@@ -8,7 +8,7 @@ AC_PREREQ([2.53])
# Example: 5.0_beta2
AC_INIT([monit], [5.34.0], [monit-general@nongnu.org])
AC_CONFIG_AUX_DIR(config)
-AC_CONFIG_MACRO_DIR([m4])
+AC_CONFIG_MACRO_DIRS([m4 config])
AM_INIT_AUTOMAKE
AC_CONFIG_SRCDIR([src/monit.c])
AC_CONFIG_SUBDIRS([libmonit])
diff --git a/libmonit/configure.ac b/libmonit/configure.ac
index d4cd0789..5366444a 100644
--- a/libmonit/configure.ac
+++ b/libmonit/configure.ac
@@ -4,7 +4,7 @@ AC_PREREQ([2.53])
AC_INIT([libmonit], [1.0], [monit-dev@tildeslash.com])
AC_CONFIG_AUX_DIR(config)
-AC_CONFIG_MACRO_DIR([m4])
+AC_CONFIG_MACRO_DIRS([m4 config])
AM_INIT_AUTOMAKE
AC_CONFIG_SRCDIR([src])
--
2.34.1

View File

@ -1,4 +1,4 @@
# From https://mmonit.com/monit/dist/monit-5.26.0.tar.gz.sha256:
sha256 87fc4568a3af9a2be89040efb169e3a2e47b262f99e78d5ddde99dd89f02f3c2 monit-5.26.0.tar.gz
# From https://mmonit.com/monit/dist/monit-5.33.0.tar.gz.sha256
sha256 1ace889c0183473a9d70160df6533bb6e1338dc1354f5928507803e1e2a863b5 monit-5.33.0.tar.gz
# Locally computed
sha256 d5a4f52b1a5e1e7fe14e01a76aac8b08dc6bbea15466058f271456c97aac1ada COPYING

View File

@ -4,26 +4,28 @@
#
################################################################################
MONIT_VERSION = 5.26.0
MONIT_VERSION = 5.33.0
MONIT_SITE = http://mmonit.com/monit/dist
MONIT_LICENSE = AGPL-3.0 with OpenSSL exception
MONIT_LICENSE_FILES = COPYING
MONIT_CPE_ID_VENDOR = mmonit
MONIT_SELINUX_MODULES = monit
#
# Touching Makefile.am:
# 0001-configure.ac-fixes-missing-config-macro-dir.patch touches configure.ac
MONIT_AUTORECONF = YES
MONIT_CONF_ENV = \
libmonit_cv_setjmp_available=yes \
libmonit_cv_vsnprintf_c99_conformant=yes
libmonit_cv_vsnprintf_c99_conformant=yes \
ac_cv_ipv6=yes
MONIT_CONF_OPTS += \
--without-pam \
--with-largefiles
ifeq ($(BR2_PACKAGE_OPENSSL),y)
MONIT_CONF_OPTS += --with-ssl=$(STAGING_DIR)/usr
MONIT_CONF_OPTS += --with-ssl --with-ssl-dir=$(STAGING_DIR)/usr
MONIT_DEPENDENCIES += openssl
else
MONIT_CONF_OPTS += --without-ssl