dropbear: bump to version 2011.54
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
This commit is contained in:
parent
a1dd178f3a
commit
8b56bfe838
@ -1,26 +0,0 @@
|
||||
dropbear: fix static build
|
||||
|
||||
the -lcrypt is missing during the link
|
||||
|
||||
svr-authpasswd.o: In function `svr_auth_password':
|
||||
svr-authpasswd.c:(.text+0xfc): undefined reference to `crypt'
|
||||
collect2: ld returned 1 exit status
|
||||
|
||||
Signed-off-by: Jean-Christophe PLAGNIOL-VILLARD <plagnioj@jcrosoft.com>
|
||||
---
|
||||
Makefile.in | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
Index: b/Makefile.in
|
||||
===================================================================
|
||||
--- a/Makefile.in
|
||||
+++ b/Makefile.in
|
||||
@@ -77,7 +77,7 @@ STRIP=@STRIP@
|
||||
INSTALL=@INSTALL@
|
||||
CPPFLAGS=@CPPFLAGS@
|
||||
CFLAGS+=-I. -I$(srcdir) $(CPPFLAGS) @CFLAGS@
|
||||
-LIBS+=@LIBS@
|
||||
+LIBS+=@CRYPTLIB@ @LIBS@
|
||||
LDFLAGS=@LDFLAGS@
|
||||
|
||||
EXEEXT=@EXEEXT@
|
18
package/dropbear/dropbear-2011.54-no-ipv6.patch
Normal file
18
package/dropbear/dropbear-2011.54-no-ipv6.patch
Normal file
@ -0,0 +1,18 @@
|
||||
Check for IPV6_TCLASS instead of IPPROTO_IPV6 since
|
||||
it's present on non-IPv6 enabled toolchains too.
|
||||
|
||||
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
|
||||
---
|
||||
|
||||
diff -Nura dropbear-2011.54.orig/dbutil.c dropbear-2011.54/dbutil.c
|
||||
--- dropbear-2011.54.orig/dbutil.c 2011-11-08 09:48:15.000000000 -0300
|
||||
+++ dropbear-2011.54/dbutil.c 2011-11-09 12:14:59.430074138 -0300
|
||||
@@ -164,7 +164,7 @@
|
||||
/* set the TOS bit for either ipv4 or ipv6 */
|
||||
#ifdef IPTOS_LOWDELAY
|
||||
val = IPTOS_LOWDELAY;
|
||||
-#ifdef IPPROTO_IPV6
|
||||
+#ifdef IPV6_TCLASS
|
||||
setsockopt(sock, IPPROTO_IPV6, IPV6_TCLASS, (void*)&val, sizeof(val));
|
||||
#endif
|
||||
setsockopt(sock, IPPROTO_IP, IP_TOS, (void*)&val, sizeof(val));
|
@ -4,8 +4,7 @@
|
||||
#
|
||||
#############################################################
|
||||
|
||||
DROPBEAR_VERSION = 0.53.1
|
||||
DROPBEAR_SOURCE = dropbear-$(DROPBEAR_VERSION).tar.gz
|
||||
DROPBEAR_VERSION = 2011.54
|
||||
DROPBEAR_SITE = http://matt.ucc.asn.au/dropbear/releases
|
||||
DROPBEAR_TARGET_BINS = dbclient dropbearkey dropbearconvert scp ssh
|
||||
DROPBEAR_MAKE = $(MAKE) MULTI=1 SCPPROGRESS=1 \
|
||||
|
Loading…
Reference in New Issue
Block a user