dtc: bump version to 1.4.1
Patch 0001-separate-lib-install.patch is no longer needed, original Makefile already contains separate install-lib target (but build always complete default target). Remove superfluous CFLAGS setting. Adjust 0002-extra-cflags.patch. Signed-off-by: Peter Seiderer <ps.report@gmx.net> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
This commit is contained in:
parent
304755acf5
commit
8b500c1b63
@ -1,28 +0,0 @@
|
|||||||
Makefile: add a rule to only install libfdt
|
|
||||||
|
|
||||||
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
|
|
||||||
|
|
||||||
---
|
|
||||||
Patch not sent upstream.
|
|
||||||
|
|
||||||
It's really specific to buildroot, and is probably not
|
|
||||||
good (aka generic) enough to be pushed upstream.
|
|
||||||
|
|
||||||
diff --git a/Makefile b/Makefile
|
|
||||||
index 1169e6c..39e7190 100644
|
|
||||||
--- a/Makefile
|
|
||||||
+++ b/Makefile
|
|
||||||
@@ -160,10 +160,12 @@ endif
|
|
||||||
# intermediate target and building them again "for real"
|
|
||||||
.SECONDARY: $(DTC_GEN_SRCS) $(CONVERT_GEN_SRCS)
|
|
||||||
|
|
||||||
-install: all $(SCRIPTS)
|
|
||||||
+install: all $(SCRIPTS) libfdt_install
|
|
||||||
@$(VECHO) INSTALL
|
|
||||||
$(INSTALL) -d $(DESTDIR)$(BINDIR)
|
|
||||||
$(INSTALL) $(BIN) $(SCRIPTS) $(DESTDIR)$(BINDIR)
|
|
||||||
+
|
|
||||||
+libfdt_install: libfdt
|
|
||||||
$(INSTALL) -d $(DESTDIR)$(LIBDIR)
|
|
||||||
$(INSTALL) $(LIBFDT_lib) $(DESTDIR)$(LIBDIR)
|
|
||||||
ln -sf $(notdir $(LIBFDT_lib)) $(DESTDIR)$(LIBDIR)/$(LIBFDT_soname)
|
|
@ -23,7 +23,7 @@ index 962f94eba661..bf6b317158cf 100644
|
|||||||
CPPFLAGS = -I libfdt -I .
|
CPPFLAGS = -I libfdt -I .
|
||||||
-WARNINGS = -Werror -Wall -Wpointer-arith -Wcast-qual -Wnested-externs \
|
-WARNINGS = -Werror -Wall -Wpointer-arith -Wcast-qual -Wnested-externs \
|
||||||
+WARNINGS = -Wall -Wpointer-arith -Wcast-qual -Wnested-externs \
|
+WARNINGS = -Wall -Wpointer-arith -Wcast-qual -Wnested-externs \
|
||||||
-Wstrict-prototypes -Wmissing-prototypes -Wredundant-decls
|
-Wstrict-prototypes -Wmissing-prototypes -Wredundant-decls -Wshadow
|
||||||
-CFLAGS = -g -Os -fPIC -Werror $(WARNINGS)
|
-CFLAGS = -g -Os -fPIC -Werror $(WARNINGS)
|
||||||
+CFLAGS ?= -g -Os
|
+CFLAGS ?= -g -Os
|
||||||
+CFLAGS += -fPIC $(WARNINGS)
|
+CFLAGS += -fPIC $(WARNINGS)
|
||||||
|
@ -4,7 +4,7 @@
|
|||||||
#
|
#
|
||||||
################################################################################
|
################################################################################
|
||||||
|
|
||||||
DTC_VERSION = 1.4.0
|
DTC_VERSION = 1.4.1
|
||||||
DTC_SOURCE = dtc-$(DTC_VERSION).tar.xz
|
DTC_SOURCE = dtc-$(DTC_VERSION).tar.xz
|
||||||
DTC_SITE = https://www.kernel.org/pub/software/utils/dtc
|
DTC_SITE = https://www.kernel.org/pub/software/utils/dtc
|
||||||
DTC_LICENSE = GPLv2+/BSD-2c
|
DTC_LICENSE = GPLv2+/BSD-2c
|
||||||
@ -19,8 +19,6 @@ endef
|
|||||||
ifeq ($(BR2_PACKAGE_DTC_PROGRAMS),y)
|
ifeq ($(BR2_PACKAGE_DTC_PROGRAMS),y)
|
||||||
|
|
||||||
DTC_LICENSE += (for the library), GPLv2+ (for the executables)
|
DTC_LICENSE += (for the library), GPLv2+ (for the executables)
|
||||||
# Use default goal to build everything
|
|
||||||
DTC_BUILD_GOAL =
|
|
||||||
DTC_INSTALL_GOAL = install
|
DTC_INSTALL_GOAL = install
|
||||||
ifeq ($(BR2_PACKAGE_BASH),)
|
ifeq ($(BR2_PACKAGE_BASH),)
|
||||||
DTC_POST_INSTALL_TARGET_HOOKS += DTC_POST_INSTALL_TARGET_RM_DTDIFF
|
DTC_POST_INSTALL_TARGET_HOOKS += DTC_POST_INSTALL_TARGET_RM_DTDIFF
|
||||||
@ -28,21 +26,17 @@ endif
|
|||||||
|
|
||||||
else # $(BR2_PACKAGE_DTC_PROGRAMS) != y
|
else # $(BR2_PACKAGE_DTC_PROGRAMS) != y
|
||||||
|
|
||||||
DTC_BUILD_GOAL = libfdt
|
DTC_INSTALL_GOAL = install-lib
|
||||||
# libfdt_install is our own install rule added by our patch
|
|
||||||
DTC_INSTALL_GOAL = libfdt_install
|
|
||||||
|
|
||||||
endif # $(BR2_PACKAGE_DTC_PROGRAMS) != y
|
endif # $(BR2_PACKAGE_DTC_PROGRAMS) != y
|
||||||
|
|
||||||
define DTC_BUILD_CMDS
|
define DTC_BUILD_CMDS
|
||||||
$(TARGET_CONFIGURE_OPTS) \
|
$(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D) PREFIX=/usr
|
||||||
CFLAGS="$(TARGET_CFLAGS)" \
|
|
||||||
$(MAKE) -C $(@D) PREFIX=/usr $(DTC_BUILD_GOAL)
|
|
||||||
endef
|
endef
|
||||||
|
|
||||||
# For staging, only the library is needed
|
# For staging, only the library is needed
|
||||||
define DTC_INSTALL_STAGING_CMDS
|
define DTC_INSTALL_STAGING_CMDS
|
||||||
$(MAKE) -C $(@D) DESTDIR=$(STAGING_DIR) PREFIX=/usr libfdt_install
|
$(MAKE) -C $(@D) DESTDIR=$(STAGING_DIR) PREFIX=/usr install-lib
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define DTC_INSTALL_TARGET_CMDS
|
define DTC_INSTALL_TARGET_CMDS
|
||||||
|
Loading…
Reference in New Issue
Block a user