package/janus-gateway: bump to version 1.0.3

- Rebased second patch
- Drop third and fourth patches (already in version)
- duktape is an optional dependency since version 1.0.0 and
  fab4215b78
- gengetopt is not a dependency since version 1.0.1 and
  c21500c02e

https://github.com/meetecho/janus-gateway/blob/v1.0.1/CHANGELOG.md

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
This commit is contained in:
Fabrice Fontaine 2022-07-26 19:32:35 +02:00 committed by Thomas Petazzoni
parent 7dba02bf62
commit 89c5bfe3e4
6 changed files with 23 additions and 59 deletions

View File

@ -18,6 +18,8 @@ Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
(rebased against v0.6.3)
Signed-off-by: Adam Duskett <Aduskett@gmail.com>
[rebased against v1.0.3)
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
[Upstream status: rejected
(https://github.com/meetecho/janus-gateway/pull/1789)]
---
@ -27,10 +29,10 @@ Signed-off-by: Adam Duskett <Aduskett@gmail.com>
3 files changed, 79 insertions(+), 2 deletions(-)
create mode 100644 m4/ax_check_compile_flag.m4
diff --git a/Makefile.am b/Makefile.am
diff --git a/src/Makefile.am b/src/Makefile.am
index f961fdb..3ddbe59 100644
--- a/Makefile.am
+++ b/Makefile.am
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -151,6 +151,7 @@ janus_CFLAGS = \
-DEVENTDIR=\"$(eventdir)\" \
-DLOGGERDIR=\"$(loggerdir)\" \

View File

@ -1,25 +0,0 @@
From f62bba6513ec840761f2434b93168106c7c65a3d Mon Sep 17 00:00:00 2001
From: Lorenzo Miniero <lminiero@gmail.com>
Date: Wed, 15 Dec 2021 14:10:01 +0100
Subject: [PATCH] Fixed missing XSS mitigation (see #2817)
[Retrieved from:
https://github.com/meetecho/janus-gateway/commit/f62bba6513ec840761f2434b93168106c7c65a3d]
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
html/textroomtest.js | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/html/textroomtest.js b/html/textroomtest.js
index bf95a260a..7d5ae832c 100644
--- a/html/textroomtest.js
+++ b/html/textroomtest.js
@@ -351,7 +351,7 @@ function sendPrivateMsg(username) {
text: JSON.stringify(message),
error: function(reason) { bootbox.alert(reason); },
success: function() {
- $('#chatroom').append('<p style="color: purple;">[' + getDateString() + '] <b>[whisper to ' + display + ']</b> ' + result);
+ $('#chatroom').append('<p style="color: purple;">[' + getDateString() + '] <b>[whisper to ' + display + ']</b> ' + escapeXmlTags(result));
$('#chatroom').get(0).scrollTop = $('#chatroom').get(0).scrollHeight;
}
});

View File

@ -1,25 +0,0 @@
From 8e450a097f5f0c7e9c034e954fbc709797521f1c Mon Sep 17 00:00:00 2001
From: Lorenzo Miniero <lminiero@gmail.com>
Date: Fri, 13 May 2022 18:42:38 +0200
Subject: [PATCH] Fix build with libressl >= 3.5.0 (see #2980)
[Retrieved from:
https://github.com/meetecho/janus-gateway/commit/8e450a097f5f0c7e9c034e954fbc709797521f1c]
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
dtls-bio.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/dtls-bio.h b/dtls-bio.h
index 92f06d7c0a..fbfd4c37bf 100644
--- a/dtls-bio.h
+++ b/dtls-bio.h
@@ -35,7 +35,7 @@ void janus_dtls_bio_agent_set_mtu(int start_mtu);
int janus_dtls_bio_agent_get_mtu(void);
#if defined(LIBRESSL_VERSION_NUMBER)
-#define JANUS_USE_OPENSSL_PRE_1_1_API (1)
+#define JANUS_USE_OPENSSL_PRE_1_1_API (LIBRESSL_VERSION_NUMBER < 0x30500000L)
#else
#define JANUS_USE_OPENSSL_PRE_1_1_API (OPENSSL_VERSION_NUMBER < 0x10100000L)
#endif

View File

@ -30,6 +30,14 @@ config BR2_PACKAGE_JANUS_GATEWAY_AUDIO_BRIDGE
bool "audio bridge"
select BR2_PACKAGE_OPUS
config BR2_PACKAGE_JANUS_GATEWAY_DUKTAPE
bool "duktape"
depends on !BR2_OPTIMIZE_FAST # duktape
select BR2_PACKAGE_DUKTAPE
comment "duktape plugin can't be built with optimize for fast"
depends on BR2_OPTIMIZE_FAST
config BR2_PACKAGE_JANUS_GATEWAY_ECHO_TEST
bool "echo test"

View File

@ -1,3 +1,3 @@
# Locally computed
sha256 b5fe70d95b9288200df15d5f75cb8eb6db66484c6ded159422a81e880ecb7104 janus-gateway-0.11.6.tar.gz
sha256 5b8a7304761783585bfa8db7471bf8c393fa2a0ffc346747afadc0c1a9d213f5 janus-gateway-1.0.3.tar.gz
sha256 91d04c97fa1da3fcd28205873276358aafc071c5b00a9ea8c49dd06d487a9dc6 COPYING

View File

@ -4,19 +4,16 @@
#
################################################################################
JANUS_GATEWAY_VERSION = 0.11.6
JANUS_GATEWAY_VERSION = 1.0.3
JANUS_GATEWAY_SITE = $(call github,meetecho,janus-gateway,v$(JANUS_GATEWAY_VERSION))
JANUS_GATEWAY_LICENSE = GPL-3.0 with OpenSSL exception
JANUS_GATEWAY_LICENSE_FILES = COPYING
JANUS_GATEWAY_CPE_ID_VENDOR = meetecho
JANUS_GATEWAY_CPE_ID_PRODUCT = janus
# 0003-Fixed-missing-XSS-mitigation.patch
JANUS_GATEWAY_IGNORE_CVES += CVE-2021-4124
# ding-libs provides the ini_config library
JANUS_GATEWAY_DEPENDENCIES = host-pkgconf jansson libnice \
libsrtp host-gengetopt libglib2 openssl libconfig \
libsrtp libglib2 openssl libconfig \
$(if $(BR2_PACKAGE_LIBOGG),libogg)
# Straight out of the repository, no ./configure, and we also patch
@ -41,6 +38,13 @@ else
JANUS_GATEWAY_CONF_OPTS += --disable-plugin-audiobridge
endif
ifeq ($(BR2_PACKAGE_JANUS_GATEWAY_DUKTAPE),y)
JANUS_GATEWAY_DEPENDENCIES += duktape
JANUS_GATEWAY_CONF_OPTS += --enable-plugin-duktape
else
JANUS_GATEWAY_CONF_OPTS += --disable-plugin-duktape
endif
ifeq ($(BR2_PACKAGE_JANUS_GATEWAY_ECHO_TEST),y)
JANUS_GATEWAY_CONF_OPTS += --enable-plugin-echotest
else