package/protozero: bump version to 1.7.1

Drop upstream patch.
Release-notes: https://github.com/mapbox/protozero/releases/tag/v1.7.1

Signed-off-by: Maxim Kochetkov <fido_max@inbox.ru>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
This commit is contained in:
Кочетков Максим 2022-01-28 07:51:40 +03:00 committed by Arnout Vandecappelle (Essensium/Mind)
parent cdbe856675
commit 89ac26c304
3 changed files with 2 additions and 49 deletions

View File

@ -1,47 +0,0 @@
From 03daae49c8fa94513b508bd12f1597e8e5e086f2 Mon Sep 17 00:00:00 2001
From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Date: Sat, 17 Apr 2021 13:06:44 +0200
Subject: [PATCH] CMakeLists.txt: respect BUILD_TESTING
Don't build tests if the standard cmake BUILD_TESTING variable is set to
OFF.
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
[Upstream status: https://github.com/mapbox/protozero/pull/105]
---
CMakeLists.txt | 9 +++++----
1 file changed, 5 insertions(+), 4 deletions(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f9702d6..7a40212 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -23,6 +23,7 @@ set(CMAKE_EXPORT_COMPILE_COMMANDS ON)
#-----------------------------------------------------------------------------
+option(BUILD_TESTING "Build tests" ON)
option(WERROR "Add -Werror flag to build (turns warnings into errors)" ON)
if(MSVC)
@@ -134,13 +135,13 @@ install(DIRECTORY include/protozero DESTINATION include)
#-----------------------------------------------------------------------------
-enable_testing()
-
add_subdirectory(doc)
add_subdirectory(tools)
-add_subdirectory(test)
-
+if(BUILD_TESTING)
+ enable_testing()
+ add_subdirectory(test)
+endif()
#-----------------------------------------------------------------------------
--
2.30.2

View File

@ -1,4 +1,4 @@
# Locally calculated
sha256 beffbdfab060854fd770178a8db9c028b5b6ee4a059a2fed82c46390a85f3f31 protozero-1.7.0.tar.gz
sha256 27e0017d5b3ba06d646a3ec6391d5ccc8500db821be480aefd2e4ddc3de5ff99 protozero-1.7.1.tar.gz
sha256 1f4d477e3c2d74d8706c8f05437bd86804abe46853b1f233ce1549a4de76fa49 LICENSE.md
sha256 0d542e0c8804e39aa7f37eb00da5a762149dc682d7829451287e11b938e94594 LICENSE.from_folly

View File

@ -4,7 +4,7 @@
#
################################################################################
PROTOZERO_VERSION = 1.7.0
PROTOZERO_VERSION = 1.7.1
PROTOZERO_SITE = $(call github,mapbox,protozero,v$(PROTOZERO_VERSION))
PROTOZERO_LICENSE = BSD-2-Clause, Apache-2.0
PROTOZERO_LICENSE_FILES = LICENSE.md LICENSE.from_folly