package/libwebsockets: bump to version 4.3.2

Drop first and second patches (already in version)

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
This commit is contained in:
Fabrice Fontaine 2022-07-17 09:50:33 +02:00 committed by Yann E. MORIN
parent 0f50b83316
commit 891bba3ce2
5 changed files with 2 additions and 72 deletions

View File

@ -1,44 +0,0 @@
From 726b36eca158063d8871c91ad99a29113ea35aea Mon Sep 17 00:00:00 2001
From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Date: Wed, 13 Apr 2022 21:03:26 +0200
Subject: [PATCH] CMakeLists.txt: fix build without C++
Fix the following build failure without C++ raised since version 4.2.0
and
https://github.com/warmcat/libwebsockets/commit/962e9ee345bc28749577c1fca2542a273404627d:
CMake Error at /nvmedata/autobuild/instance-11/output-1/per-package/libwebsockets/host/share/cmake-3.18/Modules/CMakeTestCXXCompiler.cmake:59 (message):
The C++ compiler
"/usr/bin/clang++"
is not able to compile a simple test program.
Fixes:
- http://autobuild.buildroot.org/results/550e7f7d54adf74f8cc078be5b91b3567d622ede
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
[Upstream status: https://github.com/warmcat/libwebsockets/pull/2613]
---
CMakeLists.txt | 5 ++++-
1 file changed, 4 insertions(+), 1 deletion(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 08aaf8c6..96e3ad18 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -71,7 +71,10 @@ if (ESP_PLATFORM)
endif()
# it's at this point any toolchain file is brought in
-project(libwebsockets C CXX)
+project(libwebsockets C)
+if (LWS_WITH_SECURE_STREAMS_CPP)
+ enable_language(CXX)
+endif()
include(CTest)
if (PICO_SDK_PATH)
--
2.35.1

View File

@ -1,26 +0,0 @@
From 99a8b9c4422bed45c8b7412a1e121056f2a6132a Mon Sep 17 00:00:00 2001
From: Andy Green <andy@warmcat.com>
Date: Mon, 7 Feb 2022 14:48:55 +0000
Subject: [PATCH] cmake: remove duplicate LwsCheckRequirements
Signed-off-by: Andy Green <andy@warmcat.com>
Signed-off-by: Bartosz Bilas <bartosz.bilas@hotmail.com>
Signed-off-by: Bartosz Bilas <b.bilas@grinn-global.com>
---
cmake/libwebsockets-config.cmake.in | 1 -
1 file changed, 1 deletion(-)
diff --git a/cmake/libwebsockets-config.cmake.in b/cmake/libwebsockets-config.cmake.in
index 6247b2cb..8ba97e6f 100644
--- a/cmake/libwebsockets-config.cmake.in
+++ b/cmake/libwebsockets-config.cmake.in
@@ -32,6 +32,5 @@ endforeach()
include(CheckIncludeFile)
include(CheckCSourceCompiles)
-include(LwsCheckRequirements)
set(requirements 1)
--
2.35.3

View File

@ -1,3 +1,3 @@
# Locally computed:
sha256 8fdb1454a1b34cd9a6351beaab237a485e6853806101de7e62bd2bc250bb50af libwebsockets-4.3.1.tar.gz
sha256 6a85a1bccf25acc7e8e5383e4934c9b32a102880d1e4c37c70b27ae2a42406e1 libwebsockets-4.3.2.tar.gz
sha256 2b5dd8030691f3d1870a040f085c37e45d9ab9c684a7f1284f5f379c1e829b28 LICENSE

View File

@ -4,7 +4,7 @@
#
################################################################################
LIBWEBSOCKETS_VERSION = 4.3.1
LIBWEBSOCKETS_VERSION = 4.3.2
LIBWEBSOCKETS_SITE = $(call github,warmcat,libwebsockets,v$(LIBWEBSOCKETS_VERSION))
LIBWEBSOCKETS_LICENSE = MIT with exceptions
LIBWEBSOCKETS_LICENSE_FILES = LICENSE