luajit: refactor without shared-lib.patch

the variable BUILDMODE does the job

Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
This commit is contained in:
Francois Perrad 2014-03-01 18:23:03 +01:00 committed by Thomas Petazzoni
parent ca3761fbff
commit 87c28ee58a
2 changed files with 1 additions and 17 deletions

View File

@ -1,17 +0,0 @@
Compile the luajit binary dynamically against the luajit library
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Index: b/src/Makefile
===================================================================
--- a/src/Makefile
+++ b/src/Makefile
@@ -669,7 +669,7 @@
$(LUAJIT_T): $(TARGET_O) $(LUAJIT_O) $(TARGET_DEP)
$(E) "LINK $@"
- $(Q)$(TARGET_LD) $(TARGET_ALDFLAGS) -o $@ $(LUAJIT_O) $(TARGET_O) $(TARGET_ALIBS)
+ $(Q)$(TARGET_LD) $(TARGET_ALDFLAGS) -o $@ $(LUAJIT_O) -lluajit -L. $(TARGET_ALIBS)
$(Q)$(TARGET_STRIP) $@
$(E) "OK Successfully built LuaJIT"

View File

@ -44,6 +44,7 @@ define LUAJIT_BUILD_CMDS
HOST_CFLAGS="$(HOST_CFLAGS)" \
HOST_LDFLAGS="$(HOST_LDFLAGS)" \
$(LUAJIT_NO_LARGEFILE) \
BUILDMODE=dynamic \
-C $(@D) amalg
endef