package/procps-ng: fix ncurses.h include

Fixes:
http://autobuild.buildroot.net/results/7f1/7f1e0b3d99db07ea46c9cd1f51b320b461623c8d/

Signed-off-by: Bernd Kuhls <bernd@kuhls.net>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
(cherry picked from commit 3c2f3c9039deb7e285e76391fdb28258c7312f9b)
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
This commit is contained in:
Bernd Kuhls 2024-10-26 23:23:09 +02:00 committed by Peter Korsgaard
parent 1340ae1843
commit 86e007f537
2 changed files with 56 additions and 0 deletions

View File

@ -0,0 +1,55 @@
From 263fe04f9ed6f3f40fdb7ce249221e03dc926c9b Mon Sep 17 00:00:00 2001
From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Date: Wed, 24 Jul 2024 09:51:00 +0200
Subject: [PATCH] fix ncurses.h include
Commit 58559a5b64a3634460536d6397ca382a54b599f0 was not backported from
3.3.17 to 4.0.0 resulting in the following build failure when ncursesw
headers are not installed in ../usr/include/ncursesw/..:
src/watch.c:56:11: fatal error: ncursesw/ncurses.h: No such file or directory
56 | # include <ncursesw/ncurses.h>
| ^~~~~~~~~~~~~~~~~~~~
Fixes:
- http://autobuild.buildroot.org/results/b7573be2e78f3d224f48cb3f52087e3d227d58e3
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Upstream: https://gitlab.com/procps-ng/procps/-/commit/263fe04f9ed6f3f40fdb7ce249221e03dc926c9b
Signed-off-by: Bernd Kuhls <bernd@kuhls.net>
[Bernd: backported to version 4.0.4]
---
configure.ac | 2 +-
src/watch.c | 5 ++++-
2 files changed, 5 insertions(+), 2 deletions(-)
diff --git a/configure.ac b/configure.ac
index d433901f..38350aaf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -64,7 +64,7 @@ PROCPS_PROG_PO4A
# Checks for header files.
AC_HEADER_MAJOR
-AC_CHECK_HEADERS([arpa/inet.h fcntl.h float.h langinfo.h libintl.h limits.h locale.h stdint.h stdio_ext.h stdlib.h string.h sys/file.h sys/ioctl.h sys/param.h sys/time.h termios.h unistd.h utmp.h utmpx.h values.h wchar.h wctype.h])
+AC_CHECK_HEADERS([arpa/inet.h fcntl.h float.h langinfo.h libintl.h limits.h locale.h ncursesw/ncurses.h stdint.h stdio_ext.h stdlib.h string.h sys/file.h sys/ioctl.h sys/param.h sys/time.h termios.h unistd.h utmp.h utmpx.h values.h wchar.h wctype.h])
# Checks for typedefs, structures, and compiler characteristics.
AC_CHECK_HEADER_STDBOOL
diff --git a/src/watch.c b/src/watch.c
index ef638e00..7ec634b6 100644
--- a/src/watch.c
+++ b/src/watch.c
@@ -53,6 +53,8 @@
# define _XOPEN_SOURCE_EXTENDED 1
# include <wchar.h>
# include <wctype.h>
+#endif
+#ifdef HAVE_NCURSESW_NCURSES_H
# include <ncursesw/ncurses.h>
#else
# include <ncurses.h>
--
GitLab

View File

@ -15,6 +15,7 @@ PROCPS_NG_DEPENDENCIES = ncurses host-pkgconf $(TARGET_NLS_DEPENDENCIES)
PROCPS_NG_CONF_OPTS = LIBS=$(TARGET_NLS_LIBS)
# Applying 0001-build-sys-Add-systemd-elogind-to-w.patch touches Makefile.am
# Applying 0002-fix-ncurses-h-include.patch touches configure.ac
PROCPS_NG_AUTORECONF = YES
ifeq ($(BR2_PACKAGE_SYSTEMD),y)