libserial: new package

Note that the Python binding is disabled; we can't build this in Buildroot
without the sipconfig Python module for the host.

Signed-off-by: Simon Dawson <spdawson@gmail.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
This commit is contained in:
Simon Dawson 2013-04-23 04:52:39 +00:00 committed by Peter Korsgaard
parent adc231d6a1
commit 85ffab5749
5 changed files with 65 additions and 0 deletions

View File

@ -464,6 +464,7 @@ source "package/libhid/Config.in"
source "package/libiqrf/Config.in"
source "package/libnfc/Config.in"
source "package/libnfc-llcp/Config.in"
source "package/libserial/Config.in"
source "package/libusb/Config.in"
source "package/libusb-compat/Config.in"
source "package/libv4l/Config.in"

View File

@ -0,0 +1,11 @@
config BR2_PACKAGE_LIBSERIAL
bool "libserial"
depends on BR2_INSTALL_LIBSTDCPP
help
Simplified serial port programming in C++ under POSIX operating
systems.
http://libserial.sourceforge.net/
comment "libserial requires a toolchain with C++ support enabled"
depends on !BR2_INSTALL_LIBSTDCPP

View File

@ -0,0 +1,25 @@
Disable build of Python bindings, which requires the sipconfig module.
Signed-off-by: Simon Dawson <spdawson@gmail.com>
diff -Nurp a/Makefile.am b/Makefile.am
--- a/Makefile.am 2008-11-12 01:27:31.000000000 +0000
+++ b/Makefile.am 2013-04-16 09:41:13.476002178 +0100
@@ -1,4 +1,4 @@
-SUBDIRS=src doc examples sip
+SUBDIRS=src doc examples
EXTRA_DIST = doxygen.conf.in Makefile.dist libserial.spec libserial.pc
diff -Nurp a/Makefile.in b/Makefile.in
--- a/Makefile.in 2008-11-12 01:28:14.000000000 +0000
+++ b/Makefile.in 2013-04-16 09:41:05.628013626 +0100
@@ -197,7 +197,7 @@ sysconfdir = @sysconfdir@
target_alias = @target_alias@
top_builddir = @top_builddir@
top_srcdir = @top_srcdir@
-SUBDIRS = src doc examples sip
+SUBDIRS = src doc examples
EXTRA_DIST = doxygen.conf.in Makefile.dist libserial.spec libserial.pc
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = libserial.pc

View File

@ -0,0 +1,15 @@
Add a missing header include, to fix a build error.
Signed-off-by: Simon Dawson <spdawson@gmail.com>
diff -Nurp a/src/SerialPort.cpp b/src/SerialPort.cpp
--- a/src/SerialPort.cpp 2008-11-12 01:27:30.000000000 +0000
+++ b/src/SerialPort.cpp 2013-04-23 15:43:41.537495852 +0100
@@ -27,6 +27,7 @@
#include <cassert>
#include <termios.h>
#include <fcntl.h>
+#include <unistd.h>
#include <sys/ioctl.h>
#include <sys/time.h>
#include <signal.h>

View File

@ -0,0 +1,13 @@
#############################################################
#
# libserial
#
#############################################################
LIBSERIAL_VERSION = 0.6.0rc1
LIBSERIAL_SITE = http://downloads.sourceforge.net/libserial
LIBSERIAL_INSTALL_STAGING = YES
LIBSERIAL_LICENSE = GPLv2+
LIBSERIAL_LICENSE_FILES = COPYING
$(eval $(autotools-package))