libinput: fix missing static_assert
uClibc-ng does not define the C11 static_assert macro. Patch configure.ac to detect this and define a nop macro. Fixes: http://autobuild.buildroot.net/results/3eb/3eb32c19f90a5fd8d45a0c36676e015e8278a469/ http://autobuild.buildroot.net/results/184/1844890c65615f1676a85c6fac78937249eee9f1/ http://autobuild.buildroot.net/results/3a3/3a3f8c5624e8019a6eababbf6e7440fdd668f85f/ Signed-off-by: Baruch Siach <baruch@tkos.co.il> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
This commit is contained in:
parent
2a59854aa7
commit
85ef34d35a
@ -0,0 +1,34 @@
|
||||
From 0df21f54942dc82ddde4095824e7b65efb96d261 Mon Sep 17 00:00:00 2001
|
||||
From: Peter Hutterer <peter.hutterer@who-t.net>
|
||||
Date: Mon, 16 May 2016 13:32:07 +1000
|
||||
Subject: [PATCH] Add configure.ac check for static_assert
|
||||
|
||||
Part of C11, defined via assert.h.
|
||||
|
||||
Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
|
||||
Signed-off-by: Baruch Siach <baruch@tkos.co.il>
|
||||
---
|
||||
Patch status: suggested upstream
|
||||
(https://lists.freedesktop.org/archives/wayland-devel/2016-May/028881.html)
|
||||
|
||||
configure.ac | 4 ++++
|
||||
1 file changed, 4 insertions(+)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 602a86026544..28a5197cfa2e 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -55,6 +55,10 @@ AC_CHECK_DECL(TFD_CLOEXEC,[],
|
||||
AC_CHECK_DECL(CLOCK_MONOTONIC,[],
|
||||
[AC_MSG_ERROR("CLOCK_MONOTONIC is needed to compile libinput")],
|
||||
[[#include <time.h>]])
|
||||
+AC_CHECK_DECL(static_assert, [],
|
||||
+ [AC_DEFINE(static_assert(...), [/* */], [noop static_assert() replacement]),
|
||||
+ AC_MSG_RESULT([no])],
|
||||
+ [[#include <assert.h>]])
|
||||
|
||||
PKG_PROG_PKG_CONFIG()
|
||||
PKG_CHECK_MODULES(MTDEV, [mtdev >= 1.1.0])
|
||||
--
|
||||
2.8.1
|
||||
|
@ -13,6 +13,8 @@ LIBINPUT_LICENSE = MIT
|
||||
LIBINPUT_LICENSE_FILES = COPYING
|
||||
# Tests need fork, so just disable them everywhere.
|
||||
LIBINPUT_CONF_OPTS = --disable-tests --disable-libwacom
|
||||
# Patching configure.ac
|
||||
LIBINPUT_AUTORECONF = YES
|
||||
|
||||
ifeq ($(BR2_PACKAGE_LIBGTK3),y)
|
||||
LIBINPUT_CONF_OPTS += --enable-event-gui
|
||||
|
Loading…
Reference in New Issue
Block a user