package/lz4: fix static build
Fix the following static build failure raised since bump to version
1.9.4 in commit 1f54af8c4f
:
compiling dynamic library 1.9.4
/home/giuliobenetti/autobuild/run/instance-0/output-1/host/opt/ext-toolchain/m68k-buildroot-uclinux-uclibc/bin/ld.real: /home/giuliobenetti/autobuild/run/instance-0/output-1/host/m68k-buildroot-uclinux-uclibc/sysroot/usr/lib/crt1.o: in function `_start':
(.text+0x1c): undefined reference to `main'
Fixes:
- http://autobuild.buildroot.org/results/9187852fb7a869bf5595275d47929632659a4407
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
This commit is contained in:
parent
94c6ba6c70
commit
85c20ffa95
42
package/lz4/0001-build-Support-BUILD_SHARED-no.patch
Normal file
42
package/lz4/0001-build-Support-BUILD_SHARED-no.patch
Normal file
@ -0,0 +1,42 @@
|
||||
From 5ccbd38277989ae6a728171d59ae03bad6f2f4d5 Mon Sep 17 00:00:00 2001
|
||||
From: Fotis Xenakis <foxen@windowslive.com>
|
||||
Date: Tue, 13 Sep 2022 20:09:36 +0300
|
||||
Subject: [PATCH] build: Support BUILD_SHARED=no
|
||||
|
||||
Since e585a438c714652e866a59371b287f52aa4d2dc3, the BUILD_SHARED
|
||||
Makefile variable only takes effect for the install target (i.e. the
|
||||
shared libraries always built). This restores the original behaviour.
|
||||
|
||||
[Retrieved from:
|
||||
https://github.com/lz4/lz4/commit/5ccbd38277989ae6a728171d59ae03bad6f2f4d5]
|
||||
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
||||
---
|
||||
lib/Makefile | 4 ++++
|
||||
1 file changed, 4 insertions(+)
|
||||
|
||||
diff --git a/lib/Makefile b/lib/Makefile
|
||||
index 06503cb2a..ee262c0df 100644
|
||||
--- a/lib/Makefile
|
||||
+++ b/lib/Makefile
|
||||
@@ -112,17 +112,21 @@ liblz4-dll.o: liblz4-dll.rc
|
||||
$(WINDRES) -i liblz4-dll.rc -o liblz4-dll.o
|
||||
|
||||
$(LIBLZ4): $(SRCFILES) liblz4-dll.o
|
||||
+ifeq ($(BUILD_SHARED),yes)
|
||||
@echo compiling dynamic library $(LIBVER)
|
||||
$(CC) $(FLAGS) -DLZ4_DLL_EXPORT=1 -shared $^ -o dll/$@.dll -Wl,--out-implib,dll/$(LIBLZ4_EXP)
|
||||
+endif
|
||||
|
||||
else # not windows
|
||||
|
||||
$(LIBLZ4): $(SRCFILES)
|
||||
+ifeq ($(BUILD_SHARED),yes)
|
||||
@echo compiling dynamic library $(LIBVER)
|
||||
$(CC) $(FLAGS) -shared $^ -fPIC -fvisibility=hidden $(SONAME_FLAGS) -o $@
|
||||
@echo creating versioned links
|
||||
$(LN_SF) $@ liblz4.$(SHARED_EXT_MAJOR)
|
||||
$(LN_SF) $@ liblz4.$(SHARED_EXT)
|
||||
+endif
|
||||
|
||||
endif
|
||||
|
Loading…
Reference in New Issue
Block a user